mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/systemd to 248.2-2
This commit is contained in:
parent
2d4978c42e
commit
0f7a9dcbb9
4 changed files with 6 additions and 113 deletions
|
@ -1,27 +0,0 @@
|
|||
From 7010b37c91b0b02f5aaa01b22e17c9b67ed66f8d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 1 Apr 2021 15:38:59 -0600
|
||||
Subject: [PATCH] link test-random-util with libm
|
||||
|
||||
---
|
||||
src/test/meson.build | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/test/meson.build b/src/test/meson.build
|
||||
index ff40a8d10d..dd4f219ee1 100644
|
||||
--- a/src/test/meson.build
|
||||
+++ b/src/test/meson.build
|
||||
@@ -158,7 +158,9 @@ tests += [
|
||||
|
||||
[['src/test/test-fstab-util.c']],
|
||||
|
||||
- [['src/test/test-random-util.c']],
|
||||
+ [['src/test/test-random-util.c'],
|
||||
+ [],
|
||||
+ [libm]],
|
||||
|
||||
[['src/test/test-format-table.c']],
|
||||
|
||||
--
|
||||
2.30.0
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Mon, 29 Mar 2021 00:12:34 +0000
|
||||
Subject: [PATCH] Disable SYSTEMD_URLIFY by default
|
||||
|
||||
Until https://github.com/gwsw/less/issues/140 is fixed.
|
||||
---
|
||||
src/shared/pretty-print.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/shared/pretty-print.c b/src/shared/pretty-print.c
|
||||
index 0f02f32760..1d0f9901dd 100644
|
||||
--- a/src/shared/pretty-print.c
|
||||
+++ b/src/shared/pretty-print.c
|
||||
@@ -28,7 +28,7 @@ bool urlify_enabled(void) {
|
||||
if (val >= 0)
|
||||
cached_urlify_enabled = val;
|
||||
else
|
||||
- cached_urlify_enabled = colors_enabled();
|
||||
+ cached_urlify_enabled = 0;
|
||||
}
|
||||
|
||||
return cached_urlify_enabled;
|
|
@ -10,10 +10,10 @@
|
|||
|
||||
pkgbase=systemd
|
||||
pkgname=('systemd' 'systemd-libs' 'systemd-resolvconf' 'systemd-sysvcompat')
|
||||
_tag='e13126bd95857eb9344e030edbb4c603aab63884' # git rev-parse v${_tag_name}
|
||||
_tag_name=248
|
||||
_tag='bc3ad898fc7b74e818c80fdb7b14a3b9c6d91475' # git rev-parse v${_tag_name}
|
||||
_tag_name=248.2
|
||||
pkgver="${_tag_name/-/}"
|
||||
pkgrel=5
|
||||
pkgrel=2
|
||||
arch=('x86_64')
|
||||
url='https://www.github.com/systemd/systemd'
|
||||
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
|
||||
|
@ -29,9 +29,7 @@ validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <
|
|||
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
|
||||
"git+https://github.com/systemd/systemd#tag=v${_tag_name%.*}?signed"
|
||||
'0001-Use-Arch-Linux-device-access-groups.patch'
|
||||
'0002-Disable-SYSTEMD_URLIFY-by-default.patch'
|
||||
'0003-PARTIAL-REVERT-commit-tree-wide-replace-strverscmp-and-str_verscmp-with-strverscmp_improved.patch'
|
||||
'0001-link-test-random-util-with-libm.patch'
|
||||
'initcpio-hook-udev'
|
||||
'initcpio-install-systemd'
|
||||
'initcpio-install-udev'
|
||||
|
@ -52,9 +50,7 @@ source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
|
|||
sha512sums=('SKIP'
|
||||
'SKIP'
|
||||
'882e486b6d88c8bafc50088845e41a49686e98981967f72ca1fb4ef07a01767400632f4b648fd31857d2a2a24a8fd65bcc2a8983284dd4fff2380732741d4c41'
|
||||
'313f3d6cc3d88f718509007e029213a82d84b196afdadc6ef560580acf70ab480aaecd7622f51726cc1af7d7841c6ec5390f72890b055a54fc74722341395651'
|
||||
'34541f1967536524329867f9f341f8d9250d9d771c60dc3e6a22ccb82fc01f103cfd3f9903329777591ccbecd2446622a5d6b3804fa0411482b85c70593ee8ad'
|
||||
'e190abdadffecc8539c25558845c1c5a5c04082f9caa2423df104bb01ca698bd41bcb7692e6aac5cdc2cd035fa2452bfccb1b5a35357a20e8cd57393bc25d18a'
|
||||
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
|
||||
'f599e1a35cba2c4e83e37c2299fac23ae128d8f68081283e71e1729384975dee1c4b677787f31a17890aeb98c8d2fc90405a202644290708ef9c027315022b17'
|
||||
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
|
||||
|
@ -98,14 +94,9 @@ prepare() {
|
|||
# Replace cdrom/dialout/tape groups with optical/uucp/storage
|
||||
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
|
||||
|
||||
# https://github.com/gwsw/less/issues/140
|
||||
patch -Np1 -i ../0002-Disable-SYSTEMD_URLIFY-by-default.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/70264
|
||||
# https://github.com/systemd/systemd/issues/19191
|
||||
patch -Np1 -i ../0003-PARTIAL-REVERT-commit-tree-wide-replace-strverscmp-and-str_verscmp-with-strverscmp_improved.patch
|
||||
|
||||
patch -Np1 -i ../0001-link-test-random-util-with-libm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -15,44 +15,6 @@ post_common() {
|
|||
journalctl --update-catalog
|
||||
}
|
||||
|
||||
_216_2_changes() {
|
||||
echo ':: Coredumps are handled by systemd by default. Collection behavior can be'
|
||||
echo ' tuned in /etc/systemd/coredump.conf.'
|
||||
}
|
||||
|
||||
_219_2_changes() {
|
||||
if mkdir -m2755 var/log/journal/remote 2>/dev/null; then
|
||||
chgrp systemd-journal-remote var/log/journal/remote
|
||||
fi
|
||||
}
|
||||
|
||||
_219_4_changes() {
|
||||
if ! systemctl is-enabled -q remote-fs.target; then
|
||||
systemctl enable -q remote-fs.target
|
||||
fi
|
||||
}
|
||||
|
||||
_230_1_changes() {
|
||||
echo ':: systemd-bootchart is no longer included with systemd'
|
||||
}
|
||||
|
||||
_232_8_changes() {
|
||||
# paper over possible effects of CVE-2016-10156
|
||||
local stamps=(/var/lib/systemd/timers/*.timer)
|
||||
|
||||
if [[ -f ${stamps[0]} ]]; then
|
||||
chmod 0644 "${stamps[@]}"
|
||||
fi
|
||||
}
|
||||
|
||||
_233_75_3_changes() {
|
||||
# upstream installs services to /etc, which we remove
|
||||
# to keep bus activation we re-enable systemd-resolved
|
||||
if systemctl is-enabled -q systemd-resolved.service; then
|
||||
systemctl reenable systemd-resolved.service 2>/dev/null
|
||||
fi
|
||||
}
|
||||
|
||||
_242_0_2_changes() {
|
||||
if [[ -L var/lib/systemd/timesync ]]; then
|
||||
rm var/lib/systemd/timesync
|
||||
|
@ -70,7 +32,9 @@ post_install() {
|
|||
add_journal_acls
|
||||
|
||||
# enable some services by default, but don't track them
|
||||
systemctl enable getty@tty1.service remote-fs.target
|
||||
systemctl enable \
|
||||
getty@tty1.service \
|
||||
remote-fs.target
|
||||
|
||||
echo ":: Append 'init=/usr/lib/systemd/systemd' to your kernel command line in your"
|
||||
echo " bootloader to replace sysvinit with systemd, or install systemd-sysvcompat"
|
||||
|
@ -83,19 +47,7 @@ post_install() {
|
|||
post_upgrade() {
|
||||
post_common "$@"
|
||||
|
||||
# don't reexec if the old version is 231-1 or 231-2.
|
||||
# https://github.com/systemd/systemd/commit/bd64d82c1c
|
||||
if [[ $1 != 231-[12] ]] && sd_booted; then
|
||||
systemctl --system daemon-reexec
|
||||
fi
|
||||
|
||||
local v upgrades=(
|
||||
216-2
|
||||
219-2
|
||||
219-4
|
||||
230-1
|
||||
232-8
|
||||
233.75-3
|
||||
242.0-2
|
||||
)
|
||||
|
||||
|
|
Loading…
Reference in a new issue