added extra/suitesparse

This commit is contained in:
Kevin Mihelich 2020-04-26 20:00:27 +00:00
parent f184c5ba1c
commit 10066e871d
3 changed files with 85 additions and 0 deletions

View file

@ -0,0 +1,49 @@
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch from debian to link with libatomic
pkgname=suitesparse
pkgver=5.7.2
pkgrel=1
pkgdesc="A collection of sparse matrix libraries"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('x86_64')
conflicts=('umfpack')
provides=('umfpack')
replaces=('umfpack')
depends=('metis' 'lapack' 'intel-tbb')
makedepends=('gcc-fortran' 'cmake' 'chrpath')
license=('GPL')
options=('staticlibs')
source=($pkgname-$pkgver.tar.gz::"https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver.tar.gz"
suitesparse-no-demo.patch
libatomic.patch)
sha256sums=('fe3bc7c3bd1efdfa5cffffb5cebf021ff024c83b5daf0ab445429d3d741bd3ad'
'f80488bb076753d38ea21d207bd682bdc97e21220c733da025f518a5b7e8e030'
'b91e5ee92c027a5b216debccee2d37712b31a4fb2a544d7721060ccf2f60a7da')
prepare() {
cd SuiteSparse-$pkgver
patch -p1 -i ../suitesparse-no-demo.patch
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && patch -p1 -i ../libatomic.patch || true
}
build() {
cd SuiteSparse-$pkgver
BLAS=-lblas LAPACK=-llapack TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib/libmetis.so make
}
package() {
cd SuiteSparse-$pkgver
install -dm755 "${pkgdir}"/usr/{include,lib}
BLAS=-lblas LAPACK=-llapack TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib/libmetis.so \
make INSTALL_LIB="${pkgdir}"/usr/lib INSTALL_INCLUDE="${pkgdir}"/usr/include install
# fix RPATH
chrpath -d "$pkgdir"/usr/lib/*
}

View file

@ -0,0 +1,25 @@
Description: Add missing link of GraphBLAS to libatomic
Needed for at least armel, mipsel, m68k and powerpc.
Author: Sébastien Villemot <sebastien@debian.org>
Bug: https://github.com/DrTimothyAldenDavis/SuiteSparse/issues/21
Last-Update: 2020-02-28
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/GraphBLAS/CMakeLists.txt
+++ b/GraphBLAS/CMakeLists.txt
@@ -294,6 +294,7 @@ SET_TARGET_PROPERTIES ( graphblas PROPER
C_STANDARD_REQUIRED 11
PUBLIC_HEADER "Include/GraphBLAS.h" )
set_property ( TARGET graphblas PROPERTY C_STANDARD 11 )
+target_link_libraries(graphblas atomic)
#-------------------------------------------------------------------------------
# static graphblas library properties
@@ -308,6 +309,7 @@ if ( BUILD_GRB_STATIC_LIBRARY )
C_STANDARD_REQUIRED 11
PUBLIC_HEADER "Include/GraphBLAS.h" )
set_property ( TARGET graphblas_static PROPERTY C_STANDARD 11 )
+ target_link_libraries(graphblas_static atomic)
endif ( )
#-------------------------------------------------------------------------------

View file

@ -0,0 +1,11 @@
--- SuiteSparse-5.6.0/Makefile.orig 2019-11-05 22:37:26.086135974 +0000
+++ SuiteSparse-5.6.0/Makefile 2019-11-05 22:37:37.549632429 +0000
@@ -12,7 +12,7 @@
# Compile the default rules for each package
go: metis
( cd SuiteSparse_config && $(MAKE) )
- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
( cd AMD && $(MAKE) )
( cd BTF && $(MAKE) )
( cd CAMD && $(MAKE) )