core/linux-armv5-rc to 4.1.rc3-1

This commit is contained in:
Kevin Mihelich 2015-05-12 02:01:54 +00:00
parent 0195eaf667
commit 10422da079
7 changed files with 25 additions and 23 deletions

View file

@ -1,4 +1,4 @@
From a855ffd581def7001f44ae7e7441e51aaa6445e7 Mon Sep 17 00:00:00 2001
From e74efbd1dd2b84c8761af9d2be2dc1294fbb8b6d Mon Sep 17 00:00:00 2001
From: Michal Ulianko <info@itserve.cz>
Date: Mon, 29 Jul 2013 20:14:38 +0200
Subject: [PATCH 1/5] Added ASoC driver for i.MX233's builtin ADC/DAC codec.

View file

@ -1,4 +1,4 @@
From 4d384150261938722424fe58b5b2e321f64e58eb Mon Sep 17 00:00:00 2001
From 67cd1951bac133002ce52cd7132625ff6f1943a8 Mon Sep 17 00:00:00 2001
From: Robert Nelson <robertcnelson@gmail.com>
Date: Mon, 12 Aug 2013 11:27:22 -0500
Subject: [PATCH 2/5] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
@ -9,10 +9,10 @@ Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
1 file changed, 25 insertions(+)
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
index 7e6eef2..cf5058b 100644
index 8204539..db0fd3f 100644
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
@@ -88,6 +88,25 @@
@@ -89,6 +89,25 @@
usbphy0: usbphy@8007c000 {
status = "okay";
};
@ -38,8 +38,8 @@ index 7e6eef2..cf5058b 100644
};
};
@@ -125,4 +144,10 @@
gpios = <&gpio2 1 1>;
@@ -127,4 +146,10 @@
gpios = <&gpio2 1 GPIO_ACTIVE_HIGH>;
};
};
+

View file

@ -1,4 +1,4 @@
From b29557c7c38f35d7f0cd24b8f51a977d60466996 Mon Sep 17 00:00:00 2001
From aad1b273d25d2a45aa7527913955c215eac4b86f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 18 Jun 2014 21:55:51 -0600
Subject: [PATCH 3/5] imx23 I2C fixes
@ -9,10 +9,10 @@ Subject: [PATCH 3/5] imx23 I2C fixes
2 files changed, 75 insertions(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
index cf5058b..2ecee35 100644
index db0fd3f..aca7625 100644
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
@@ -73,6 +73,25 @@
@@ -74,6 +74,25 @@
status = "okay";
};
@ -38,7 +38,7 @@ index cf5058b..2ecee35 100644
duart: serial@80070000 {
pinctrl-names = "default";
pinctrl-0 = <&duart_pins_a>;
@@ -132,6 +151,22 @@
@@ -134,6 +153,22 @@
startup-delay-us = <300>; /* LAN9215 requires a POR of 200us minimum */
gpio = <&gpio0 17 0>;
};

View file

@ -1,4 +1,4 @@
From e62c10d588514aace9254df1231e12aaec9a161f Mon Sep 17 00:00:00 2001
From 1d9e3650cc61660e0bed3c4696be90cff10cd21b Mon Sep 17 00:00:00 2001
From: Michal Ulianko <info@itserve.cz>
Date: Tue, 30 Jul 2013 14:28:17 +0200
Subject: [PATCH 4/5] Added DTS with mxs-builtin-* entries for testing the

View file

@ -1,4 +1,4 @@
From fbc9910aa9553955cc3066707cd55f0f496a646b Mon Sep 17 00:00:00 2001
From c64d2aae17c941a1fae8a6a59655ec8b5b3e9bf8 Mon Sep 17 00:00:00 2001
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
Date: Mon, 12 Aug 2013 10:36:25 -0500
Subject: [PATCH 5/5] at91: ariag25 updates

View file

@ -4,7 +4,7 @@
buildarch=2
_rcver=4.1
_rcrel=2
_rcrel=3
pkgbase=linux-armv5-rc
_srcname=linux-4.$((${_rcver##*.}-1))
@ -26,13 +26,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0005-at91-ariag25-updates.patch'
'config')
md5sums=('a86916bd12798220da9eb4a1eec3616d'
'1af1ca2f20db7ebc2a94a786fb6f8e86'
'4425a61f4850823509c4c308bf98a85e'
'5d8b0f650d70f7603ce385a11c73a7f9'
'0a604a9981434bddb98045169645c516'
'bd8b8485d4084247565f3a877eeb73e0'
'6c3aee91d74e45dd8ff0787a99949890'
'bb9f3cb5b02ae37b589d9109590095b4')
'a858fe84bfa6428ff24852221613131f'
'ed7991bb04554fd9ed4292ffd07bc916'
'9225efbd445352fcfeaa83317bed0825'
'560af5c50a5374201e3b89113cd69977'
'8b9d27de7a5a5b73dba4dbd249b378eb'
'a6461a6896d6d9bc2144ee199def455d'
'f3424a7908925779d781f56c9940ed41')
prepare() {
cd "${srcdir}/${_srcname}"

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 4.1.0-rc2-1 Kernel Configuration
# Linux/arm 4.1.0-rc3-1 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -1383,6 +1383,7 @@ CONFIG_OF=y
# CONFIG_OF_UNITTEST is not set
CONFIG_OF_FLATTREE=y
CONFIG_OF_EARLY_FLATTREE=y
CONFIG_OF_DYNAMIC=y
CONFIG_OF_ADDRESS=y
CONFIG_OF_ADDRESS_PCI=y
CONFIG_OF_IRQ=y
@ -1392,7 +1393,8 @@ CONFIG_OF_PCI=y
CONFIG_OF_PCI_IRQ=y
CONFIG_OF_MTD=y
CONFIG_OF_RESERVED_MEM=y
# CONFIG_OF_OVERLAY is not set
CONFIG_OF_RESOLVE=y
CONFIG_OF_OVERLAY=y
CONFIG_ARCH_MIGHT_HAVE_PC_PARPORT=y
# CONFIG_PARPORT is not set
CONFIG_BLK_DEV=y
@ -4281,6 +4283,7 @@ CONFIG_RTC_INTF_DEV=y
# I2C RTC drivers
#
# CONFIG_RTC_DRV_ABB5ZES3 is not set
# CONFIG_RTC_DRV_ABX80X is not set
CONFIG_RTC_DRV_DS1307=m
# CONFIG_RTC_DRV_DS1374 is not set
# CONFIG_RTC_DRV_DS1672 is not set
@ -5240,7 +5243,6 @@ CONFIG_PROVE_RCU=y
# CONFIG_SPARSE_RCU_POINTER is not set
# CONFIG_TORTURE_TEST is not set
# CONFIG_RCU_TORTURE_TEST is not set
CONFIG_RCU_TORTURE_TEST_SLOW_INIT_DELAY=3
CONFIG_RCU_CPU_STALL_TIMEOUT=21
# CONFIG_RCU_CPU_STALL_INFO is not set
# CONFIG_RCU_TRACE is not set