mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/p7zip to 16.02-3
This commit is contained in:
parent
ef786b4273
commit
10906877a2
2 changed files with 20 additions and 3 deletions
12
extra/p7zip/CVE-2016-9296.patch
Normal file
12
extra/p7zip/CVE-2016-9296.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- ./CPP/7zip/Archive/7z/7zIn.cpp.orig 2016-11-21 01:42:29.460901230 +0000
|
||||
+++ ./CPP/7zip/Archive/7z/7zIn.cpp 2016-11-21 01:42:57.481197725 +0000
|
||||
@@ -1097,7 +1097,8 @@ HRESULT CInArchive::ReadAndDecodePackedS
|
||||
if (CrcCalc(data, unpackSize) != folders.FolderCRCs.Vals[i])
|
||||
ThrowIncorrect();
|
||||
}
|
||||
- HeadersSize += folders.PackPositions[folders.NumPackStreams];
|
||||
+ if (folders.PackPositions)
|
||||
+ HeadersSize += folders.PackPositions[folders.NumPackStreams];
|
||||
return S_OK;
|
||||
}
|
||||
|
|
@ -11,7 +11,7 @@
|
|||
|
||||
pkgname=p7zip
|
||||
pkgver=16.02
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="Command-line file archiver with high compression ratio"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://p7zip.sourceforge.net/"
|
||||
|
@ -20,12 +20,17 @@ depends=('gcc-libs' 'sh')
|
|||
makedepends_i686=('nasm')
|
||||
makedepends_x86_64=('yasm')
|
||||
install=$pkgname.install
|
||||
source=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2)
|
||||
sha256sums=('5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f')
|
||||
source=(https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/${pkgname}_${pkgver}_src_all.tar.bz2
|
||||
CVE-2016-9296.patch)
|
||||
sha256sums=('5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f'
|
||||
'f9bcbf21d4aa8938861a6cba992df13dec19538286e9ed747ccec6d9a4e8f983')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/${pkgname}_$pkgver"
|
||||
|
||||
# https://sourceforge.net/p/p7zip/bugs/185/
|
||||
patch -Np1 -i ../CVE-2016-9296.patch
|
||||
|
||||
cp makefile.linux_any_cpu_gcc_4.X makefile.machine
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue