extra/pyqt to 4.9.1-1

This commit is contained in:
Kevin Mihelich 2012-02-15 10:32:22 -05:00
parent 2dbd673ab4
commit 1096478626
2 changed files with 16 additions and 20 deletions

View file

@ -11,8 +11,8 @@ plugrel=1
pkgbase=pyqt
pkgname=('pyqt' 'python2-pyqt')
pkgver=4.9
pkgrel=2
pkgver=4.9.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
@ -21,22 +21,22 @@ makedepends=('qt' 'python-sip' 'dbus-python' 'python2-sip' 'phonon'
source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz"
"fix-qthelp-build.patch"
"PyQt4-4.7.3-qreal_float_support.patch")
md5sums=('61619500d09d87b6c2a25bd3ea994504'
'356a453331a33c507b1baba4a9771764'
md5sums=('7f495dc49f71e3bfb64bf942e0d8bb3c'
'6acfe0a5a00779f946c29d5fac647ce1'
'a20d7022e91071f838bd4908851a0f7b')
build() {
# Build QtHelp (FS#27665)
cd "${srcdir}"/PyQt-x11-gpl-${pkgver}
patch -p1 -i "${srcdir}"/fix-qthelp-build.patch
# ALARM: Fix for QReal
patch -p1 -i "${srcdir}"/PyQt4-4.7.3-qreal_float_support.patch
cd "${srcdir}"
patch -p0 -i "${srcdir}"/fix-qthelp-build.patch
cp -r PyQt-x11-gpl-${pkgver} Py2Qt-x11-gpl-${pkgver}
cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
# ALARM: Fix for QReal
patch -Np1 -i ${srcdir}/PyQt4-4.7.3-qreal_float_support.patch
python configure.py \
--confirm-license \
--qsci-api
@ -48,10 +48,6 @@ build() {
### Python2 version ###
cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
# ALARM: Fix for QReal
patch -Np1 -i ${srcdir}/PyQt4-4.7.3-qreal_float_support.patch
python2 configure.py \
--confirm-license \
-v /usr/share/sip \

View file

@ -1,11 +1,11 @@
--- PyQt-x11-gpl-4.9/configure.py~ 2011-12-23 14:53:07.981490550 +0100
+++ PyQt-x11-gpl-4.9/configure.py 2011-12-23 14:52:38.384984221 +0100
@@ -1264,7 +1264,7 @@
--- PyQt-x11-gpl-4.9.1/configure.py~ 2012-02-13 20:16:11.418786488 +0000
+++ PyQt-x11-gpl-4.9.1/configure.py 2012-02-13 20:16:50.561809527 +0000
@@ -1261,7 +1261,7 @@
opengl = (mname == "QtOpenGL")
qt = [mname]
- if mname in ("QtOpenGL", "QtWebKit"):
+ if mname in ("QtHelp", "QtOpenGL", "QtWebKit"):
qt.append("QtCore")
makefile = sipconfig.ProgramMakefile(sipcfg, console=1, qt=qt, warnings=0,