extra/firefox: remove unneeded patch

This commit is contained in:
Kevin Mihelich 2015-01-14 01:49:26 +00:00
parent f257097189
commit 10bc53bf02
2 changed files with 2 additions and 36 deletions

View file

@ -4,7 +4,6 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org> # ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building webrtc # - patch to fix building webrtc
# - patch to fix downloads (https://bugzilla.mozilla.org/show_bug.cgi?id=1050258)
buildarch=20 buildarch=20
@ -29,8 +28,7 @@ options=('!emptydirs' '!makeflags')
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2{,.asc} source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2{,.asc}
mozconfig firefox.desktop firefox-install-dir.patch vendor.js rhbz-966424.patch mozconfig firefox.desktop firefox-install-dir.patch vendor.js rhbz-966424.patch
firefox-fixed-loading-icon.png firefox-fixed-loading-icon.png
arm-webrtc-fix.patch arm-webrtc-fix.patch)
arm-download-fix.patch)
sha256sums=('bedeb5bbd8b49e5b286497ef7732542c6e7441088fd8cd577d7ca8af4c871e81' sha256sums=('bedeb5bbd8b49e5b286497ef7732542c6e7441088fd8cd577d7ca8af4c871e81'
'SKIP' 'SKIP'
'ffcb2a0ba2ed08f74931a11043717391ef380234cadccc6f0c13f1186ad80e8b' 'ffcb2a0ba2ed08f74931a11043717391ef380234cadccc6f0c13f1186ad80e8b'
@ -39,8 +37,7 @@ sha256sums=('bedeb5bbd8b49e5b286497ef7732542c6e7441088fd8cd577d7ca8af4c871e81'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4' '4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
'4f0046b39a8d98f6e4fc3360ec490cb2416e38c7b3e92699f7e511c206c2c961' '4f0046b39a8d98f6e4fc3360ec490cb2416e38c7b3e92699f7e511c206c2c961'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213' '68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
'6f81cd3c1d5d96aaeae9882cc24da4fd42ff7ebf25113d9516d5e7c94d375090' '6f81cd3c1d5d96aaeae9882cc24da4fd42ff7ebf25113d9516d5e7c94d375090')
'a1fb0067e665af22d5e7bff5623fd85b89491c8f222a6f8eaca07c81b624454e')
validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A') validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys) # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -82,9 +79,6 @@ prepare() {
# Fix webrtc build on ARM # Fix webrtc build on ARM
patch -Np0 -i ../arm-webrtc-fix.patch patch -Np0 -i ../arm-webrtc-fix.patch
# Fix downloading on ARM
patch -Np1 -i ../arm-download-fix.patch
} }
build() { build() {

View file

@ -1,28 +0,0 @@
# HG changeset patch
# User Douglas Crosher <dtc-moz@scieneer.com>
# Date 1415349848 -39600
# Fri Nov 07 19:44:08 2014 +1100
# Node ID b98d6205da98b5bec30b0677c30a6d09f351f4b8
# Parent 17e19083908620e8a83876e49bac6f6ba2fcc272
Bug 1050258 - ARM hard-float XPCOM: correct argument passing.
diff --git a/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp b/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
--- a/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
+++ b/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp
@@ -219,16 +219,17 @@ static inline void copy_dword(uint32_t*
{
if (ireg_args + 1 < end) {
if ((uint32_t)ireg_args & 4) {
ireg_args++;
}
*(uint64_t *)ireg_args = data;
ireg_args += 2;
} else {
+ ireg_args = end;
if ((uint32_t)stack_args & 4) {
stack_args++;
}
*(uint64_t *)stack_args = data;
stack_args += 2;
}
}