mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added community/opencollada
This commit is contained in:
parent
5f9fe0a6a0
commit
1144fff3cf
3 changed files with 63 additions and 0 deletions
51
community/opencollada/PKGBUILD
Normal file
51
community/opencollada/PKGBUILD
Normal file
|
@ -0,0 +1,51 @@
|
|||
# $Id$
|
||||
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix signed char usage
|
||||
|
||||
pkgname=opencollada
|
||||
pkgver=1.6.59
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc="Stream based reader and writer library for COLLADA files"
|
||||
arch=(i686 x86_64)
|
||||
url="https://github.com/KhronosGroup/OpenCOLLADA"
|
||||
license=('GPL')
|
||||
depends=('libxml2' 'pcre')
|
||||
makedepends=('git' 'cmake')
|
||||
source=('opencollada.conf'
|
||||
"git://github.com/KhronosGroup/OpenCOLLADA.git#tag=v${pkgver}"
|
||||
'openCOLLADA-narrowing_gcc6.patch')
|
||||
md5sums=('5f7e9d79ab86756648b648ee5ed6ce1d'
|
||||
'SKIP'
|
||||
'1b1ee8b442ffdf2ff30f0877f43e07bc')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir"/OpenCOLLADA
|
||||
|
||||
patch -p1 -i ../openCOLLADA-narrowing_gcc6.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"/OpenCOLLADA
|
||||
|
||||
[[ -d build ]] && rm -r build
|
||||
mkdir build && cd build
|
||||
|
||||
cmake .. \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DUSE_SHARED=ON \
|
||||
-DUSE_STATIC=OFF
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir"/OpenCOLLADA/build
|
||||
|
||||
make DESTDIR=$pkgdir install
|
||||
|
||||
install -Dm644 $srcdir/opencollada.conf $pkgdir/etc/ld.so.conf.d/opencollada.conf
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
11
community/opencollada/openCOLLADA-narrowing_gcc6.patch
Normal file
11
community/opencollada/openCOLLADA-narrowing_gcc6.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/COLLADABaseUtils/src/COLLADABUURI.cpp
|
||||
+++ b/COLLADABaseUtils/src/COLLADABUURI.cpp
|
||||
@@ -32,7 +32,7 @@ namespace COLLADABU
|
||||
|
||||
|
||||
|
||||
- const char HEX2DEC[256] =
|
||||
+ const signed char HEX2DEC[256] =
|
||||
{
|
||||
/* 0 1 2 3 4 5 6 7 8 9 A B C D E F */
|
||||
/* 0 */ -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1,
|
1
community/opencollada/opencollada.conf
Normal file
1
community/opencollada/opencollada.conf
Normal file
|
@ -0,0 +1 @@
|
|||
/usr/lib/opencollada
|
Loading…
Reference in a new issue