extra/speexdsp to 1.2.0-1

This commit is contained in:
Kevin Mihelich 2019-06-09 21:19:09 +00:00
parent 9556cc3da5
commit 115655b3ba
2 changed files with 4 additions and 44 deletions

View file

@ -4,22 +4,18 @@
# - configure with --disable-neon
pkgname=speexdsp
pkgver=1.2rc3
pkgrel=4
pkgver=1.2.0
pkgrel=1
pkgdesc="DSP library derived from Speex"
arch=(x86_64)
url="https://www.speex.org/"
license=(BSD)
depends=(glibc)
source=(https://downloads.us.xiph.org/releases/speex/$pkgname-$pkgver.tar.gz
speexdsp-fixbuilds-774c87d.patch)
sha512sums=('29dfa8345df025eeb076561648a9b5c0485692be699b6da3c2a3734b4329187a1c2eb181252f4df12b21f1309ecdf59797437dfb123d160fd723491ab216e858'
'0f0c8054591915a4ea06b28b13d50da41be10d594f39a0496e2e80e4514ed53db7cd0e1fdb205ce5e87f602b9c1e15409c33cf946ab25cdef8a3b147dbfcc0f3')
source=(https://downloads.us.xiph.org/releases/speex/$pkgname-$pkgver.tar.gz)
sha512sums=('e357cd5377415ea66c862302c7cf8bf6a10063cacd903f0846478975b87974cf5bdf00e2c6759d8f4f453c4c869cf284e9dc948a84a83d7b2ab96bd5405c05ec')
prepare() {
cd $pkgname-$pkgver
patch -Np1 -i ../speexdsp-fixbuilds-774c87d.patch
autoreconf -vi
}
build() {

View file

@ -1,36 +0,0 @@
diff --git a/configure.ac b/configure.ac
index 2cd2d1e..1de0c23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -334,6 +334,12 @@ AC_SUBST([USIZE16])
AC_SUBST([SIZE32])
AC_SUBST([USIZE32])
+AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
+ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
+ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
+
+AC_SUBST([INCLUDE_STDINT])
+
AC_CONFIG_FILES([
Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
include/Makefile include/speex/Makefile speexdsp.pc
diff --git a/include/speex/speexdsp_config_types.h.in b/include/speex/speexdsp_config_types.h.in
index 02b82fd..5ea7b55 100644
--- a/include/speex/speexdsp_config_types.h.in
+++ b/include/speex/speexdsp_config_types.h.in
@@ -1,13 +1,7 @@
#ifndef __SPEEX_TYPES_H__
#define __SPEEX_TYPES_H__
-#if defined HAVE_STDINT_H
-# include <stdint.h>
-#elif defined HAVE_INTTYPES_H
-# include <inttypes.h>
-#elif defined HAVE_SYS_TYPES_H
-# include <sys/types.h>
-#endif
+@INCLUDE_STDINT@
typedef @SIZE16@ spx_int16_t;
typedef @USIZE16@ spx_uint16_t;