mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/rust to 1.67.1-1
This commit is contained in:
parent
2e978e8c46
commit
115cc003c2
2 changed files with 4 additions and 37 deletions
|
@ -1,26 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: bjorn3 <17426603+bjorn3@users.noreply.github.com>
|
||||
Date: Fri, 27 Jan 2023 11:48:36 +0000
|
||||
Subject: [PATCH] Revert back to LlvmArchiveBuilder on all platforms
|
||||
|
||||
ArArchiveBuilder doesn't support reading thin archives, causing a
|
||||
regression.
|
||||
---
|
||||
compiler/rustc_codegen_llvm/src/back/archive.rs | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/compiler/rustc_codegen_llvm/src/back/archive.rs b/compiler/rustc_codegen_llvm/src/back/archive.rs
|
||||
index 0aee1a1439b9..2cf2f585f214 100644
|
||||
--- a/compiler/rustc_codegen_llvm/src/back/archive.rs
|
||||
+++ b/compiler/rustc_codegen_llvm/src/back/archive.rs
|
||||
@@ -108,7 +108,9 @@ fn build(mut self: Box<Self>, output: &Path) -> bool {
|
||||
|
||||
impl ArchiveBuilderBuilder for LlvmArchiveBuilderBuilder {
|
||||
fn new_archive_builder<'a>(&self, sess: &'a Session) -> Box<dyn ArchiveBuilder<'a> + 'a> {
|
||||
- if sess.target.arch == "wasm32" || sess.target.arch == "wasm64" {
|
||||
+ // FIXME use ArArchiveBuilder on most targets again once reading thin archives is
|
||||
+ // implemented
|
||||
+ if true || sess.target.arch == "wasm32" || sess.target.arch == "wasm64" {
|
||||
Box::new(LlvmArchiveBuilder { sess, additions: Vec::new() })
|
||||
} else {
|
||||
Box::new(ArArchiveBuilder::new(sess, get_llvm_object_symbols))
|
|
@ -17,8 +17,8 @@ highmem=1
|
|||
pkgbase=rust
|
||||
pkgname=(rust rust-src)
|
||||
epoch=1
|
||||
pkgver=1.67.0
|
||||
pkgrel=2
|
||||
pkgver=1.67.1
|
||||
pkgrel=1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
arch=(x86_64)
|
||||
|
@ -57,15 +57,13 @@ source=(
|
|||
0001-bootstrap-Change-libexec-dir.patch
|
||||
0002-compiler-Change-LLVM-targets.patch
|
||||
0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
0004-Revert-back-to-LlvmArchiveBuilder-on-all-platforms.patch
|
||||
)
|
||||
sha256sums=('d029f14fce45a2ec7a9a605d2a0a40aae4739cb2fdae29ee9f7a6e9025a7fde4'
|
||||
sha256sums=('46483d3e5de85a3bd46f8e7a3ae1837496391067dbe713a25d3cf051b3d9ff6e'
|
||||
'SKIP'
|
||||
'b2ef8c3bca5d72ed58ff8930e69947602f875a639c2b01de5943b1ecb1b5c3c3'
|
||||
'6a4e09671cd96a854cf0fc9a1f43651ac5a0fdc8dca571730131ae272b630cfe'
|
||||
'e32fd355330e6c1ca4f0c630a3e254d261c48516128243a5d5d49f612cd217ed'
|
||||
'f83bf98daee94d3e592fd2d96eecc25dc92b6b20575a3e3df7841a90a5b9f965'
|
||||
'307c1ea2a7394ee166bc48fe3ba3d9e940dbd38d33d56824300407518df011cf')
|
||||
'f83bf98daee94d3e592fd2d96eecc25dc92b6b20575a3e3df7841a90a5b9f965')
|
||||
validpgpkeys=(108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
474E22316ABF4785A88C6E8EA2C794A986419D8A) # Tom Stellard <tstellar@redhat.com>
|
||||
|
||||
|
@ -83,11 +81,6 @@ prepare() {
|
|||
# Use our wasm-ld
|
||||
patch -Np1 -i ../0003-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
|
||||
# Fix mesa build
|
||||
# https://github.com/rust-lang/rust/issues/107334
|
||||
# https://github.com/rust-lang/rust/pull/107360
|
||||
patch -Np1 -i ../0004-Revert-back-to-LlvmArchiveBuilder-on-all-platforms.patch
|
||||
|
||||
cat >config.toml <<END
|
||||
changelog-seen = 2
|
||||
profile = "user"
|
||||
|
|
Loading…
Reference in a new issue