diff --git a/community/efl/PKGBUILD b/community/efl/PKGBUILD
index b8ac6aaef..609c74ccc 100644
--- a/community/efl/PKGBUILD
+++ b/community/efl/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Ronald van Haren <ronald@archlinux.org>
+# Contributor: Ronald van Haren <ronald@archlinux.org>
 # Contributor: Enlightenment Developers <enlightenment-devel@enlightenment.org>
 
 # ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
@@ -7,26 +7,31 @@
 pkgbase=efl
 pkgname=('efl' 'efl-docs')
 pkgver=1.26.3
-pkgrel=5
+pkgrel=6
 pkgdesc="Enlightenment Foundation Libraries"
 arch=('x86_64')
 url="https://www.enlightenment.org"
 license=('BSD' 'LGPL2.1' 'GPL2' 'MIT' 'custom')
-depends=('curl' 'fontconfig' 'fribidi' 'harfbuzz'
-         'gst-plugins-base-libs' 'lua52' 'libexif' 'libgl' 'libinput'
-         'libpulse' 'libsndfile' 'libspectre' 'libraw' 'librsvg' 'libwebp'
-         'libxcomposite' 'libxcursor' 'libxinerama' 'libxkbcommon' 'libxrandr'
-         'libxss' 'libunwind' 'mesa' 'poppler' 'openjpeg2' 'libjpeg-turbo'
-         'libutil-linux' 'dbus'
-         'shared-mime-info' 'mailcap' 'ttf-font' 'scim'
-         'wayland' 'wayland-protocols' 'libxkbcommon-x11' 'pulseaudio')
+depends=('curl' 'dbus' 'fontconfig' 'freetype2' 'fribidi' 'giflib' 'glib2' 'gstreamer'
+         'gst-plugins-base-libs' 'harfbuzz' 'hicolor-icon-theme' 'libglvnd' 'libinput'
+         'libjpeg-turbo' 'libpng' 'libpulse' 'libsndfile' 'libtiff' 'libunwind' 'libwebp' 'libx11'
+         'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi'
+         'libxinerama' 'libxkbcommon' 'libxkbcommon-x11' 'libxrandr' 'libxrender' 'libxss'
+         'libxtst' 'lua52' 'mailcap' 'mesa' 'openjpeg2' 'openssl' 'shared-mime-info' 'systemd-libs'
+         'ttf-font' 'util-linux-libs' 'wayland' 'zlib')
 optdepends=('gst-plugins-base: Video and thumbnail codecs'
             'gst-plugins-good: Video and thumbnail codecs'
             'gst-plugins-bad: Video and thumbnail codecs'
             'gst-plugins-ugly: Video and thumbnail codecs'
             'gst-libav: Video and thumbnails with ffmpeg/libav'
-            'libreoffice: Office document thumbnails')
-makedepends=('doxygen' 'python' 'texlive-core' 'ghostscript' 'imagemagick' 'meson' 'ninja')
+            'libraw: RAW image loader'
+            'libreoffice: Office document loader'
+            'librsvg: SVG loader'
+            'libspectre: PostScript loader'
+            'poppler: PDF loader'
+            'scim: IM module for SCIM')
+makedepends=('doxygen' 'libraw' 'librsvg' 'libspectre' 'meson' 'ninja' 'poppler' 'python' 'scim'
+             'texlive-core' 'wayland-protocols')
 options=('!emptydirs')
 source=(https://download.enlightenment.org/rel/libs/${pkgname}/$pkgname-$pkgver.tar.xz)
 sha256sums=('d9f83aa0fd9334f44deeb4e4952dc0e5144683afac786feebce6030951617d15')
diff --git a/community/efl/eina_doxygen.patch b/community/efl/eina_doxygen.patch
deleted file mode 100644
index fa6e49c05..000000000
--- a/community/efl/eina_doxygen.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/lib/eina/eina_hamster.h	2013-02-16 12:52:32.000000000 +0100
-+++ src/lib/eina/eina_hamster.h.new	2014-09-16 22:19:04.820163522 +0200
-@@ -24,7 +24,6 @@
-  *
-  * @brief These functions provide hamster calls.
-  *
-- * @{
-  */
- 
- /**