mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
grep patch so our slow plugs will pass tests
This commit is contained in:
parent
c4834bc409
commit
11913b0aea
3 changed files with 66 additions and 0 deletions
33
core/grep/PKGBUILD
Normal file
33
core/grep/PKGBUILD
Normal file
|
@ -0,0 +1,33 @@
|
|||
# $Id: PKGBUILD 91020 2010-09-21 03:26:36Z allan $
|
||||
# Maintainer: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: judd <jvinet@zeroflux.org>
|
||||
# PlugApps patch: Kevin Mihelich <kevin@plugaps.com>
|
||||
|
||||
pkgname=grep
|
||||
pkgver=2.7
|
||||
pkgrel=1
|
||||
pkgdesc="A string search utility"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL3')
|
||||
url="http://www.gnu.org/software/grep/grep.html"
|
||||
groups=('base')
|
||||
depends=('glibc' 'pcre' 'sh')
|
||||
makedepends=('texinfo')
|
||||
install=${pkgname}.install
|
||||
source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
|
||||
grep.patch)
|
||||
md5sums=('6dd9931a52501519d7779a27cf953326'
|
||||
'79d26bec3335edc85add876f297ef961')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
patch -Np1 -i ${srcdir}/grep.patch
|
||||
./configure --prefix=/usr --bindir=/bin --without-included-regex
|
||||
make
|
||||
make check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
make DESTDIR=${pkgdir} install
|
||||
}
|
21
core/grep/grep.install
Normal file
21
core/grep/grep.install
Normal file
|
@ -0,0 +1,21 @@
|
|||
infodir=/usr/share/info
|
||||
filelist=(grep.info)
|
||||
|
||||
post_install() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
install-info $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
for file in ${filelist[@]}; do
|
||||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
12
core/grep/grep.patch
Normal file
12
core/grep/grep.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -urN a/tests/backref-multibyte-slow b/tests/backref-multibyte-slow
|
||||
--- a/tests/backref-multibyte-slow 2010-08-13 23:36:34.000000000 +0000
|
||||
+++ b/tests/backref-multibyte-slow 2011-01-05 04:32:14.669176000 +0000
|
||||
@@ -12,7 +12,7 @@
|
||||
|
||||
for LOC in en_US.UTF-8; do
|
||||
out=out-$LOC
|
||||
- LC_ALL=$LOC timeout 5s grep -E '^([a-z]).\1$' in > $out 2>&1
|
||||
+ LC_ALL=$LOC timeout 120s grep -E '^([a-z]).\1$' in > $out 2>&1
|
||||
test $? = 0 || fail=1
|
||||
compare $out in || fail=1
|
||||
done
|
Loading…
Reference in a new issue