community/botan to 2.17.0-1

This commit is contained in:
Kevin Mihelich 2020-11-05 17:25:18 +00:00
parent 5bbe0e8b42
commit 11cf00826e
2 changed files with 6 additions and 30 deletions

View file

@ -10,8 +10,8 @@
# - disable neon on !AArch64
pkgname=botan
pkgver=2.16.0
pkgrel=2
pkgver=2.17.0
pkgrel=1
pkgdesc='Crypto library written in C++'
arch=(x86_64)
url='https://botan.randombit.net/'
@ -19,17 +19,10 @@ license=(BSD)
depends=(xz sqlite)
makedepends=(python boost openssl)
optdepends=('python: for using botan2.py' 'boost-libs: for the botan executable')
validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC')
source=("https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz"{,.asc}
botan-ldflags.patch)
sha256sums=('92ed6ebc918d86bd1b04221ca518af4cf29cc326c4760740bd2d22e61cea2628'
'SKIP'
'a6e85d537f9a1299be8a6763df09c1b90680f5efd92c42a53ff0f985c82b3000')
prepare() {
cd ${pkgname^}-$pkgver
patch -p1 -i ../botan-ldflags.patch # Fix --as-needed
}
source=("https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz"{,.asc})
sha256sums=('b97044b312aa718349af7851331b064bc7bd5352400d5f80793bace427d01343'
'SKIP')
validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC') # Botan Distribution Key
build() {
cd "${pkgname^}-$pkgver"

View file

@ -1,17 +0,0 @@
diff --git a/src/build-data/makefile.in b/src/build-data/makefile.in
index 0d678345f..07a8d9cd5 100644
--- a/src/build-data/makefile.in
+++ b/src/build-data/makefile.in
@@ -72,10 +72,10 @@ TESTOBJS = %{join test_objs}
# Executable targets
$(CLI): $(LIBRARIES) $(CLIOBJS)
- $(EXE_LINK_CMD) $(ABI_FLAGS) $(CLIOBJS) $(EXE_LINKS_TO) $(LDFLAGS) %{output_to_exe}$@
+ $(EXE_LINK_CMD) $(ABI_FLAGS) $(CLIOBJS) $(LDFLAGS) $(EXE_LINKS_TO) %{output_to_exe}$@
$(TEST): $(LIBRARIES) $(TESTOBJS)
- $(EXE_LINK_CMD) $(ABI_FLAGS) $(TESTOBJS) $(EXE_LINKS_TO) $(LDFLAGS) %{output_to_exe}$@
+ $(EXE_LINK_CMD) $(ABI_FLAGS) $(TESTOBJS) $(LDFLAGS) $(EXE_LINKS_TO) %{output_to_exe}$@
%{if build_fuzzers}