extra/imagemagick to 6.9.0.3-1

This commit is contained in:
David Beauchamp 2015-01-06 19:42:30 -05:00
parent fa470edce8
commit 11ec804817
3 changed files with 4 additions and 37 deletions

View file

@ -8,7 +8,7 @@
pkgbase=imagemagick pkgbase=imagemagick
pkgname=('imagemagick' 'imagemagick-doc') pkgname=('imagemagick' 'imagemagick-doc')
pkgver=6.9.0.2 pkgver=6.9.0.3
pkgrel=1 pkgrel=1
arch=('i686' 'x86_64') arch=('i686' 'x86_64')
url="http://www.imagemagick.org/" url="http://www.imagemagick.org/"
@ -18,12 +18,10 @@ makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript'
'libwebp' 'subversion') 'libwebp' 'subversion')
source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc} source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
#source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc} #source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
perlmagick.rpath.patch imagemagick-palm.diff imagemagick-rle.diff) perlmagick.rpath.patch)
sha1sums=('da0ad71290bf92a848ceddbbcf67d765542febd5' sha1sums=('c7bb4eebef59544d0411ed56bda64f34fafb11f3'
'SKIP' 'SKIP'
'e143cf9d530fabf3b58023899b5cc544ba93daec' 'e143cf9d530fabf3b58023899b5cc544ba93daec')
'34f4e402963e83f5c6e6da79d75d1f43afdbca86'
'75534ddcb9f787ee270bdeb0899983fc95eb33a5')
validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A') validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A')
prepare() { prepare() {
@ -31,8 +29,6 @@ prepare() {
sed '/AC_PATH_XTRA/d' -i configure.ac sed '/AC_PATH_XTRA/d' -i configure.ac
autoreconf --force --install autoreconf --force --install
patch -p0 -i "${srcdir}/perlmagick.rpath.patch" patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
patch -p3 -i "${srcdir}/imagemagick-palm.diff"
patch -p3 -i "${srcdir}/imagemagick-rle.diff"
} }
build() { build() {

View file

@ -1,11 +0,0 @@
Index: ImageMagick/branches/ImageMagick-6/coders/palm.c
===================================================================
--- ImageMagick/branches/ImageMagick-6/coders/palm.c (revision 17434)
+++ ImageMagick/branches/ImageMagick-6/coders/palm.c (revision 17515)
@@ -511,5 +511,5 @@
IndexPacket index=ConstrainColormapIndex(image,(mask-transparentIndex));
if (bits_per_pixel != 16)
- SetMagickPixelPacket(image,image->colormap+index,
+ SetMagickPixelPacket(image,image->colormap+(ssize_t) index,
(const IndexPacket *) NULL,&transpix);
(void) TransparentPaintImage(image,&transpix,(Quantum)

View file

@ -1,18 +0,0 @@
Index: ImageMagick/branches/ImageMagick-6/coders/rle.c
===================================================================
--- ImageMagick/branches/ImageMagick-6/coders/rle.c (revision 17434)
+++ ImageMagick/branches/ImageMagick-6/coders/rle.c (revision 17516)
@@ -457,5 +457,5 @@
MagickFalse)
break;
- *p=colormap[index];
+ *p=colormap[(ssize_t) index];
p++;
}
@@ -468,5 +468,5 @@
(*p & mask)),&index,exception) == MagickFalse)
break;
- *p=colormap[index];
+ *p=colormap[(ssize_t) index];
p++;
}