mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/mythtv to 0.26.0-4
This commit is contained in:
parent
dbabb046da
commit
122c7f418e
2 changed files with 71 additions and 1 deletions
|
@ -11,7 +11,7 @@
|
||||||
|
|
||||||
pkgname=mythtv
|
pkgname=mythtv
|
||||||
pkgver=0.26.0
|
pkgver=0.26.0
|
||||||
pkgrel=3
|
pkgrel=4
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgdesc="A Homebrew PVR project"
|
pkgdesc="A Homebrew PVR project"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
|
@ -33,10 +33,12 @@ replaces=('myththemes' 'mythplugins-mythvideo')
|
||||||
backup=('etc/conf.d/mythbackend')
|
backup=('etc/conf.d/mythbackend')
|
||||||
install='mythtv.install'
|
install='mythtv.install'
|
||||||
source=("ftp://ftp.osuosl.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2"
|
source=("ftp://ftp.osuosl.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2"
|
||||||
|
'alsa.patch'
|
||||||
'mythbackend.rc'
|
'mythbackend.rc'
|
||||||
'mythbackend.conf'
|
'mythbackend.conf'
|
||||||
'mythbackend.service')
|
'mythbackend.service')
|
||||||
md5sums=('f57066bf75e6f14824c494d41639f4f9'
|
md5sums=('f57066bf75e6f14824c494d41639f4f9'
|
||||||
|
'f64b8219e3d27a2edf96733b851e576b'
|
||||||
'c8f935d42fb8617e9279bd539811ca5f'
|
'c8f935d42fb8617e9279bd539811ca5f'
|
||||||
'ab962d83614cbd0ac11ce3fcc929829d'
|
'ab962d83614cbd0ac11ce3fcc929829d'
|
||||||
'e4d572dcc307d6d8ae26bee5aebf9f3a')
|
'e4d572dcc307d6d8ae26bee5aebf9f3a')
|
||||||
|
@ -45,6 +47,8 @@ build() {
|
||||||
cd "$srcdir/$pkgname-$pkgver"
|
cd "$srcdir/$pkgname-$pkgver"
|
||||||
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
|
find 'bindings/python' 'contrib' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
|
||||||
|
|
||||||
|
patch -Np1 -i "$srcdir/alsa.patch"
|
||||||
|
|
||||||
sed -re 's@Key, &@Key, @' -i 'bindings/php/MythBase.php'
|
sed -re 's@Key, &@Key, @' -i 'bindings/php/MythBase.php'
|
||||||
|
|
||||||
[[ $CARCH == "arm" ]] && ARCH="armv5te"
|
[[ $CARCH == "arm" ]] && ARCH="armv5te"
|
||||||
|
|
66
community/mythtv/alsa.patch
Normal file
66
community/mythtv/alsa.patch
Normal file
|
@ -0,0 +1,66 @@
|
||||||
|
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio-common.c b/external/FFmpeg/libavdevice/alsa-audio-common.c
|
||||||
|
--- a/external/FFmpeg/libavdevice/alsa-audio-common.c 2012-10-02 23:30:24.000000000 +1300
|
||||||
|
+++ b/external/FFmpeg/libavdevice/alsa-audio-common.c 2013-01-09 13:23:49.704360811 +1300
|
||||||
|
@@ -28,6 +28,7 @@
|
||||||
|
* @author Nicolas George ( nicolas george normalesup org )
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <alsa/asoundlib.h>
|
||||||
|
#include "avdevice.h"
|
||||||
|
#include "libavutil/avassert.h"
|
||||||
|
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio-dec.c b/external/FFmpeg/libavdevice/alsa-audio-dec.c
|
||||||
|
--- a/external/FFmpeg/libavdevice/alsa-audio-dec.c 2012-10-02 23:30:24.000000000 +1300
|
||||||
|
+++ b/external/FFmpeg/libavdevice/alsa-audio-dec.c 2013-01-09 13:23:47.911005108 +1300
|
||||||
|
@@ -45,6 +45,7 @@
|
||||||
|
* plugin.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <alsa/asoundlib.h>
|
||||||
|
#include "libavformat/internal.h"
|
||||||
|
#include "libavutil/opt.h"
|
||||||
|
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio-enc.c b/external/FFmpeg/libavdevice/alsa-audio-enc.c
|
||||||
|
--- a/external/FFmpeg/libavdevice/alsa-audio-enc.c 2012-10-02 23:30:24.000000000 +1300
|
||||||
|
+++ b/external/FFmpeg/libavdevice/alsa-audio-enc.c 2013-01-09 13:23:46.880992286 +1300
|
||||||
|
@@ -37,6 +37,7 @@
|
||||||
|
* which gives a low latency suitable for real-time playback.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <alsa/asoundlib.h>
|
||||||
|
|
||||||
|
#include "libavformat/internal.h"
|
||||||
|
diff -Nru a/external/FFmpeg/libavdevice/alsa-audio.h b/external/FFmpeg/libavdevice/alsa-audio.h
|
||||||
|
--- a/external/FFmpeg/libavdevice/alsa-audio.h 2012-10-02 23:30:24.000000000 +1300
|
||||||
|
+++ b/external/FFmpeg/libavdevice/alsa-audio.h 2013-01-09 13:23:51.121045145 +1300
|
||||||
|
@@ -30,6 +30,7 @@
|
||||||
|
#ifndef AVDEVICE_ALSA_AUDIO_H
|
||||||
|
#define AVDEVICE_ALSA_AUDIO_H
|
||||||
|
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <alsa/asoundlib.h>
|
||||||
|
#include "config.h"
|
||||||
|
#include "libavutil/log.h"
|
||||||
|
diff -Nru a/libs/libmyth/audio/audiooutputalsa.h b/libs/libmyth/audio/audiooutputalsa.h
|
||||||
|
--- a/libs/libmyth/audio/audiooutputalsa.h 2012-10-02 23:30:24.000000000 +1300
|
||||||
|
+++ b/libs/libmyth/audio/audiooutputalsa.h 2013-01-09 13:22:13.313180438 +1300
|
||||||
|
@@ -1,6 +1,7 @@
|
||||||
|
#ifndef AUDIOOUTPUTALSA
|
||||||
|
#define AUDIOOUTPUTALSA
|
||||||
|
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#define ALSA_PCM_NEW_HW_PARAMS_API
|
||||||
|
#define ALSA_PCM_NEW_SW_PARAMS_API
|
||||||
|
#include <alsa/asoundlib.h>
|
||||||
|
diff -Nru a/libs/libmythtv/audioinputalsa.h b/libs/libmythtv/audioinputalsa.h
|
||||||
|
--- a/libs/libmythtv/audioinputalsa.h 2012-10-02 23:30:24.000000000 +1300
|
||||||
|
+++ b/libs/libmythtv/audioinputalsa.h 2013-01-09 13:22:44.470223553 +1300
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include "audioinput.h"
|
||||||
|
|
||||||
|
#ifdef USING_ALSA
|
||||||
|
+#include <sys/types.h>
|
||||||
|
#include <alsa/asoundlib.h>
|
||||||
|
#else
|
||||||
|
typedef int snd_pcm_t;
|
Loading…
Reference in a new issue