extra/webkit2gtk to 2.32.0-2

This commit is contained in:
Kevin Mihelich 2021-04-17 19:28:25 +00:00
parent 349ee4b88a
commit 123756cf54
2 changed files with 20 additions and 3 deletions

View file

@ -8,7 +8,7 @@ highmem=1
pkgname=webkit2gtk
pkgver=2.32.0
pkgrel=1
pkgrel=2
pkgdesc="Web content engine for GTK"
url="https://webkitgtk.org"
arch=(x86_64)
@ -25,14 +25,19 @@ optdepends=('geoclue: Geolocation support'
'gst-plugins-good: media decoding'
'gst-plugins-bad: media decoding'
'gst-libav: nonfree media decoding')
source=($url/releases/webkitgtk-$pkgver.tar.xz{,.asc})
source=($url/releases/webkitgtk-$pkgver.tar.xz{,.asc}
unhide-deprecated-api.patch)
sha256sums=('9d7df4dae9ada2394257565acc2a68ace9308c4c61c3fcc00111dc1f11076bf0'
'SKIP')
'SKIP'
'48ee7bee0b50776c8153c20b96854bd5086e0a7d04e621fd57ea7fc6c690c3a2')
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3' # Carlos Garcia Campos <cgarcia@igalia.com>
'5AA3BC334FD7E3369E7C77B291C559DBE4C9123B') # Adrián Pérez de Castro <aperez@igalia.com>
prepare() {
cd webkitgtk-$pkgver
# Use deprecated API for ubrk_safeClone until ICU 69 is officially supported
patch -Np1 -i ../unhide-deprecated-api.patch
}
build() {

View file

@ -0,0 +1,12 @@
diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
index 6fa104c82992..8c8640c3dee7 100644
--- a/Source/WTF/wtf/Platform.h
+++ b/Source/WTF/wtf/Platform.h
@@ -113,7 +113,6 @@
/* FIXME: This does not belong in Platform.h and should instead be included in another mechanism (compiler option, prefix header, config.h, etc) */
/* ICU configuration. Some of these match ICU defaults on some platforms, but we would like them consistently set everywhere we build WebKit. */
-#define U_HIDE_DEPRECATED_API 1
#define U_SHOW_CPLUSPLUS_API 0
#ifdef __cplusplus
#define UCHAR_TYPE char16_t