community/python-autobahn to 19.5.1-1

This commit is contained in:
Kevin Mihelich 2019-05-12 15:59:04 +00:00
parent d880ec2ea3
commit 1248476545
2 changed files with 9 additions and 46 deletions

View file

@ -6,31 +6,28 @@
# - removed AUTOBAHN_USE_NVX=1 from python build/install commands # - removed AUTOBAHN_USE_NVX=1 from python build/install commands
pkgname=python-autobahn pkgname=python-autobahn
pkgver=19.3.3 pkgver=19.5.1
pkgrel=1 pkgrel=1
pkgdesc='Real-time framework for Web, Mobile & Internet of Things' pkgdesc='Real-time framework for Web, Mobile & Internet of Things'
arch=(x86_64) arch=(x86_64)
url='https://crossbar.io/autobahn/' url='https://crossbar.io/autobahn/'
license=(MIT) license=(MIT)
depends=(python-cffi python-twisted python-six python-txaio python-wsaccel) depends=(python-cffi python-twisted python-six python-txaio python-wsaccel python-setuptools)
makedepends=(python-setuptools python-argon2_cffi python-msgpack python-passlib python-pynacl) makedepends=(python-argon2_cffi python-cbor python-flatbuffers
python-msgpack python-passlib python-pynacl python-ubjson)
checkdepends=(python-mock python-pytest python-pytest-asyncio) checkdepends=(python-mock python-pytest python-pytest-asyncio)
optdepends=( optdepends=(
'python-cbor: CBOR serializer support'
'python-flatbuffers: FlatBuffers serializer support'
'python-msgpack: MsgPack serializer support' 'python-msgpack: MsgPack serializer support'
'python-ubjson: UBJSON serializer support'
'python-argon2_cffi: WAMP-SCRAM authentication support' 'python-argon2_cffi: WAMP-SCRAM authentication support'
'python-passlib: WAMP-SCRAM authentication support' 'python-passlib: WAMP-SCRAM authentication support'
'python-pynacl: WAMP-cryptosign support' 'python-pynacl: WAMP-cryptosign support'
) )
source=(https://pypi.io/packages/source/a/autobahn/autobahn-$pkgver.tar.gz source=(https://files.pythonhosted.org/packages/source/a/autobahn/autobahn-$pkgver.tar.gz)
skip-test-missing-serializers.patch) sha256sums=('2eee98f68ba4eb8d8ea3f15e411db9e69433d9367799c85bdca0ff2de4c101d3')
sha256sums=('e92f40ab26fb51672c25cd301ae79a549c6ff7748effe6abdea2ef31d5363a4f'
'2d4ec4300f98cddd13c3a4d70e6ae4934a98f17b04628cadfd18654172d04f92')
prepare() {
cd "$srcdir/autobahn-$pkgver"
patch -Np1 -i ../skip-test-missing-serializers.patch
}
build() { build() {
cd "$srcdir/autobahn-$pkgver" cd "$srcdir/autobahn-$pkgver"

View file

@ -1,34 +0,0 @@
diff --git a/autobahn/wamp/test/test_serializer.py b/autobahn/wamp/test/test_serializer.py
index 8e47805c..117df18d 100644
--- a/autobahn/wamp/test/test_serializer.py
+++ b/autobahn/wamp/test/test_serializer.py
@@ -129,11 +129,17 @@ def create_serializers():
_serializers.append(serializer.MsgPackSerializer())
_serializers.append(serializer.MsgPackSerializer(batched=True))
- _serializers.append(serializer.CBORSerializer())
- _serializers.append(serializer.CBORSerializer(batched=True))
+ try:
+ _serializers.append(serializer.CBORSerializer())
+ _serializers.append(serializer.CBORSerializer(batched=True))
+ except AttributeError:
+ pass
- _serializers.append(serializer.UBJSONSerializer())
- _serializers.append(serializer.UBJSONSerializer(batched=True))
+ try:
+ _serializers.append(serializer.UBJSONSerializer())
+ _serializers.append(serializer.UBJSONSerializer(batched=True))
+ except AttributeError:
+ pass
# FIXME: implement full FlatBuffers serializer for WAMP
if six.PY3:
@@ -146,6 +152,7 @@ def create_serializers():
@unittest.skipIf(not six.PY3, 'WAMP-FlatBuffers currently only supports Python 3')
+@unittest.skipIf(not hasattr(serializer, 'FlatBuffersSerializer'), 'FlatBuffers support missing')
class TestFlatBuffersSerializer(unittest.TestCase):
def test_basic(self):