extra/firefox to 59.0-1

This commit is contained in:
Kevin Mihelich 2018-03-14 00:26:16 +00:00
parent 806e3fa486
commit 12507e1d1d
4 changed files with 14 additions and 65 deletions

View file

@ -1,27 +0,0 @@
From 2877a352715ce7e30ef364722757c6ec380236b1 Mon Sep 17 00:00:00 2001
Message-Id: <2877a352715ce7e30ef364722757c6ec380236b1.1518037075.git.jan.steffens@gmail.com>
From: Harald van Dijk <harald@gigawatt.nl>
Date: Thu, 18 Jan 2018 15:18:37 -0700
Subject: [PATCH] Bug 1430274 - Define MOZ_ALSA for more source files. r=jld
---
security/sandbox/linux/moz.build | 3 +++
1 file changed, 3 insertions(+)
diff --git a/security/sandbox/linux/moz.build b/security/sandbox/linux/moz.build
index 681d658bfeb7..1a49b548af2d 100644
--- a/security/sandbox/linux/moz.build
+++ b/security/sandbox/linux/moz.build
@@ -78,6 +78,9 @@ if CONFIG['MOZ_GMP_SANDBOX']:
'SandboxOpenedFiles.cpp',
]
+if CONFIG['MOZ_ALSA']:
+ DEFINES['MOZ_ALSA'] = True
+
# This copy of SafeSPrintf doesn't need to avoid the Chromium logging
# dependency like the one in libxul does, but this way the behavior is
# consistent. See also the comment in SandboxLogging.h.
--
2.16.1

View file

@ -11,31 +11,28 @@ buildarch=12
highmem=1
pkgname=firefox
pkgver=58.0.2
pkgver=59.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
nss hunspell sqlite ttf-font libpulse libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
autoconf2.13 rust mercurial clang llvm jack)
autoconf2.13 rust mercurial clang llvm jack gtk2)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip)
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
source=("https://hg.mozilla.org/releases/mozilla-release/archive/FIREFOX_${pkgver//./_}_RELEASE.tar.gz"
$pkgname.desktop firefox-symbolic.svg
0001-Bug-1430274-Define-MOZ_ALSA-for-more-source-files.-r.patch
firefox-install-dir.patch no-crmf.diff)
sha256sums=('2b7794e4c2a24fa388f3acb2956c96bb2c3eae455467f0e386788ebaea7240c3'
no-crmf.diff)
sha256sums=('beed87f586b48c5c1546dc6190f9c90a5c266061f78c7117ed62122c77330ceb'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
'e8a695bd6a007525390c502739c0f00d5d753a1bde7053c21c712075f2c2994d'
'a94f80abe65608cd49054a30acc31e4d0885fe5b2a38cf08ded5e5b51b87c99d'
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb')
'02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@ -54,11 +51,7 @@ prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
cd $pkgname-$pkgver
patch -Np1 -i ../firefox-install-dir.patch
# https://bugs.archlinux.org/task/57285
patch -Np1 -i ../0001-Bug-1430274-Define-MOZ_ALSA-for-more-source-files.-r.patch
cd mozilla-release-FIREFOX_${pkgver//./_}_RELEASE
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff
@ -121,7 +114,7 @@ END
}
build() {
cd $pkgname-$pkgver
cd mozilla-release-FIREFOX_${pkgver//./_}_RELEASE
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@ -137,7 +130,7 @@ build() {
}
package() {
cd $pkgname-$pkgver
cd mozilla-release-FIREFOX_${pkgver//./_}_RELEASE
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
@ -170,14 +163,10 @@ app.distributor.channel=$pkgname
app.partner.archlinux=archlinux
END
for i in 16 22 24 32 48 256; do
for i in 16 22 24 32 48 64 128 256; do
install -Dm644 browser/branding/official/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done
install -Dm644 browser/branding/official/content/icon64.png \
"$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
install -Dm644 browser/branding/official/mozicon128.png \
"$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
install -Dm644 browser/branding/official/content/about-logo.png \
"$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
install -Dm644 browser/branding/official/content/about-logo@2x.png \

View file

@ -1,13 +0,0 @@
diff --git i/config/baseconfig.mk w/config/baseconfig.mk
index e204533ac9b66b88..27ae154ce265ca2b 100644
--- i/config/baseconfig.mk
+++ w/config/baseconfig.mk
@@ -4,7 +4,7 @@
# whether a normal build is happening or whether the check is running.
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
ifeq (.,$(DEPTH))
DIST = dist

View file

@ -1,9 +1,9 @@
diff --git i/old-configure.in w/old-configure.in
index 0a06e470d2085922..d41c8e9d5dd2dbfb 100644
index 12170a47568f..dbbaa0bc9194 100644
--- i/old-configure.in
+++ w/old-configure.in
@@ -2020,9 +2020,7 @@ if test -n "$_USE_SYSTEM_NSS"; then
AM_PATH_NSS(3.31, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
@@ -1808,9 +1808,7 @@ if test -n "$_USE_SYSTEM_NSS"; then
AM_PATH_NSS(3.35, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
fi
-if test -n "$MOZ_SYSTEM_NSS"; then