mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-gru to 4.4.92-1
This commit is contained in:
parent
1fe1fedcda
commit
1252762178
6 changed files with 20 additions and 155 deletions
|
@ -1,7 +1,7 @@
|
|||
From 69c6eaeae8786cb0ea9f4111274403fbc221eb15 Mon Sep 17 00:00:00 2001
|
||||
From 2cc2cfbd02ccc2151111f9eb8bacf5beba4e11b4 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 15 Feb 2017 18:32:55 -0700
|
||||
Subject: [PATCH 1/4] Input: atmel_mxt_ts: Use KERN_DEBUG loglevel for status
|
||||
Subject: [PATCH 1/3] Input: atmel_mxt_ts: Use KERN_DEBUG loglevel for status
|
||||
message
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -23,5 +23,5 @@ index b89c2c8e2c05..2f8c1887a3d8 100644
|
|||
if (status == 0x00)
|
||||
complete(&data->auto_cal_completion);
|
||||
--
|
||||
2.14.1
|
||||
2.14.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 7f0c0725ee953b8ddbc45815354717153b8801ba Mon Sep 17 00:00:00 2001
|
||||
From 7d6e59980fd7ce4e0c2b878e5e9436b49c89c005 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 5 Apr 2017 22:55:05 -0600
|
||||
Subject: [PATCH 2/4] Revert "CHROMIUM: drm: rockchip: Add PSR residency debug
|
||||
Subject: [PATCH 2/3] Revert "CHROMIUM: drm: rockchip: Add PSR residency debug
|
||||
entry"
|
||||
|
||||
This reverts commit 9f416401b95d3f1dee2ffb12e0e27339fce3ce1b.
|
||||
|
@ -85,5 +85,5 @@ index 9e953ee0d003..8d52abeb3f0b 100644
|
|||
dp->adp = ERR_PTR(-ENODEV);
|
||||
}
|
||||
--
|
||||
2.14.1
|
||||
2.14.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 5b406d74d5217e3f29b802c57010ef506b09878b Mon Sep 17 00:00:00 2001
|
||||
From dfb644d43cc14094715282dc75732c4ad8d52635 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 26 Feb 2017 19:14:10 -0700
|
||||
Subject: [PATCH 3/4] temporary hack to fix console output
|
||||
Subject: [PATCH 3/3] temporary hack to fix console output
|
||||
|
||||
---
|
||||
drivers/gpu/drm/rockchip/analogix_dp-rockchip.c | 14 --------------
|
||||
|
@ -33,5 +33,5 @@ index 8d52abeb3f0b..19d0f9d8b4d0 100644
|
|||
return 0;
|
||||
}
|
||||
--
|
||||
2.14.1
|
||||
2.14.2
|
||||
|
||||
|
|
|
@ -1,134 +0,0 @@
|
|||
From bb6481e5f5d78cb83fc07e845766f8094bc51112 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 23 Apr 2017 13:42:34 -0600
|
||||
Subject: [PATCH 4/4] skip HDCP setup
|
||||
|
||||
This causes a lockup immediately upon starting X.
|
||||
---
|
||||
drivers/gpu/drm/rockchip/cdn-dp-core.c | 89 ----------------------------------
|
||||
1 file changed, 89 deletions(-)
|
||||
|
||||
diff --git a/drivers/gpu/drm/rockchip/cdn-dp-core.c b/drivers/gpu/drm/rockchip/cdn-dp-core.c
|
||||
index e10ac220ef4b..c9d94e17b13c 100644
|
||||
--- a/drivers/gpu/drm/rockchip/cdn-dp-core.c
|
||||
+++ b/drivers/gpu/drm/rockchip/cdn-dp-core.c
|
||||
@@ -1151,88 +1151,6 @@ static int cdn_dp_pd_event(struct notifier_block *nb,
|
||||
return NOTIFY_DONE;
|
||||
}
|
||||
|
||||
-static int cdn_dp_set_hdcp_drm_property(struct cdn_dp_device *dp, uint64_t val)
|
||||
-{
|
||||
- struct drm_connector *connector = &dp->connector;
|
||||
- struct drm_mode_config *mc = &connector->dev->mode_config;
|
||||
-
|
||||
- return drm_object_property_set_value(&connector->base,
|
||||
- mc->content_protection_property,
|
||||
- val);
|
||||
-}
|
||||
-
|
||||
-static bool cdn_dp_hdcp_authorize(struct cdn_dp_device *dp)
|
||||
-{
|
||||
- bool auth_done = false;
|
||||
- u16 tx_status;
|
||||
- u32 sw_event;
|
||||
- int ret;
|
||||
-
|
||||
- mutex_lock(&dp->lock);
|
||||
-
|
||||
- /*
|
||||
- * HDCP authentication might cause the disconnect hpd event, just
|
||||
- * stop the hdcp event SM.
|
||||
- */
|
||||
- if (!dp->connected) {
|
||||
- auth_done = true;
|
||||
- goto out;
|
||||
- }
|
||||
-
|
||||
- sw_event = cdn_dp_get_event(dp);
|
||||
-
|
||||
- if (sw_event & HDCP_TX_STATUS_EVENT) {
|
||||
- auth_done = true;
|
||||
-
|
||||
- ret = cdn_dp_hdcp_tx_status_req(dp, &tx_status);
|
||||
- if (ret)
|
||||
- goto out;
|
||||
- if (HDCP_TX_STATUS_ERROR(tx_status)) {
|
||||
- dev_err(dp->dev, "hdcp status error: %x\n",
|
||||
- HDCP_TX_STATUS_ERROR(tx_status));
|
||||
- goto out;
|
||||
- } else if (tx_status & HDCP_TX_STATUS_AUTHENTICATED) {
|
||||
- cdn_dp_set_hdcp_drm_property(dp,
|
||||
- DRM_MODE_CONTENT_PROTECTION_ENABLED);
|
||||
- goto out;
|
||||
- } else {
|
||||
- auth_done = false;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
- if (sw_event & HDCP_TX_IS_RECEIVER_ID_VALID_EVENT) {
|
||||
- ret = cdn_dp_hdcp_tx_is_receiver_id_valid_req(dp);
|
||||
- if (ret) {
|
||||
- auth_done = true;
|
||||
- goto out;
|
||||
- }
|
||||
- ret = cdn_dp_hdcp_tx_respond_id_valid(dp, true);
|
||||
- if (ret)
|
||||
- auth_done = true;
|
||||
- }
|
||||
-
|
||||
-out:
|
||||
- mutex_unlock(&dp->lock);
|
||||
-
|
||||
- return auth_done;
|
||||
-}
|
||||
-
|
||||
-static void cdn_dp_hdcp_event_work(struct work_struct *work)
|
||||
-{
|
||||
- struct cdn_dp_device *dp = container_of(work, struct cdn_dp_device,
|
||||
- hdcp_event_work.work);
|
||||
- unsigned long timeout = jiffies +
|
||||
- msecs_to_jiffies(HDCP_EVENT_TIMEOUT_MS);
|
||||
-
|
||||
- while (time_before(jiffies, timeout)) {
|
||||
- if (cdn_dp_hdcp_authorize(dp))
|
||||
- return;
|
||||
- msleep(HDCP_RETRY_INTERVAL_MS);
|
||||
- }
|
||||
-
|
||||
- dev_err(dp->dev, "Failed to authorize hdcp\n");
|
||||
-}
|
||||
-
|
||||
static int cdn_dp_bind(struct device *dev, struct device *master, void *data)
|
||||
{
|
||||
struct cdn_dp_device *dp = dev_get_drvdata(dev);
|
||||
@@ -1240,7 +1158,6 @@ static int cdn_dp_bind(struct device *dev, struct device *master, void *data)
|
||||
struct drm_connector *connector;
|
||||
struct cdn_dp_port *port;
|
||||
struct drm_device *drm_dev = data;
|
||||
- struct drm_mode_config *mode_config;
|
||||
int ret, i;
|
||||
|
||||
ret = cdn_dp_parse_dt(dp);
|
||||
@@ -1253,7 +1170,6 @@ static int cdn_dp_bind(struct device *dev, struct device *master, void *data)
|
||||
dp->active_port = -1;
|
||||
|
||||
INIT_WORK(&dp->event_work, cdn_dp_pd_event_work);
|
||||
- INIT_DELAYED_WORK(&dp->hdcp_event_work, cdn_dp_hdcp_event_work);
|
||||
|
||||
encoder = &dp->encoder;
|
||||
|
||||
@@ -1310,11 +1226,6 @@ static int cdn_dp_bind(struct device *dev, struct device *master, void *data)
|
||||
|
||||
schedule_work(&dp->event_work);
|
||||
|
||||
- mode_config = &connector->dev->mode_config;
|
||||
- drm_object_attach_property(&connector->base,
|
||||
- mode_config->content_protection_property,
|
||||
- DRM_MODE_CONTENT_PROTECTION_UNDESIRED);
|
||||
-
|
||||
return 0;
|
||||
|
||||
err_free_connector:
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -6,9 +6,9 @@ buildarch=8
|
|||
pkgbase=linux-gru
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Gru Chromebooks"
|
||||
pkgver=4.4.86
|
||||
pkgrel=2
|
||||
_commit=d5dcc34e053c963d083c2d4bf9409ede1878199a
|
||||
pkgver=4.4.92
|
||||
pkgrel=1
|
||||
_commit=96e56ffa00a57f0990f7d0dbf9161668fa11f620
|
||||
arch=('aarch64')
|
||||
url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-4.4"
|
||||
license=('GPL2')
|
||||
|
@ -18,17 +18,15 @@ source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archiv
|
|||
'0001-Input-atmel_mxt_ts-Use-KERN_DEBUG-loglevel-for-statu.patch'
|
||||
'0002-Revert-CHROMIUM-drm-rockchip-Add-PSR-residency-debug.patch'
|
||||
'0003-temporary-hack-to-fix-console-output.patch'
|
||||
'0004-skip-HDCP-setup.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk')
|
||||
md5sums=('6b25d80eccace593b9ee2a8181097053'
|
||||
'61adb09d59c65c2df72135180ee39f8d'
|
||||
'6abb843c77b2fc684b1a4c6b21ac2b7e'
|
||||
'6c2221b2f8856a2d6a7a6de7eacab03a'
|
||||
'548731c6c4abc1e9679dabb3f53d2652'
|
||||
'9aa22cbed3e1b3a3adbcf65f80844a49'
|
||||
md5sums=('60c3f22600dde69ac57e4a887a117f1a'
|
||||
'd3b3d9d59f91cc6fad24c29873ad87bc'
|
||||
'66cd7c64f8861025fa8e394675222aa1'
|
||||
'8f416793377fc69914851a32fe6ca33e'
|
||||
'647f38a39979cdb1e599aba477cc4a1c'
|
||||
'25dea537b93937f77b92cde7adffcb55'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8')
|
||||
|
@ -37,7 +35,6 @@ prepare() {
|
|||
git apply 0001-Input-atmel_mxt_ts-Use-KERN_DEBUG-loglevel-for-statu.patch
|
||||
git apply 0002-Revert-CHROMIUM-drm-rockchip-Add-PSR-residency-debug.patch
|
||||
git apply 0003-temporary-hack-to-fix-console-output.patch
|
||||
git apply 0004-skip-HDCP-setup.patch
|
||||
|
||||
cp config .config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm64 4.4.79-1 Kernel Configuration
|
||||
# Linux/arm64 4.4.92-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM64=y
|
||||
CONFIG_64BIT=y
|
||||
|
@ -1125,6 +1125,7 @@ CONFIG_BT_LE=y
|
|||
# CONFIG_BT_LEDS is not set
|
||||
# CONFIG_BT_SELFTEST is not set
|
||||
CONFIG_BT_DEBUGFS=y
|
||||
# CONFIG_BT_EVE_HACKS is not set
|
||||
|
||||
#
|
||||
# Bluetooth device drivers
|
||||
|
@ -3207,6 +3208,7 @@ CONFIG_DRM_BRIDGE=y
|
|||
# CONFIG_DRM_PARADE_PS8640 is not set
|
||||
CONFIG_DRM_ANALOGIX_DP=y
|
||||
# CONFIG_DRM_ANALOGIX_ANX7688 is not set
|
||||
# CONFIG_DRM_POWERVR_ROGUE is not set
|
||||
|
||||
#
|
||||
# ARM GPU Configuration
|
||||
|
|
Loading…
Reference in a new issue