mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qt5-webengine to 5.9.0-1
This commit is contained in:
parent
9fa25a57af
commit
128400df02
5 changed files with 6 additions and 254 deletions
|
@ -10,9 +10,9 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=qt5-webengine
|
||||
_qtver=5.8.0
|
||||
_qtver=5.9.0
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=9
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
|
@ -20,21 +20,11 @@ pkgdesc='Provides support for web applications using the Chromium browser projec
|
|||
depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils' 'libxss' 'libvpx'
|
||||
'libevent' 'libsrtp' 'snappy' 'nss' 'protobuf' 'libxslt' 'libxdamage' 'minizip' 'ffmpeg')
|
||||
# namcap note: libxdamage is needed for nvidia users
|
||||
makedepends=('python2' 'git' 'gperf' 'jsoncpp')
|
||||
makedepends=('python2' 'git' 'gperf' 'jsoncpp' 'ninja')
|
||||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz" qt5-webengine-nss.patch
|
||||
qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
|
||||
qtwebengine-5.7.0-icu58.patch
|
||||
qtbug-58488.patch::"https://github.com/qt/qtwebengine/commit/7e7dd262.patch"
|
||||
qtbug-58381.patch::"https://github.com/qt/qtwebengine/commit/8e147ed3.patch"
|
||||
qtbug-58515.patch::"https://github.com/qt/qtwebengine/commit/a6c6665d.patch"
|
||||
qtbug-58673.patch::"https://github.com/qt/qtwebengine/commit/90501711.patch"
|
||||
qtbug-58362.patch::"https://github.com/qt/qtwebengine/commit/31374ba9.patch"
|
||||
qtbug-57778.patch::"https://github.com/qt/qtwebengine/commit/5c2cbfcc.patch"
|
||||
system-ffmpeg.patch)
|
||||
|
||||
md5sums=('6e7fb2be161c6db4d988a4f5b329672f'
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
|
||||
sha256sums=('6e7fb2be161c6db4d988a4f5b329672f'
|
||||
'2a1610b34204102938a24154a52e5571'
|
||||
'123d4d0d7db7473649ff2b5650330cc4'
|
||||
'9d225d1bf83ea45dbf6556d30d35fcb8'
|
||||
|
@ -52,37 +42,13 @@ prepare() {
|
|||
# Hack to force using python2
|
||||
mkdir -p bin
|
||||
ln -s /usr/bin/python2 bin/python
|
||||
|
||||
# Fix opening some websites with recent NSS https://github.com/QupZilla/qupzilla/issues/1870 (KaOSx patch)
|
||||
cd ${_pkgfqn}
|
||||
# patch -p1 -i ../qt5-webengine-nss.patch
|
||||
|
||||
# Fix build with ICU 58 (gentoo)
|
||||
#patch -p1 -i "$srcdir"/qtwebengine-5.7.0-icu58.patch
|
||||
|
||||
# Prevent drop-down popups form stealing focus https://bugreports.qt.io/browse/QTBUG-58488
|
||||
patch -p1 -i ../qtbug-58488.patch
|
||||
|
||||
# Backport some focus fixes
|
||||
patch -p1 -i ../qtbug-58381.patch
|
||||
patch -p1 -i ../qtbug-58515.patch
|
||||
patch -p1 -i ../qtbug-58673.patch
|
||||
|
||||
# Fix IME support
|
||||
patch -p1 -i ../qtbug-58362.patch
|
||||
|
||||
# Fix incorrectly overriding new and delete
|
||||
patch -p1 -i ../qtbug-57778.patch
|
||||
|
||||
[[ $CARCH == "armv7h" ]] && patch -p0 -i ../qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
|
||||
patch -p1 -i ../system-ffmpeg.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd build
|
||||
|
||||
export PATH="$srcdir/bin:$PATH"
|
||||
qmake CONFIG+="proprietary-codecs" WEBENGINE_CONFIG+="use_proprietary_codecs use_system_ffmpeg" ../${_pkgfqn}
|
||||
qmake CONFIG+="proprietary-codecs" WEBENGINE_CONFIG+="use_proprietary_codecs" ../${_pkgfqn}
|
||||
make
|
||||
}
|
||||
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
diff -ur qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/net/socket/ssl_client_socket_openssl.cc
|
||||
qtwebengine-opensource-src-5.6.0-beta-chimera-nss-init/src/3rdparty/chromium/net/socket/ssl_client_socket_openssl.cc
|
||||
--- qtwebengine-opensource-src-5.6.0-beta/src/3rdparty/chromium/net/socket/ssl_client_socket_openssl.cc 2015-12-10 18:17:21.000000000 +0100
|
||||
+++ qtwebengine-opensource-src-5.6.0-beta-chimera-nss-init/src/3rdparty/chromium/net/socket/ssl_client_socket_openssl.cc 2016-01-14
|
||||
17:11:38.432633534 +0100
|
||||
@@ -57,6 +57,10 @@
|
||||
#include "net/ssl/ssl_platform_key.h"
|
||||
#endif
|
||||
|
||||
+#if defined(USE_NSS_CERTS) || defined(OS_IOS)
|
||||
+#include "net/cert_net/nss_ocsp.h"
|
||||
+#endif
|
||||
+
|
||||
namespace net {
|
||||
|
||||
namespace {
|
||||
@@ -795,6 +799,14 @@
|
||||
DCHECK(!ssl_);
|
||||
DCHECK(!transport_bio_);
|
||||
|
||||
+#if defined(USE_NSS_CERTS) || defined(OS_IOS)
|
||||
+ if (ssl_config_.cert_io_enabled) {
|
||||
+ // TODO(davidben): Move this out of SSLClientSocket. See
|
||||
+ // https://crbug.com/539520.
|
||||
+ EnsureNSSHttpIOInit();
|
||||
+ }
|
||||
+#endif
|
||||
+
|
||||
SSLContext* context = SSLContext::GetInstance();
|
||||
crypto::OpenSSLErrStackTracer err_tracer(FROM_HERE);
|
||||
|
|
@ -1,105 +0,0 @@
|
|||
From 424584b4984bde7c831f42e9fb47f1ad583a1c46 Mon Sep 17 00:00:00 2001
|
||||
From: jshin <jshin@chromium.org>
|
||||
Date: Fri, 21 Oct 2016 01:15:50 -0700
|
||||
Subject: [PATCH] Update aspirational_scripts per Unicode 9
|
||||
|
||||
This is a preparation to update ICU to 58.1.
|
||||
Without this change, ICU update CL cannot be tested on
|
||||
trybots because a compile will fail due to '#error' checking
|
||||
if ICU version is less than 58.
|
||||
|
||||
BUG=637001
|
||||
TEST=None
|
||||
TBR=pkasting@chromium.org
|
||||
|
||||
Review-Url: https://chromiumcodereview.appspot.com/2436113003
|
||||
Cr-Commit-Position: refs/heads/master@{#426749}
|
||||
---
|
||||
components/url_formatter/url_formatter.cc | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/components/url_formatter/url_formatter.cc b/components/url_formatter/url_formatter.cc
|
||||
index 4455db3..2b82c0c 100644
|
||||
--- qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/components/url_formatter/url_formatter.cc
|
||||
+++ qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/components/url_formatter/url_formatter.cc
|
||||
@@ -428,9 +428,9 @@ void IDNSpoofChecker::SetAllowedUnicodeSet(UErrorCode* status) {
|
||||
// section at
|
||||
// http://www.unicode.org/Public/security/latest/xidmodifications.txt) are
|
||||
// are added to the allowed set. The list has to be updated when a new
|
||||
- // version of Unicode is released. The current version is 8.0.0 and ICU 58
|
||||
- // will have Unicode 9.0 data.
|
||||
-#if U_ICU_VERSION_MAJOR_NUM < 58
|
||||
+ // version of Unicode is released. The current version is 9.0.0 and ICU 60
|
||||
+ // will have Unicode 10.0 data.
|
||||
+#if U_ICU_VERSION_MAJOR_NUM < 60
|
||||
const icu::UnicodeSet aspirational_scripts(
|
||||
icu::UnicodeString(
|
||||
// Unified Canadian Syllabics
|
||||
@@ -444,13 +444,13 @@ void IDNSpoofChecker::SetAllowedUnicodeSet(UErrorCode* status) {
|
||||
// Yi
|
||||
"\\uA000-\\uA48C"
|
||||
// Miao
|
||||
- "\\U00016F00-\\U00016F44\\U00016F50-\\U00016F7F"
|
||||
+ "\\U00016F00-\\U00016F44\\U00016F50-\\U00016F7E"
|
||||
"\\U00016F8F-\\U00016F9F]",
|
||||
-1, US_INV),
|
||||
*status);
|
||||
allowed_set.addAll(aspirational_scripts);
|
||||
#else
|
||||
-#error "Update aspirational_scripts per Unicode 9.0"
|
||||
+#error "Update aspirational_scripts per Unicode 10.0"
|
||||
#endif
|
||||
|
||||
// U+0338 is included in the recommended set, while U+05F4 and U+2027 are in
|
||||
diff -Naur qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp
|
||||
--- qtwebengine-opensource-src-5.7.0.orig/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp 2016-11-15 17:07:38.680665385 -0800
|
||||
+++ qtwebengine-opensource-src-5.7.0/src/3rdparty/chromium/third_party/WebKit/Source/platform/text/TextBreakIterator.cpp 2016-11-15 17:12:17.564001354 -0800
|
||||
@@ -26,6 +26,9 @@
|
||||
#include "wtf/StdLibExtras.h"
|
||||
#include "wtf/text/CharacterNames.h"
|
||||
|
||||
+#include <unicode/uchar.h>
|
||||
+#include <unicode/uvernum.h>
|
||||
+
|
||||
namespace blink {
|
||||
|
||||
unsigned numGraphemeClusters(const String& string)
|
||||
@@ -122,13 +125,18 @@
|
||||
{ B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), 0, B(0, 0, 0, 0, 0, 0, 0, 0), 0, 0, 0, B(0, 0, 0, 0, 0, 0, 0, 0), 0, 0, 0, B(0, 0, 0, 0, 0, 0, 0, 0) }, // DEL
|
||||
};
|
||||
|
||||
+#if U_ICU_VERSION_MAJOR_NUM >= 58
|
||||
+#define BA_LB_COUNT (U_LB_COUNT - 3)
|
||||
+#else
|
||||
+#define BA_LB_COUNT U_LB_COUNT
|
||||
+#endif
|
||||
// Line breaking table for CSS word-break: break-all. This table differs from
|
||||
// asciiLineBreakTable in:
|
||||
// - Indices are Line Breaking Classes defined in UAX#14 Unicode Line Breaking
|
||||
// Algorithm: http://unicode.org/reports/tr14/#DescriptionOfProperties
|
||||
// - 1 indicates additional break opportunities. 0 indicates to fallback to
|
||||
// normal line break, not "prohibit break."
|
||||
-static const unsigned char breakAllLineBreakClassTable[][U_LB_COUNT / 8 + 1] = {
|
||||
+static const unsigned char breakAllLineBreakClassTable[][BA_LB_COUNT / 8 + 1] = {
|
||||
// XX AI AL B2 BA BB BK CB CL CM CR EX GL HY ID IN IS LF NS NU OP PO PR QU SA SG SP SY ZW NL WJ H2 H3 JL JT JV CP CJ HL RI
|
||||
{ B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 0, 0) }, // XX
|
||||
{ B(0, 1, 1, 0, 1, 0, 0, 0), B(0, 0, 0, 0, 0, 1, 0, 0), B(0, 0, 0, 1, 1, 0, 1, 0), B(1, 0, 0, 0, 0, 0, 0, 0), B(0, 0, 0, 0, 0, 0, 1, 0) }, // AI
|
||||
@@ -178,7 +186,7 @@
|
||||
#undef AL
|
||||
|
||||
static_assert(WTF_ARRAY_LENGTH(asciiLineBreakTable) == asciiLineBreakTableLastChar - asciiLineBreakTableFirstChar + 1, "asciiLineBreakTable should be consistent");
|
||||
-static_assert(WTF_ARRAY_LENGTH(breakAllLineBreakClassTable) == U_LB_COUNT, "breakAllLineBreakClassTable should be consistent");
|
||||
+static_assert(WTF_ARRAY_LENGTH(breakAllLineBreakClassTable) == BA_LB_COUNT, "breakAllLineBreakClassTable should be consistent");
|
||||
|
||||
static inline bool shouldBreakAfter(UChar lastCh, UChar ch, UChar nextCh)
|
||||
{
|
||||
@@ -209,7 +217,7 @@
|
||||
|
||||
static inline bool shouldBreakAfterBreakAll(ULineBreak lastLineBreak, ULineBreak lineBreak)
|
||||
{
|
||||
- if (lineBreak >= 0 && lineBreak < U_LB_COUNT && lastLineBreak >= 0 && lastLineBreak < U_LB_COUNT) {
|
||||
+ if (lineBreak >= 0 && lineBreak < BA_LB_COUNT && lastLineBreak >= 0 && lastLineBreak < BA_LB_COUNT) {
|
||||
const unsigned char* tableRow = breakAllLineBreakClassTable[lastLineBreak];
|
||||
return tableRow[lineBreak / 8] & (1 << (lineBreak % 8));
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- src/core/gyp_run.pro.orig 2016-12-17 09:08:25.447058042 -0700
|
||||
+++ src/core/gyp_run.pro 2016-12-17 09:11:34.499737847 -0700
|
||||
@@ -80,7 +80,7 @@
|
||||
# we use arm_neon_optional for ARMv7 and newer and let chromium decide
|
||||
# about the mfpu option.
|
||||
contains(MFPU, ".*neon.*"): GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=1
|
||||
- else:!lessThan(MARMV, 7): GYP_CONFIG += arm_neon=0 arm_neon_optional=1
|
||||
+ # else:!lessThan(MARMV, 7): GYP_CONFIG += arm_neon=0 arm_neon_optional=1
|
||||
else: GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=0 arm_neon_optional=0
|
||||
} else {
|
||||
# Chromium defaults to arm_neon=1, Qt does not.
|
|
@ -1,67 +0,0 @@
|
|||
diff --git a/src/3rdparty/chromium/media/ffmpeg/ffmpeg_common.h b/src/3rdparty/chromium/media/ffmpeg/ffmpeg_common.h
|
||||
index 11659fb..e943b16 100644
|
||||
--- a/src/3rdparty/chromium/media/ffmpeg/ffmpeg_common.h
|
||||
+++ b/src/3rdparty/chromium/media/ffmpeg/ffmpeg_common.h
|
||||
@@ -21,10 +21,6 @@
|
||||
|
||||
// Include FFmpeg header files.
|
||||
extern "C" {
|
||||
-// Disable deprecated features which result in spammy compile warnings. This
|
||||
-// list of defines must mirror those in the 'defines' section of BUILD.gn file &
|
||||
-// ffmpeg.gyp file or the headers below will generate different structures!
|
||||
-#define FF_API_CONVERGENCE_DURATION 0
|
||||
// Upstream libavcodec/utils.c still uses the deprecated
|
||||
// av_dup_packet(), causing deprecation warnings.
|
||||
// The normal fix for such things is to disable the feature as below,
|
||||
@@ -39,7 +35,6 @@ MSVC_PUSH_DISABLE_WARNING(4244);
|
||||
#include <libavcodec/avcodec.h>
|
||||
#include <libavformat/avformat.h>
|
||||
#if !defined(USE_SYSTEM_FFMPEG)
|
||||
-#include <libavformat/internal.h>
|
||||
#endif
|
||||
#include <libavformat/avio.h>
|
||||
#include <libavutil/avutil.h>
|
||||
diff --git a/src/3rdparty/chromium/media/filters/ffmpeg_demuxer.cc b/src/3rdparty/chromium/media/filters/ffmpeg_demuxer.cc
|
||||
index 237c938..2b6cd3e 100644
|
||||
--- a/src/3rdparty/chromium/media/filters/ffmpeg_demuxer.cc
|
||||
+++ b/src/3rdparty/chromium/media/filters/ffmpeg_demuxer.cc
|
||||
@@ -1036,24 +1036,6 @@ void FFmpegDemuxer::OnFindStreamInfoDone(const PipelineStatusCB& status_cb,
|
||||
std::vector<base::TimeDelta> start_time_estimates(format_context->nb_streams,
|
||||
kInfiniteDuration());
|
||||
#if !defined(USE_SYSTEM_FFMPEG)
|
||||
- const AVFormatInternal* internal = format_context->internal;
|
||||
- if (internal && internal->packet_buffer &&
|
||||
- format_context->start_time != static_cast<int64_t>(AV_NOPTS_VALUE)) {
|
||||
- struct AVPacketList* packet_buffer = internal->packet_buffer;
|
||||
- while (packet_buffer != internal->packet_buffer_end) {
|
||||
- DCHECK_LT(static_cast<size_t>(packet_buffer->pkt.stream_index),
|
||||
- start_time_estimates.size());
|
||||
- const AVStream* stream =
|
||||
- format_context->streams[packet_buffer->pkt.stream_index];
|
||||
- if (packet_buffer->pkt.pts != static_cast<int64_t>(AV_NOPTS_VALUE)) {
|
||||
- const base::TimeDelta packet_pts =
|
||||
- ConvertFromTimeBase(stream->time_base, packet_buffer->pkt.pts);
|
||||
- if (packet_pts < start_time_estimates[stream->index])
|
||||
- start_time_estimates[stream->index] = packet_pts;
|
||||
- }
|
||||
- packet_buffer = packet_buffer->next;
|
||||
- }
|
||||
- }
|
||||
#endif
|
||||
|
||||
AVStream* audio_stream = NULL;
|
||||
diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
|
||||
index 8854a4b..9af24c5 100644
|
||||
--- a/src/core/config/linux.pri
|
||||
+++ b/src/core/config/linux.pri
|
||||
@@ -21,6 +21,10 @@ GYP_CONFIG += \
|
||||
use_pango=0 \
|
||||
use_openssl=1
|
||||
|
||||
+GYP_CONFIG += \
|
||||
+ enable_webrtc=0 \
|
||||
+ use_system_ffmpeg=1
|
||||
+
|
||||
use?(nss) {
|
||||
GYP_CONFIG += use_nss_certs=1 \
|
||||
use_openssl_certs=0
|
Loading…
Reference in a new issue