core/pacman: fix

This commit is contained in:
Kevin Mihelich 2021-07-15 12:49:20 +00:00
parent f0f689f70b
commit 12adb7fe50
4 changed files with 21 additions and 21 deletions

View file

@ -1,4 +1,4 @@
From 2eb709681537fed1156b2e1dc134e194e7b5c762 Mon Sep 17 00:00:00 2001
From a2da301a5e247c33ea9f925c269346b610a5383f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Sep 2014 18:58:16 -0600
Subject: [PATCH 1/3] Sychronize filesystem
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+)
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
index 4d97921f..531dbbe4 100644
index f22f9bf9..04f94dab 100644
--- a/lib/libalpm/trans.c
+++ b/lib/libalpm/trans.c
@@ -230,6 +230,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
@@ -237,6 +237,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
trans->state = STATE_COMMITED;
@ -28,5 +28,5 @@ index 4d97921f..531dbbe4 100644
}
--
2.22.0
2.30.1

View file

@ -1,4 +1,4 @@
From 544d96b66768a77e838787807235bacb62f31c4b Mon Sep 17 00:00:00 2001
From 2cf9026a6b56ffa56d54554538a17c9162090045 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 30 Jan 2016 17:19:03 -0700
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
@ -16,10 +16,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 deletion(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index d33eef2a..e08cb923 100644
index 299d287e..82e01c5a 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -627,7 +627,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -635,7 +635,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
if(pid == 0) {
/* this code runs for the child only (the actual chroot/exec) */
@ -28,5 +28,5 @@ index d33eef2a..e08cb923 100644
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
--
2.22.0
2.30.1

View file

@ -1,4 +1,4 @@
From dd5e69dbd55b9649628b5166ad2ebeb664e3d2e0 Mon Sep 17 00:00:00 2001
From 83d11b75aa34cebe97bf6d31714870ca9c4cea78 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 11 Mar 2016 20:11:24 -0700
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
@ -10,10 +10,10 @@ This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index e08cb923..7e788a7e 100644
index 82e01c5a..1457535d 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -611,7 +611,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -619,7 +619,7 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
goto cleanup;
}
@ -22,7 +22,7 @@ index e08cb923..7e788a7e 100644
_alpm_log(handle, ALPM_LOG_ERROR, _("could not create pipe (%s)\n"), strerror(errno));
retval = 1;
goto cleanup;
@@ -631,9 +631,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -639,9 +639,11 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
while(dup2(child2parent_pipefd[HEAD], 2) == -1 && errno == EINTR);
@ -37,7 +37,7 @@ index e08cb923..7e788a7e 100644
close(child2parent_pipefd[TAIL]);
close(child2parent_pipefd[HEAD]);
if(cwdfd >= 0) {
@@ -670,16 +672,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
@@ -678,16 +680,15 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
child2parent->events = POLLIN;
fcntl(child2parent->fd, F_SETFL, O_NONBLOCK);
close(child2parent_pipefd[HEAD]);
@ -56,5 +56,5 @@ index e08cb923..7e788a7e 100644
#define STOP_POLLING(p) do { close(p->fd); p->fd = -1; } while(0)
--
2.22.0
2.30.1

View file

@ -29,8 +29,8 @@ options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig}
pacman-6.0.0-fix-404-download.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/3401f9e142ac4c701cd98c52618cb13164f2146b
pacman-6.0.0-fix-key-import-double-free.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/542910d684191eb7f25ddc5d3d8fe3060028a267
pacman-6.0.0-fix-404-download.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/3401f9e142ac4c701cd98c52618cb13164f2146b.patch
pacman-6.0.0-fix-key-import-double-free.patch::https://gitlab.archlinux.org/pacman/pacman/-/commit/542910d684191eb7f25ddc5d3d8fe3060028a267.patch
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
@ -38,11 +38,11 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.xz{,.sig
makepkg.conf)
sha256sums=('004448085a7747bdc7a0a4dd5d1fb7556c6b890111a06e029ab088f9905d4808'
'SKIP'
'fe7e037e1b84bfa5bc401650d148c2a2e87d827705a6ec18a596ff5eea3cc0fd'
'a51b57dd47818d97e29ac0b8604b4b409916bbe6029adfbb03ac7e7c2b2a0819'
'187bef40b14461ef7caba83e8124b6725e0cc9d46fa84353dae3b2afdc013589'
'83597d3092edb2414d3b1a3e2e7337c0edcf102636a5884f3d3f3755fdceb2b0'
'6e6434d123dd57961922627b39d967de384e3902a041e12dfc077081552fec28'
'f4c1c39b43b52ba19b656b32913688b81085c73685afe32d2018dbb695d5a1e6'
'defdf1686d65fc896c19f41d1bc166912fccf9134b72e50da3b24538366cecdf'
'f9a8ae2805cc995ef1b787e10f402d574aaee183cc3a23fe26805555b7d87fea'
'7beb2faec0ec37dcb2050d9ed3c95353fb7f73da7e3bbe0e226e9e3f7858a01f'
'0fdbdc3c86b826fe87d8051a5d34db23b366b0a7bdc22f3701b1bf2b01218d59'
'19f189accab294af7085cb709417eb41784d21aa8da07a8aa24bf7591ec3ce94'
'5db3f78ca0c3afa0678d5df83df810c202ce1fbdc82f8f73d90515929c0eb4ce')