mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/mysql-workbench to 6.3.6-3
This commit is contained in:
parent
dbf4f00114
commit
12d185c049
2 changed files with 3 additions and 50 deletions
|
@ -1,41 +0,0 @@
|
|||
diff --git a/cppconn/datatype.h b/cppconn/datatype.h
|
||||
index 7ada3bc..50c71cf 100644
|
||||
--- a/cppconn/datatype.h
|
||||
+++ b/cppconn/datatype.h
|
||||
@@ -59,7 +59,8 @@ public:
|
||||
GEOMETRY,
|
||||
ENUM,
|
||||
SET,
|
||||
- SQLNULL
|
||||
+ SQLNULL,
|
||||
+ JSON
|
||||
};
|
||||
};
|
||||
|
||||
diff --git a/driver/mysql_metadata.cpp b/driver/mysql_metadata.cpp
|
||||
index 8d3ef8b..2faf454 100644
|
||||
--- a/driver/mysql_metadata.cpp
|
||||
+++ b/driver/mysql_metadata.cpp
|
||||
@@ -4736,6 +4736,9 @@ MySQL_ConnectionMetaData::supportsConvert(int fromType, int toType)
|
||||
}
|
||||
}
|
||||
|
||||
+ case sql::DataType::JSON:
|
||||
+ return false;
|
||||
+
|
||||
// MySQL doesn't support a NULL type
|
||||
case sql::DataType::SQLNULL:
|
||||
return false;
|
||||
diff --git a/driver/mysql_util.cpp b/driver/mysql_util.cpp
|
||||
index af5a7f4..3283eca 100644
|
||||
--- a/driver/mysql_util.cpp
|
||||
+++ b/driver/mysql_util.cpp
|
||||
@@ -431,6 +431,8 @@ mysql_type_to_datatype(const MYSQL_FIELD * const field)
|
||||
return sql::DataType::SET;
|
||||
case MYSQL_TYPE_GEOMETRY:
|
||||
return sql::DataType::GEOMETRY;
|
||||
+ case MYSQL_TYPE_JSON:
|
||||
+ return sql::DataType::JSON;
|
||||
default:
|
||||
return sql::DataType::UNKNOWN;
|
||||
}
|
|
@ -10,9 +10,9 @@
|
|||
|
||||
pkgname=mysql-workbench
|
||||
pkgver=6.3.6
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
_mysql_version=5.7.10
|
||||
_connector_version=1.1.6
|
||||
_connector_version=1.1.7
|
||||
_gdal_version=2.0.1
|
||||
_boost_version=1.59.0
|
||||
pkgdesc='A cross-platform, visual database design tool developed by MySQL'
|
||||
|
@ -37,19 +37,17 @@ source=("http://cdn.mysql.com/Downloads/MySQLGUITools/mysql-workbench-community-
|
|||
"https://downloads.sourceforge.net/project/boost/boost/${_boost_version}/boost_${_boost_version//./_}.tar.bz2"
|
||||
'http://www.antlr3.org/download/antlr-3.4-complete.jar'
|
||||
'0001-mysql-workbench-no-check-for-updates.patch'
|
||||
'0002-mysql-connector-c++-json.patch'
|
||||
'arch_linux_profile.xml')
|
||||
sha256sums=('c51fce1a3fd9425dd9adf4d16e24e84f92e2f8374b43a956f580fd84d03afe62'
|
||||
'SKIP'
|
||||
'1ea1644884d086a23eafd8ccb04d517fbd43da3a6a06036f23c5c3a111e25c74'
|
||||
'SKIP'
|
||||
'ad710b3900cae3be94656825aa70319cf7a96e1ad46bf93e07275f3606f69447'
|
||||
'5b353fbcd26f607a2a0987ce78a4b811f8971813d46b0f4ae6fa07887e9fc763'
|
||||
'SKIP'
|
||||
'b55f794768e104a2fd0304eaa61bb8bda3dc7c4e14f2c9d0913baca3e55b83ab'
|
||||
'727a932322d94287b62abb1bd2d41723eec4356a7728909e38adb65ca25241ca'
|
||||
'9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7'
|
||||
'b189e15c6b6f5a707357d9a9297f39ee3a33264fd28b44d5de6f537f851f82cf'
|
||||
'4beb8b6c92f6b2b2189bfdd2f1a073ad54d501f05ef4686e47c661b40f63b9d3'
|
||||
'2ade582ca25f6d6d748bc84a913de39b34dcaa6e621a77740fe143007f2833af')
|
||||
|
||||
prepare() {
|
||||
|
@ -63,10 +61,6 @@ prepare() {
|
|||
sed -i '/^FIND_PROGRAM(PYTHON_EXEC /c FIND_PROGRAM(PYTHON_EXEC "python2")' \
|
||||
CMakeLists.txt
|
||||
|
||||
# MySQL connector C++ is lagging behind and misses JSON support
|
||||
cd "${srcdir}/mysql-connector-c++-${_connector_version}/"
|
||||
patch -Np1 < "${srcdir}"/0002-mysql-connector-c++-json.patch
|
||||
|
||||
# put antlr into place
|
||||
install -D ${srcdir}/antlr-3.4-complete.jar ${srcdir}/linux-res/bin/antlr-3.4-complete.jar
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue