extra/qt6-webengine: fix

This commit is contained in:
Kevin Mihelich 2021-10-28 01:15:55 +00:00
parent 2d795ed729
commit 12f32f14e8
5 changed files with 10 additions and 119 deletions

View file

@ -1,7 +1,7 @@
From e3433bcca3f78b5a2d5b1c1aff0ae415475c9e32 Mon Sep 17 00:00:00 2001
From 28ee70e324c7946a4e939515d4f6a8e1f5d87e83 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 4 Jul 2017 11:54:39 -0600
Subject: [PATCH 1/4] ARM toolchain fixes
Subject: [PATCH 1/3] ARM toolchain fixes
---
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------

View file

@ -1,7 +1,7 @@
From 719510740eaab4137d089ab9ea7463903c411271 Mon Sep 17 00:00:00 2001
From f93cfb3e00903cb4d7a068f2030683d28dc27bb8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 1 Jul 2019 07:10:36 -0600
Subject: [PATCH 2/4] Fix ARM skia ICE
Subject: [PATCH 2/3] Fix ARM skia ICE
---
chromium/third_party/skia/third_party/skcms/src/Transform_inl.h | 2 +-

View file

@ -1,7 +1,7 @@
From c8d5726f28ef66408dd8b9278fc755abda16e99f Mon Sep 17 00:00:00 2001
From 917a82b9fd93d6c994c9bac6ea1deeaefeadd6f3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 2 Feb 2021 13:58:59 -0700
Subject: [PATCH 3/4] Run blink bindings generation single threaded
Subject: [PATCH 3/3] Run blink bindings generation single threaded
When not single threaded this process will eat all the RAM.
---

View file

@ -1,106 +0,0 @@
From 5b87fed684ddc9c881e5f2a68ba59f24cf2d5a44 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 2 Feb 2021 13:58:21 -0700
Subject: [PATCH 4/4] Fix sandbox 'Aw snap' for sycalls 403 and 407
---
.../sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc | 9 ++++++++-
.../syscall_parameters_restrictions_unittests.cc | 6 ++++++
.../sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc | 6 ++++++
.../sandbox/linux/system_headers/arm_linux_syscalls.h | 8 ++++++++
.../sandbox/linux/system_headers/mips_linux_syscalls.h | 8 ++++++++
5 files changed, 36 insertions(+), 1 deletion(-)
diff --git a/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc b/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
index 89450d6d4eb..531334672b3 100644
--- a/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
+++ b/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
@@ -159,7 +159,14 @@ ResultExpr EvaluateSyscallImpl(int fs_denied_errno,
return Allow();
#endif
- if (sysno == __NR_clock_gettime || sysno == __NR_clock_nanosleep) {
+ if (sysno == __NR_clock_gettime || sysno == __NR_clock_nanosleep
+#if defined(__NR_clock_gettime64)
+ || sysno == __NR_clock_gettime64
+#endif
+#if defined(__NR_clock_nanosleep_time64)
+ || sysno == __NR_clock_nanosleep_time64
+#endif
+ ) {
return RestrictClockID();
}
diff --git a/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc b/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
index 4bbfc7e53b6..540149b67d9 100644
--- a/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
+++ b/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_parameters_restrictions_unittests.cc
@@ -61,6 +61,12 @@ class RestrictClockIdPolicy : public bpf_dsl::Policy {
case __NR_clock_gettime:
case __NR_clock_getres:
case __NR_clock_nanosleep:
+#if defined(__NR_clock_nanosleep_time64)
+ case __NR_clock_nanosleep_time64:
+#endif
+#if defined(__NR_clock_gettime64)
+ case __NR_clock_gettime64:
+#endif
return RestrictClockID();
default:
return Allow();
diff --git a/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc b/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
index f40d436edfb..c712b00f617 100644
--- a/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
+++ b/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
@@ -39,6 +39,12 @@ bool SyscallSets::IsAllowedGettime(int sysno) {
// filtered by RestrictClokID().
case __NR_clock_gettime: // Parameters filtered by RestrictClockID().
case __NR_clock_nanosleep: // Parameters filtered by RestrictClockID().
+#if defined(__NR_clock_gettime64)
+ case __NR_clock_gettime64: // Parameters filtered by RestrictClockID().
+#endif
+#if defined(__NR_clock_nanosleep_time64)
+ case __NR_clock_nanosleep_time64: // Parameters filtered by RestrictClockID().
+#endif
case __NR_clock_settime: // Privileged.
#if defined(__i386__) || \
(defined(ARCH_CPU_MIPS_FAMILY) && defined(ARCH_CPU_32_BITS))
diff --git a/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h b/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h
index 85e2110b4c2..c39c22b5114 100644
--- a/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h
+++ b/chromium/sandbox/linux/system_headers/arm_linux_syscalls.h
@@ -1441,6 +1441,14 @@
#define __NR_io_pgetevents (__NR_SYSCALL_BASE+399)
#endif
+#if !defined(__NR_clock_gettime64)
+#define __NR_clock_gettime64 (__NR_SYSCALL_BASE+403)
+#endif
+
+#if !defined(__NR_clock_nanosleep_time64)
+#define __NR_clock_nanosleep_time64 (__NR_SYSCALL_BASE+407)
+#endif
+
// ARM private syscalls.
#if !defined(__ARM_NR_BASE)
#define __ARM_NR_BASE (__NR_SYSCALL_BASE + 0xF0000)
diff --git a/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h b/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h
index ddbf97f3d8b..fa01b3bbc66 100644
--- a/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h
+++ b/chromium/sandbox/linux/system_headers/mips_linux_syscalls.h
@@ -1433,4 +1433,12 @@
#define __NR_memfd_create (__NR_Linux + 354)
#endif
+#if !defined(__NR_clock_gettime64)
+#define __NR_clock_gettime64 (__NR_Linux + 403)
+#endif
+
+#if !defined(__NR_clock_nanosleep_time64)
+#define __NR_clock_nanosleep_time64 (__NR_Linux + 407)
+#endif
+
#endif // SANDBOX_LINUX_SYSTEM_HEADERS_MIPS_LINUX_SYSCALLS_H_
--
2.33.0

View file

@ -28,13 +28,11 @@ _pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
0001-ARM-toolchain-fixes.patch
0002-Fix-ARM-skia-ICE.patch
0003-Run-blink-bindings-generation-single-threaded.patch
0004-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch)
0003-Run-blink-bindings-generation-single-threaded.patch)
sha256sums=('1f933cffb8671c1e71b6b2a4924cb6b3f9878388ae6298ac8d31a76c1ecffbb7'
'2f9388902350b706d85181e8a5864efe577b665afefb7328ad213a6c71b09d27'
'd7bfd8ed1db238c540935ff31539a54e4e807eb8c3013ed98f7dcc7367d35784'
'a24170d4576adebbfb8ee19dccd892f4038b9848765036b2ff78dbf590fc8138'
'9aed8036ca3d287fe86824e88e197f09fb2da45841e7a8cd87b6492b95cfdb3a')
'3dba0f507498ed078dbe5dc5753c593fa6babb7252be1cb964c404b62bf600ab'
'20f5f470bdd350e40046eb11cd786730aaa777a2ad6b68d004f7464313792320'
'005e5c1476b2c6e8edd6ab0637315cf268060090a7d3a89060a339f9ce4c9851')
prepare() {
cd $_pkgfn
@ -47,7 +45,6 @@ prepare() {
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
patch -p1 -i ${srcdir}/0003-Run-blink-bindings-generation-single-threaded.patch
patch -p1 -i ${srcdir}/0004-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch
}
build() {