core/linux-odroid-xu3 to 3.10.60-3

This commit is contained in:
Kevin Mihelich 2014-12-05 04:05:16 +00:00
parent 9f3f066f32
commit 134337b67a
3 changed files with 130 additions and 3 deletions

View file

@ -0,0 +1,35 @@
From 432f0d9800a3d7bcb9ad9bbb9470e744f71fe722 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 4 Dec 2014 20:59:39 -0700
Subject: [PATCH 1/2] remove thermal messages
---
drivers/thermal/exynos_thermal.c | 5 -----
1 file changed, 5 deletions(-)
diff --git a/drivers/thermal/exynos_thermal.c b/drivers/thermal/exynos_thermal.c
index 1cdb5fe..8aa1f40 100644
--- a/drivers/thermal/exynos_thermal.c
+++ b/drivers/thermal/exynos_thermal.c
@@ -510,10 +510,6 @@ void exynos_tmu_call_notifier(enum tmu_noti_state_t cur_state, int temp)
blocking_notifier_call_chain(&exynos_tmu_notifier, TMU_COLD, &cur_state);
else
blocking_notifier_call_chain(&exynos_tmu_notifier, cur_state, &tmu_old_state);
- if (cur_state == TMU_COLD)
- pr_info("tmu temperature state %d to %d\n", tmu_old_state, cur_state);
- else
- pr_info("tmu temperature state %d to %d, cur_temp : %d\n", tmu_old_state, cur_state, temp);
tmu_old_state = cur_state;
}
}
@@ -529,7 +525,6 @@ void exynos_gpu_call_notifier(enum gpu_noti_state_t cur_state)
cur_state = GPU_COLD;
if (cur_state != gpu_old_state) {
- pr_info("gpu temperature state %d to %d\n", gpu_old_state, cur_state);
blocking_notifier_call_chain(&exynos_gpu_notifier, cur_state, &cur_state);
gpu_old_state = cur_state;
}
--
2.1.3

View file

@ -0,0 +1,85 @@
From 7ace6c3d9febe7e9ae7499b1e91c6ed9cf726e1b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 4 Dec 2014 21:02:34 -0700
Subject: [PATCH 2/2] remove rtc messages
---
drivers/rtc/rtc-sec.c | 27 ---------------------------
1 file changed, 27 deletions(-)
diff --git a/drivers/rtc/rtc-sec.c b/drivers/rtc/rtc-sec.c
index 95d13bd..743678c 100644
--- a/drivers/rtc/rtc-sec.c
+++ b/drivers/rtc/rtc-sec.c
@@ -150,10 +150,6 @@ static int s2m_rtc_read_time(struct device *dev, struct rtc_time *tm)
s2m_data_to_tm(data, tm, info->rtc_24hr_mode);
- printk(KERN_INFO "%s: %d/%d/%d %d:%d:%d(%d)\n", __func__,
- 1900 + tm->tm_year, 1 + tm->tm_mon, tm->tm_mday,
- tm->tm_hour, tm->tm_min, tm->tm_sec, tm->tm_wday);
-
return rtc_valid_tm(tm);
}
@@ -171,10 +167,6 @@ static int s2m_rtc_set_time(struct device *dev, struct rtc_time *tm)
ret = s2m_rtc_set_time_reg(info, 0);
- printk(KERN_INFO "%s: %d/%d/%d %d:%d:%d(%d)\n", __func__,
- 1900 + tm->tm_year, 1 + tm->tm_mon, tm->tm_mday,
- tm->tm_hour, tm->tm_min, tm->tm_sec, tm->tm_wday);
-
return ret;
}
@@ -191,12 +183,6 @@ static int s2m_rtc_read_alarm(struct device *dev, struct rtc_wkalrm *alrm)
s2m_data_to_tm(data, &alrm->time, info->rtc_24hr_mode);
- printk(KERN_INFO "%s: %d/%d/%d %d:%d:%d(%d)\n", __func__,
- 1900 + alrm->time.tm_year, 1 + alrm->time.tm_mon,
- alrm->time.tm_mday, alrm->time.tm_hour,
- alrm->time.tm_min, alrm->time.tm_sec,
- alrm->time.tm_wday);
-
alrm->enabled = 0;
for (i = 0; i < 7; i++) {
@@ -275,10 +261,6 @@ static int s2m_rtc_stop_alarm(struct s2m_rtc_info *info)
s2m_data_to_tm(data, &tm, info->rtc_24hr_mode);
- printk(KERN_INFO "%s: %d/%d/%d %d:%d:%d(%d)\n", __func__,
- 1900 + tm.tm_year, 1 + tm.tm_mon, tm.tm_mday,
- tm.tm_hour, tm.tm_min, tm.tm_sec, tm.tm_wday);
-
for (i = 0; i < 7; i++)
data[i] &= ~ALARM_ENABLE_MASK;
@@ -302,10 +284,6 @@ static int s2m_rtc_start_alarm(struct s2m_rtc_info *info)
s2m_data_to_tm(data, &tm, info->rtc_24hr_mode);
- printk(KERN_INFO "%s: %d/%d/%d %d:%d:%d(%d)\n", __func__,
- 1900 + tm.tm_year, 1 + tm.tm_mon, tm.tm_mday,
- tm.tm_hour, tm.tm_min, tm.tm_sec, tm.tm_wday);
-
data[RTC_SEC] |= ALARM_ENABLE_MASK;
data[RTC_MIN] |= ALARM_ENABLE_MASK;
data[RTC_HOUR] |= ALARM_ENABLE_MASK;
@@ -334,11 +312,6 @@ static int s2m_rtc_set_alarm(struct device *dev, struct rtc_wkalrm *alrm)
s2m_tm_to_data(&alrm->time, data);
- printk(KERN_INFO "%s: %d/%d/%d %d:%d:%d(%d)\n", __func__,
- 1900 + alrm->time.tm_year, 1 + alrm->time.tm_mon,
- alrm->time.tm_mday, alrm->time.tm_hour, alrm->time.tm_min,
- alrm->time.tm_sec, alrm->time.tm_wday);
-
ret = s2m_rtc_stop_alarm(info);
if (ret < 0)
return ret;
--
2.1.3

View file

@ -9,16 +9,20 @@ _srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="ODROID-XU3"
pkgver=3.10.60
pkgrel=2
pkgrel=3
arch=('armv7h')
url="https://github.com/hardkernel/linux"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
'config')
'config'
'0001-remove-thermal-messages.patch'
'0002-remove-rtc-messages.patch')
md5sums=('51afdb99bd7d64c653d90b37a4039e2a'
'b42e274da4a8e3b848fe4c75d7dee379')
'b42e274da4a8e3b848fe4c75d7dee379'
'5e9df4f50e140c4491d0045fac025663'
'367bbb0892ce26c3627ecd5f95081e7c')
prepare() {
cd "${srcdir}/${_srcname}"
@ -30,6 +34,9 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
git apply ../0001-remove-thermal-messages.patch
git apply ../0002-remove-rtc-messages.patch
}
build() {