mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/nodejs to 8.0.0-1
This commit is contained in:
parent
7be4c63086
commit
134efa3403
3 changed files with 4 additions and 71 deletions
|
@ -9,8 +9,8 @@
|
|||
# Contributor: Jason Plum <jplum@archlinuxarm.org>
|
||||
|
||||
pkgname=nodejs
|
||||
pkgver=7.10.0
|
||||
pkgrel=2
|
||||
pkgver=8.0.0
|
||||
pkgrel=1
|
||||
pkgdesc='Evented I/O for V8 javascript'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://nodejs.org/'
|
||||
|
@ -20,10 +20,8 @@ depends=('openssl-1.0' 'zlib' 'icu' 'libuv' 'http-parser' 'c-ares') # 'v8')
|
|||
makedepends=('python2' 'procps-ng')
|
||||
optdepends=('npm: nodejs package manager')
|
||||
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz"
|
||||
'nodejs-v8-icu59.patch'
|
||||
'0001-arm-fixes.patch')
|
||||
sha512sums=('b5a1c5167e9f22fccdf61e33a28b03f12c5bb51e4ceefa27b021c5c7e0f3c2ed021cb7ee0b34ea8c4fbf7cafc7a2658a64a7eaa73d75c4905c10683be32bbeb3'
|
||||
'da8071f9b5d7c88c13b812cd422de412c7720a7644620be5e0af8fc79a4af8d8e764308b7607022953a0270c67a6cb2d98d5bad7c2c3974066ec348e4fe86c7b'
|
||||
sha512sums=('cb4d19fc68c5f40066aa0aa06bc92840931033056dbfb9852f4ac6a07dc711559459a01142e9e6e2f68480471930bb89f9f12388b8b806b05007b0be2619f18e'
|
||||
'4811e1d9bc0e03458072cad6af9284e3ceb6c74005ae00e3407c18d0e6eae0bce2edcbdbe547975ade916c1bcdb2bb53101edce2afeca0bcac84d8807934fc8c')
|
||||
|
||||
set_flags_for_arm() {
|
||||
|
@ -48,9 +46,6 @@ set_flags_for_arm() {
|
|||
prepare() {
|
||||
cd node-$pkgver
|
||||
|
||||
# https://github.com/nodejs/node/pull/11754#issuecomment-285407461
|
||||
patch -Np1 -d deps/v8 <../nodejs-v8-icu59.patch
|
||||
|
||||
patch -p1 -i ../0001-arm-fixes.patch
|
||||
|
||||
msg 'Fixing for python2 name'
|
||||
|
|
|
@ -1,63 +0,0 @@
|
|||
Index: src/i18n.cc
|
||||
diff --git a/src/i18n.cc b/src/i18n.cc
|
||||
index d2245ef34a9a319a53b4cf4b4ea05ec095fef2d5..7c22871ff5e440f771659d44a0db013b34ec2105 100644
|
||||
--- a/src/i18n.cc
|
||||
+++ b/src/i18n.cc
|
||||
@@ -30,8 +30,13 @@
|
||||
#include "unicode/ucol.h"
|
||||
#include "unicode/ucurr.h"
|
||||
#include "unicode/unum.h"
|
||||
+#include "unicode/uvernum.h"
|
||||
#include "unicode/uversion.h"
|
||||
|
||||
+#if U_ICU_VERSION_MAJOR_NUM >= 59
|
||||
+#include "unicode/char16ptr.h"
|
||||
+#endif
|
||||
+
|
||||
namespace v8 {
|
||||
namespace internal {
|
||||
|
||||
@@ -270,8 +275,13 @@ icu::DecimalFormat* CreateICUNumberFormat(
|
||||
}
|
||||
|
||||
UErrorCode status_digits = U_ZERO_ERROR;
|
||||
+#if U_ICU_VERSION_MAJOR_NUM >= 59
|
||||
uint32_t fraction_digits = ucurr_getDefaultFractionDigits(
|
||||
- currency.getTerminatedBuffer(), &status_digits);
|
||||
+ icu::toUCharPtr(currency.getTerminatedBuffer()), &status_digits);
|
||||
+#else
|
||||
+ uint32_t fraction_digits = ucurr_getDefaultFractionDigits(
|
||||
+ currency.getTerminatedBuffer(), &status_digits);
|
||||
+#endif
|
||||
if (U_SUCCESS(status_digits)) {
|
||||
number_format->setMinimumFractionDigits(fraction_digits);
|
||||
number_format->setMaximumFractionDigits(fraction_digits);
|
||||
Index: src/runtime/runtime-i18n.cc
|
||||
diff --git a/src/runtime/runtime-i18n.cc b/src/runtime/runtime-i18n.cc
|
||||
index 0b45381914641a824e36e99eaa0d315bf96252aa..e89175a37db11aa6990888e26e6bb989cf7c36b5 100644
|
||||
--- a/src/runtime/runtime-i18n.cc
|
||||
+++ b/src/runtime/runtime-i18n.cc
|
||||
@@ -43,6 +43,7 @@
|
||||
#include "unicode/uloc.h"
|
||||
#include "unicode/unistr.h"
|
||||
#include "unicode/unum.h"
|
||||
+#include "unicode/ustring.h"
|
||||
#include "unicode/uversion.h"
|
||||
|
||||
|
||||
@@ -609,10 +610,11 @@ RUNTIME_FUNCTION(Runtime_InternalCompare) {
|
||||
String::FlatContent flat2 = string2->GetFlatContent();
|
||||
std::unique_ptr<uc16[]> sap1;
|
||||
std::unique_ptr<uc16[]> sap2;
|
||||
- const UChar* string_val1 = GetUCharBufferFromFlat(flat1, &sap1, length1);
|
||||
- const UChar* string_val2 = GetUCharBufferFromFlat(flat2, &sap2, length2);
|
||||
- result =
|
||||
- collator->compare(string_val1, length1, string_val2, length2, status);
|
||||
+ icu::UnicodeString string_val1(
|
||||
+ FALSE, GetUCharBufferFromFlat(flat1, &sap1, length1), length1);
|
||||
+ icu::UnicodeString string_val2(
|
||||
+ FALSE, GetUCharBufferFromFlat(flat2, &sap2, length2), length2);
|
||||
+ result = collator->compare(string_val1, string_val2, status);
|
||||
}
|
||||
if (U_FAILURE(status)) return isolate->ThrowIllegalOperation();
|
||||
|
1
community/nodejs/rebuild.list
Normal file
1
community/nodejs/rebuild.list
Normal file
|
@ -0,0 +1 @@
|
|||
apm
|
Loading…
Reference in a new issue