mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/bullet to 2.86-1
This commit is contained in:
parent
784ef1d7dd
commit
137555f6d9
2 changed files with 38 additions and 7 deletions
23
extra/bullet/954.patch
Normal file
23
extra/bullet/954.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
From 04b3e88cdeb847efd3917b534bc53a74c572dcdf Mon Sep 17 00:00:00 2001
|
||||
From: Erwin Coumans <erwincoumans@google.com>
|
||||
Date: Tue, 7 Feb 2017 19:15:22 -0800
|
||||
Subject: [PATCH] Attempt to use VERSION string for CMakeLists.txt See Issue
|
||||
953, https://github.com/bulletphysics/bullet3/issues/953
|
||||
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 26e662c..66f8871 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -5,7 +5,7 @@ set(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS true)
|
||||
SET(MSVC_INCREMENTAL_DEFAULT ON)
|
||||
|
||||
PROJECT(BULLET_PHYSICS)
|
||||
-SET(BULLET_VERSION 2.85)
|
||||
+FILE (STRINGS "VERSION" BULLET_VERSION)
|
||||
|
||||
IF(COMMAND cmake_policy)
|
||||
cmake_policy(SET CMP0003 NEW)
|
|
@ -7,15 +7,23 @@
|
|||
|
||||
pkgbase=bullet
|
||||
pkgname=('bullet' 'bullet-docs')
|
||||
pkgver=2.85.1
|
||||
pkgrel=3
|
||||
pkgver=2.86
|
||||
pkgrel=1
|
||||
pkgdesc="A 3D Collision Detection and Rigid Body Dynamics Library for games and animation"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.bulletphysics.com/Bullet/"
|
||||
license=('custom:zlib')
|
||||
makedepends=('cmake' 'doxygen' 'graphviz' 'ttf-dejavu' 'mesa' 'glu' 'python' 'python-numpy')
|
||||
source=("https://github.com/bulletphysics/bullet3/archive/${pkgver}.tar.gz")
|
||||
md5sums=('194cf1ef1eeb7fa9ac7dc580219d3c8b')
|
||||
source=("https://github.com/bulletphysics/bullet3/archive/${pkgver}.tar.gz"
|
||||
954.patch)
|
||||
sha512sums=('af8a6b282ab606437d7975a59cd8a9c2bf273c83b0e79f0c4c1de6fa51695ba6d5f3c853dce2fdba9cb55e7572214e15089e54db51afc465ca26f502cbd5a4f9'
|
||||
'6ab8a2e3ac518705e09a4a5ca51ce5efd9d07918ad5374d3b69b3879239576ef1641ca86154e04345027503533ec5578aa5155131b83e927c2a09d34f44e9a70')
|
||||
|
||||
prepare() {
|
||||
cd bullet3-${pkgver}
|
||||
|
||||
patch -Np1 -i ${srcdir}/954.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd bullet3-${pkgver}
|
||||
|
@ -38,7 +46,6 @@ build() {
|
|||
make
|
||||
|
||||
cd ..
|
||||
#sed -i 's/GENERATE_HTMLHELP.*//g' Doxyfile
|
||||
doxygen
|
||||
}
|
||||
|
||||
|
@ -52,8 +59,9 @@ package_bullet() {
|
|||
|
||||
make DESTDIR=${pkgdir} install
|
||||
|
||||
install -Dm755 examples/pybullet/libpybullet.so.2.85 ${pkgdir}/usr/lib/libpybullet.so.2.85
|
||||
install -Dm755 examples/ExampleBrowser/libBulletExampleBrowserLib.so.2.85 ${pkgdir}/usr/lib/libBulletExampleBrowserLib.so.2.85
|
||||
ls examples/pybullet
|
||||
install -Dm755 examples/pybullet/pybullet.so.${pkgver} ${pkgdir}/usr/lib/libpybullet.so.${pkgver}
|
||||
install -Dm755 examples/ExampleBrowser/libBulletExampleBrowserLib.so.${pkgver} ${pkgdir}/usr/lib/libBulletExampleBrowserLib.so.${pkgver}
|
||||
install -Dm755 examples/OpenGLWindow/libOpenGLWindow.so ${pkgdir}/usr/lib/libOpenGLWindow.so
|
||||
install -Dm755 examples/ThirdPartyLibs/Gwen/libgwen.so ${pkgdir}/usr/lib/libgwen.so
|
||||
install -Dm755 examples/ThirdPartyLibs/BussIK/libBussIK.so ${pkgdir}/usr/lib/libBussIK.so
|
||||
|
|
Loading…
Reference in a new issue