core/linux downgraded to 3.1.10-1

This commit is contained in:
Kevin Mihelich 2012-01-29 17:23:21 -05:00
parent ca3733daba
commit 1392fc71f6
9 changed files with 917 additions and 968 deletions

View file

@ -8,15 +8,15 @@ pkgbase=linux
pkgname=('linux' 'linux-headers')
# pkgname=linux-custom # Build kernel with a different name
_kernelname=${pkgname#linux}
_basekernel=3.2
pkgver=${_basekernel}.1
_basekernel=3.1
pkgver=${_basekernel}.10
pkgrel=1
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage')
options=('!strip')
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.xz"
source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.bz2"
"ftp://ftp.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.bz2"
'archlinuxarm.patch'
'support.patch'
@ -25,17 +25,21 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${_basekernel}.tar.xz"
'aufs3-standalone.patch'
'aufs3-git-extras.patch'
'config'
'change-default-console-loglevel.patch')
md5sums=('364066fa18767ec0ae5f4e4abcf9dc51'
'31fc34340f11118873463a1d59d47b7f'
'642ee27498d0db67bb626acf88f2f786'
'mach-types::http://www.arm.linux.org.uk/developer/machines/download.php'
'change-default-console-loglevel.patch'
'usb-add-reset-resume-quirk-for-several-webcams.patch')
md5sums=('8d43453f8159b2332ad410b19d86a931'
'a8e1c25a93a685ec2a1c3a808715fe9d'
'7f3ec25d5ab2e368a05376d59e400850'
'f5d3635da03cb45904bedd69b47133de'
'3b763062a5503534c2e11c6d0f45b185'
'44a5461daf301a46adf20c475069aaa7'
'9c1d9e47a0991b9d3d1f1ede01171c04'
'8da3fed1e26cb1e76dd44e7a84872fd0'
'133e7ede6ffc62f77f8d6c8e9f79022d'
'9d3c56a4b999c8bfbd4018089a62f662')
'3f64ed9d71499fe9293dc671f4e4087e'
'29628745258df910abfb8cb24ca3ccd9'
'c9e6e8bb0774a89f7f9bd30a13be7532'
'55b04499a4578e586cf5a4d0b69fc5aa'
'1bc999c824910b5eab108a48e75302ad'
'ca6fec585152e0488ee04bc0b311ecf3'
'9d3c56a4b999c8bfbd4018089a62f662'
'd00814b57448895e65fbbc800e8a58ba')
build() {
cd "${srcdir}/linux-${_basekernel}"
@ -43,9 +47,14 @@ build() {
# add upstream patch
patch -p1 -i "${srcdir}/patch-${pkgver}"
# Add Arch Linux ARM patch for ARMv5te plug computers and requested additional support
# Add the USB_QUIRK_RESET_RESUME for several webcams
# FS#26528
patch -Np1 -i "${srcdir}/usb-add-reset-resume-quirk-for-several-webcams.patch"
# Add Arch Linux ARM patch for ARMv5te plug computers, requested additional support, mach-types
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
patch -Np1 -i "${srcdir}/support.patch"
cp "${srcdir}/mach-types" arch/arm/tools
# Add AUFS3 patches
patch -Np1 -i "${srcdir}/aufs3-kbuild.patch"
@ -101,7 +110,6 @@ package_linux() {
provides=('kernel26' 'aufs_friendly')
conflicts=('kernel26')
replaces=('kernel26')
backup=("etc/mkinitcpio.d/${pkgname}.preset")
install=${pkgname}.install
cd "${srcdir}/linux-${_basekernel}"

View file

@ -1,6 +1,6 @@
diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/dockstar-setup.c
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2012-01-21 19:54:46.000000000 -0700
--- a/arch/arm/mach-kirkwood/dockstar-setup.c 2011-10-24 07:10:05.000000000 +0000
+++ b/arch/arm/mach-kirkwood/dockstar-setup.c 2012-01-29 18:10:32.631138668 +0000
@@ -19,7 +19,6 @@
#include <asm/mach-types.h>
#include <asm/mach/arch.h>
@ -53,8 +53,8 @@ diff -urN a/arch/arm/mach-kirkwood/dockstar-setup.c b/arch/arm/mach-kirkwood/doc
};
diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/goflexhome-setup.c
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2012-01-21 23:29:42.000000000 -0700
--- a/arch/arm/mach-kirkwood/goflexhome-setup.c 1970-01-01 00:00:00.000000000 +0000
+++ b/arch/arm/mach-kirkwood/goflexhome-setup.c 2012-01-29 18:10:32.631138668 +0000
@@ -0,0 +1,123 @@
+/*
+ * arch/arm/mach-kirkwood/goflexhome-setup.c
@ -171,7 +171,7 @@ diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/g
+
+MACHINE_START(GOFLEXHOME, "Seagate GoFlex Home")
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
+ .atag_offset = 0x100,
+ .boot_params = 0x00000100,
+ .init_machine = goflexhome_init,
+ .map_io = kirkwood_map_io,
+ .init_early = kirkwood_init_early,
@ -180,8 +180,8 @@ diff -urN a/arch/arm/mach-kirkwood/goflexhome-setup.c b/arch/arm/mach-kirkwood/g
+MACHINE_END
+
diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/goflexnet-setup.c
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2012-01-21 23:29:47.000000000 -0700
--- a/arch/arm/mach-kirkwood/goflexnet-setup.c 1970-01-01 00:00:00.000000000 +0000
+++ b/arch/arm/mach-kirkwood/goflexnet-setup.c 2012-01-29 18:10:32.631138668 +0000
@@ -0,0 +1,176 @@
+/*
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
@ -351,7 +351,7 @@ diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/go
+
+MACHINE_START(GOFLEXNET, "Seagate GoFlex Net")
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
+ .atag_offset = 0x100,
+ .boot_params = 0x00000100,
+ .init_machine = goflexnet_init,
+ .map_io = kirkwood_map_io,
+ .init_early = kirkwood_init_early,
@ -360,8 +360,8 @@ diff -urN a/arch/arm/mach-kirkwood/goflexnet-setup.c b/arch/arm/mach-kirkwood/go
+MACHINE_END
+
diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/guruplug-setup.c
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2012-01-21 19:54:46.000000000 -0700
--- a/arch/arm/mach-kirkwood/guruplug-setup.c 2011-10-24 07:10:05.000000000 +0000
+++ b/arch/arm/mach-kirkwood/guruplug-setup.c 2012-01-29 18:10:32.701453479 +0000
@@ -57,22 +57,24 @@
static struct gpio_led guruplug_led_pins[] = {
@ -392,8 +392,8 @@ diff -urN a/arch/arm/mach-kirkwood/guruplug-setup.c b/arch/arm/mach-kirkwood/gur
.active_low = 1,
},
diff -urN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/iconnect-setup.c
--- a/arch/arm/mach-kirkwood/iconnect-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 2012-01-21 23:29:51.000000000 -0700
--- a/arch/arm/mach-kirkwood/iconnect-setup.c 1970-01-01 00:00:00.000000000 +0000
+++ b/arch/arm/mach-kirkwood/iconnect-setup.c 2012-01-29 18:10:32.701453479 +0000
@@ -0,0 +1,203 @@
+/*
+ * arch/arm/mach-kirkwood/iconnect-setup.c
@ -591,7 +591,7 @@ diff -urN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/ico
+
+
+MACHINE_START(ICONNECT, "Iomega iConnect Wireless")
+ .atag_offset = 0x100,
+ .boot_params = 0x00000100,
+ .init_machine = iconnect_init,
+ .map_io = kirkwood_map_io,
+ .init_early = kirkwood_init_early,
@ -599,8 +599,8 @@ diff -urN a/arch/arm/mach-kirkwood/iconnect-setup.c b/arch/arm/mach-kirkwood/ico
+ .timer = &kirkwood_timer,
+MACHINE_END
diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
--- a/arch/arm/mach-kirkwood/Kconfig 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/mach-kirkwood/Kconfig 2012-01-21 20:01:00.000000000 -0700
--- a/arch/arm/mach-kirkwood/Kconfig 2011-10-24 07:10:05.000000000 +0000
+++ b/arch/arm/mach-kirkwood/Kconfig 2012-01-29 18:11:29.007972046 +0000
@@ -64,6 +64,36 @@
Say 'Y' here if you want your kernel to support the
Seagate FreeAgent DockStar.
@ -623,24 +623,24 @@ diff -urN a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
+ Say 'Y' here if you want your kernel to support the
+ Iomega iConnect Wireless.
+
+config MACH_POGO_E02
+ bool "Pogoplug E02"
+ help
+ Say 'Y' here if you want your kernel to support the
+ CloudEngines Pogoplug e02.
+
+config MACH_POGOPLUGV4
+ bool "Pogoplug Series 4"
+ help
+ Say 'Y' here if you want your kernel to support the
+ Pogoplug Series 4.
+
+config MACH_POGO_E02
+ bool "CE Pogoplug E02"
+ help
+ Say 'Y' here if you want your kernel to support the
+ CloudEngines Pogoplug e02.
+
config MACH_OPENRD
bool
diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
--- a/arch/arm/mach-kirkwood/Makefile 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/mach-kirkwood/Makefile 2012-01-21 23:11:47.000000000 -0700
--- a/arch/arm/mach-kirkwood/Makefile 2011-10-24 07:10:05.000000000 +0000
+++ b/arch/arm/mach-kirkwood/Makefile 2012-01-29 18:11:44.610037721 +0000
@@ -8,6 +8,11 @@
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
@ -648,14 +648,14 @@ diff -urN a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
+obj-$(CONFIG_MACH_GOFLEXHOME) += goflexhome-setup.o
+obj-$(CONFIG_MACH_ICONNECT) += iconnect-setup.o
+obj-$(CONFIG_MACH_POGO_E02) += pogo_e02-setup.o
+obj-$(CONFIG_MACH_POGOPLUGV4) += pogoplugv4-setup.o
+obj-$(CONFIG_MACH_POGO_E02) += pogo_e02-setup.o
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
diff -urN a/arch/arm/mach-kirkwood/mpp.h b/arch/arm/mach-kirkwood/mpp.h
--- a/arch/arm/mach-kirkwood/mpp.h 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/mach-kirkwood/mpp.h 2012-01-21 19:54:46.000000000 -0700
--- a/arch/arm/mach-kirkwood/mpp.h 2011-10-24 07:10:05.000000000 +0000
+++ b/arch/arm/mach-kirkwood/mpp.h 2012-01-29 18:10:32.717078989 +0000
@@ -102,6 +102,7 @@
#define MPP11_SATA0_ACTn MPP( 11, 0x5, 0, 1, 0, 1, 1, 1, 1 )
@ -665,8 +665,8 @@ diff -urN a/arch/arm/mach-kirkwood/mpp.h b/arch/arm/mach-kirkwood/mpp.h
#define MPP12_AU_SPDIF0 MPP( 12, 0xa, 0, 1, 0, 0, 0, 0, 1 )
#define MPP12_SPI_MOSI MPP( 12, 0xb, 0, 1, 0, 0, 0, 0, 1 )
diff -urN a/arch/arm/mach-kirkwood/pogo_e02-setup.c b/arch/arm/mach-kirkwood/pogo_e02-setup.c
--- a/arch/arm/mach-kirkwood/pogo_e02-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/pogo_e02-setup.c 2012-01-21 23:29:56.000000000 -0700
--- a/arch/arm/mach-kirkwood/pogo_e02-setup.c 1970-01-01 00:00:00.000000000 +0000
+++ b/arch/arm/mach-kirkwood/pogo_e02-setup.c 2012-01-29 18:56:18.062423780 +0000
@@ -0,0 +1,114 @@
+/*
+ * arch/arm/mach-kirkwood/pogo_e02-setup.c
@ -775,7 +775,7 @@ diff -urN a/arch/arm/mach-kirkwood/pogo_e02-setup.c b/arch/arm/mach-kirkwood/pog
+}
+
+MACHINE_START(POGO_E02, "Pogoplug E02")
+ .atag_offset = 0x100,
+ .boot_params = 0x00000100,
+ .init_machine = pogo_e02_init,
+ .map_io = kirkwood_map_io,
+ .init_early = kirkwood_init_early,
@ -783,8 +783,8 @@ diff -urN a/arch/arm/mach-kirkwood/pogo_e02-setup.c b/arch/arm/mach-kirkwood/pog
+ .timer = &kirkwood_timer,
+MACHINE_END
diff -urN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/pogoplugv4-setup.c
--- a/arch/arm/mach-kirkwood/pogoplugv4-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b/arch/arm/mach-kirkwood/pogoplugv4-setup.c 2012-01-21 23:30:01.000000000 -0700
--- a/arch/arm/mach-kirkwood/pogoplugv4-setup.c 1970-01-01 00:00:00.000000000 +0000
+++ b/arch/arm/mach-kirkwood/pogoplugv4-setup.c 2012-01-29 18:10:32.717078989 +0000
@@ -0,0 +1,194 @@
+/*
+ * arch/arm/mach-kirkwood/pogoplugv4-setup.c
@ -973,7 +973,7 @@ diff -urN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/p
+
+MACHINE_START(POGOPLUGV4, "Pogoplug V4")
+ /* Maintainer: Kevin Mihelich <kevin@archlinuxarm.org> */
+ .atag_offset = 0x100,
+ .boot_params = 0x00000100,
+ .init_machine = pogoplugv4_init,
+ .map_io = kirkwood_map_io,
+ .init_early = kirkwood_init_early,
@ -981,8 +981,26 @@ diff -urN a/arch/arm/mach-kirkwood/pogoplugv4-setup.c b/arch/arm/mach-kirkwood/p
+ .timer = &kirkwood_timer,
+MACHINE_END
diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/sheevaplug-setup.c
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2012-01-21 19:54:46.000000000 -0700
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c 2011-10-24 07:10:05.000000000 +0000
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c 2012-01-29 18:34:56.420983884 +0000
@@ -43,7 +43,7 @@
.phy_addr = MV643XX_ETH_PHY_ADDR(0),
};
-static struct mv_sata_platform_data sheeva_esata_sata_data = {
+static struct mv_sata_platform_data esata_sheevaplug_sata_data = {
.n_ports = 2,
};
@@ -51,7 +51,7 @@
/* unfortunately the CD signal has not been connected */
};
-static struct mvsdio_platform_data sheeva_esata_mvsdio_data = {
+static struct mvsdio_platform_data esata_sheevaplug_mvsdio_data = {
.gpio_write_protect = 44, /* MPP44 used as SD write protect */
.gpio_card_detect = 47, /* MPP47 used as SD card detect */
};
@@ -64,7 +64,13 @@
.active_low = 1,
},
@ -998,7 +1016,7 @@ diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
.default_trigger = "default-on",
.gpio = 49,
.active_low = 1,
@@ -87,7 +93,8 @@
@@ -87,15 +93,18 @@
static unsigned int sheevaplug_mpp_config[] __initdata = {
MPP29_GPIO, /* USB Power Enable */
MPP46_GPIO, /* LED Red */
@ -1008,7 +1026,8 @@ diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
0
};
@@ -95,7 +102,9 @@
-static unsigned int sheeva_esata_mpp_config[] __initdata = {
+static unsigned int esata_sheevaplug_mpp_config[] __initdata = {
MPP29_GPIO, /* USB Power Enable */
MPP44_GPIO, /* SD Write Protect */
MPP47_GPIO, /* SD Card Detect */
@ -1019,12 +1038,31 @@ diff -urN a/arch/arm/mach-kirkwood/sheevaplug-setup.c b/arch/arm/mach-kirkwood/s
0
};
diff -urN a/arch/arm/tools/mach-types b/arch/arm/tools/mach-types
--- a/arch/arm/tools/mach-types 2012-01-04 16:55:44.000000000 -0700
+++ b/arch/arm/tools/mach-types 2012-01-21 19:55:49.000000000 -0700
@@ -1126,3 +1126,5 @@
m28evk MACH_M28EVK M28EVK 3613
smdk4212 MACH_SMDK4212 SMDK4212 3638
smdk4412 MACH_SMDK4412 SMDK4412 3765
+pogo_e02 MACH_POGO_E02 POGO_E02 3542
+pogoplugv4 MACH_POGOPLUGV4 POGOPLUGV4 3960
@@ -107,8 +116,8 @@
kirkwood_init();
/* setup gpio pin select */
- if (machine_is_sheeva_esata())
- kirkwood_mpp_conf(sheeva_esata_mpp_config);
+ if (machine_is_esata_sheevaplug())
+ kirkwood_mpp_conf(esata_sheevaplug_mpp_config);
else
kirkwood_mpp_conf(sheevaplug_mpp_config);
@@ -123,12 +132,12 @@
kirkwood_ge00_init(&sheevaplug_ge00_data);
/* honor lower power consumption for plugs with out eSATA */
- if (machine_is_sheeva_esata())
- kirkwood_sata_init(&sheeva_esata_sata_data);
+ if (machine_is_esata_sheevaplug())
+ kirkwood_sata_init(&esata_sheevaplug_sata_data);
/* enable sd wp and sd cd on plugs with esata */
- if (machine_is_sheeva_esata())
- kirkwood_sdio_init(&sheeva_esata_mvsdio_data);
+ if (machine_is_esata_sheevaplug())
+ kirkwood_sdio_init(&esata_sheevaplug_mvsdio_data);
else
kirkwood_sdio_init(&sheevaplug_mvsdio_data);

View file

@ -1,10 +1,10 @@
aufs3.2 base patch
aufs3.1 base patch
diff --git a/fs/namei.c b/fs/namei.c
index 5008f01..4cc94cf 100644
index 0b3138d..8edad02 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1753,7 +1753,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
@@ -1748,7 +1748,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@ -42,10 +42,10 @@ index fa2defa..e3569b0 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index ffc0213..ef35a31 100644
index 409328d..40afdc0 100644
--- a/include/linux/namei.h
+++ b/include/linux/namei.h
@@ -85,6 +85,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
@@ -84,6 +84,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
int (*open)(struct inode *, struct file *));

File diff suppressed because it is too large Load diff

View file

@ -1,7 +1,7 @@
aufs3.2 kbuild patch
aufs3.1 kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index 5f4c45d..357a8a6 100644
index 9fe0b34..c4311f8 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -215,6 +215,7 @@ source "fs/pstore/Kconfig"
@ -13,11 +13,11 @@ index 5f4c45d..357a8a6 100644
endif # MISC_FILESYSTEMS
diff --git a/fs/Makefile b/fs/Makefile
index d2c3353..680ad8a 100644
index afc1096..5c5ac76 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -123,3 +123,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-y += exofs/ # Multiple modules
obj-$(CONFIG_EXOFS_FS) += exofs/
obj-$(CONFIG_CEPH_FS) += ceph/
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/

View file

@ -1,4 +1,4 @@
aufs3.2 standalone patch
aufs3.1 standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index c322794..2aad244 100644
@ -14,7 +14,7 @@ index c322794..2aad244 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index ee4e66b..728042b 100644
index ec79246..46ac6f9 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -65,6 +65,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
@ -26,10 +26,10 @@ index ee4e66b..728042b 100644
/*
* Empty aops. Can be used for the cases where the user does not
diff --git a/fs/namei.c b/fs/namei.c
index 4cc94cf..af19e30 100644
index 8edad02..50e8718 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1757,6 +1757,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1752,6 +1752,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@ -38,10 +38,10 @@ index 4cc94cf..af19e30 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index cfc6d44..173d15a 100644
index b4febb2..598a308 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1506,6 +1506,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1508,6 +1508,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -111,7 +111,7 @@ index e14587d..be6533b 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index 22c41b5..33b4033 100644
index f711921..d742fc0 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -143,27 +143,19 @@ index e3569b0..9dc07b7 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
index ee4f848..611fd70 100644
index a93b3b7..024282c 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -975,3 +975,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
@@ -971,3 +971,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
}
return ret;
}
+EXPORT_SYMBOL(cap_file_mmap);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 4450fbe..bc94175 100644
index 4450fbe..2c437e5 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
#include <linux/device_cgroup.h>
#include <linux/cgroup.h>
#include <linux/ctype.h>
+#include <linux/export.h>
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -500,6 +501,7 @@ found:
@@ -500,6 +500,7 @@ found:
return -EPERM;
}
@ -172,10 +164,10 @@ index 4450fbe..bc94175 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index e2f684a..892000c 100644
index d9e1533..466ee5c 100644
--- a/security/security.c
+++ b/security/security.c
@@ -411,6 +411,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@@ -373,6 +373,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@ -183,7 +175,7 @@ index e2f684a..892000c 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
@@ -427,6 +428,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
@@ -389,6 +390,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@ -191,7 +183,7 @@ index e2f684a..892000c 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
@@ -435,6 +437,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
@@ -397,6 +399,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@ -199,7 +191,7 @@ index e2f684a..892000c 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
@@ -453,6 +456,7 @@ int security_path_truncate(struct path *path)
@@ -415,6 +418,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@ -207,7 +199,7 @@ index e2f684a..892000c 100644
int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
mode_t mode)
@@ -461,6 +465,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
@@ -423,6 +427,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
return 0;
return security_ops->path_chmod(dentry, mnt, mode);
}
@ -215,7 +207,7 @@ index e2f684a..892000c 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
@@ -468,6 +473,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
@@ -430,6 +435,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@ -223,7 +215,7 @@ index e2f684a..892000c 100644
int security_path_chroot(struct path *path)
{
@@ -544,6 +550,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -506,6 +512,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@ -231,7 +223,7 @@ index e2f684a..892000c 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
@@ -558,6 +565,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -520,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
}
@ -239,7 +231,7 @@ index e2f684a..892000c 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -673,6 +681,7 @@ int security_file_permission(struct file *file, int mask)
@@ -619,6 +627,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -247,7 +239,7 @@ index e2f684a..892000c 100644
int security_file_alloc(struct file *file)
{
@@ -700,6 +709,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
@@ -646,6 +655,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}

File diff suppressed because it is too large Load diff

View file

@ -2,7 +2,7 @@
# arg 2: the old package version
KERNEL_NAME=
KERNEL_VERSION=3.2.1-1-ARCH
KERNEL_VERSION=3.1.10-1-ARCH
post_install () {
# updating module dependencies
@ -14,6 +14,7 @@ post_upgrade() {
if grep "^[^#]*[[:space:]]/boot" etc/fstab 2>&1 >/dev/null; then
if ! grep "[[:space:]]/boot" etc/mtab 2>&1 >/dev/null; then
echo "WARNING: /boot appears to be a seperate partition but is not mounted."
echo " You probably just broke your system. Congratulations."
fi
fi

View file

@ -0,0 +1,98 @@
commit 2394d67e446bf616a0885167d5f0d397bdacfdfc
Author: Oliver Neukum <oneukum@suse.de>
Date: Tue Sep 13 08:42:21 2011 +0200
USB: add RESET_RESUME for webcams shown to be quirky
The new runtime PM code has shown that many webcams suffer
from a race condition that may crash them upon resume.
Runtime PM is especially prone to show the problem because
it retains power to the cameras at all times. However
system suspension may also crash the devices and retain
power to the devices.
The only way to solve this problem without races is in
usbcore with the RESET_RESUME quirk.
Signed-off-by: Oliver Neukum <oneukum@suse.de>
Signed-off-by: stable <stable@kernel.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
index 81ce6a8..38f0510 100644
--- a/drivers/usb/core/quirks.c
+++ b/drivers/usb/core/quirks.c
@@ -38,6 +38,24 @@ static const struct usb_device_id usb_quirk_list[] = {
/* Creative SB Audigy 2 NX */
{ USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },
+ /* Logitech Webcam C200 */
+ { USB_DEVICE(0x046d, 0x0802), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C250 */
+ { USB_DEVICE(0x046d, 0x0804), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam B/C500 */
+ { USB_DEVICE(0x046d, 0x0807), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam Pro 9000 */
+ { USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C310 */
+ { USB_DEVICE(0x046d, 0x081b), .driver_info = USB_QUIRK_RESET_RESUME },
+
+ /* Logitech Webcam C270 */
+ { USB_DEVICE(0x046d, 0x0825), .driver_info = USB_QUIRK_RESET_RESUME },
+
/* Logitech Harmony 700-series */
{ USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },
@@ -69,6 +87,9 @@ static const struct usb_device_id usb_quirk_list[] = {
{ USB_DEVICE(0x06a3, 0x0006), .driver_info =
USB_QUIRK_CONFIG_INTF_STRINGS },
+ /* Guillemot Webcam Hercules Dualpix Exchange*/
+ { USB_DEVICE(0x06f8, 0x0804), .driver_info = USB_QUIRK_RESET_RESUME },
+
/* M-Systems Flash Disk Pioneers */
{ USB_DEVICE(0x08ec, 0x1000), .driver_info = USB_QUIRK_RESET_RESUME },
commit 5b253d88cc6c65a23cefc457a5a4ef139913c5fc
Author: Jon Levell <linuxusb@coralbark.net>
Date: Thu Sep 29 20:42:52 2011 +0100
USB: add quirk for Logitech C300 web cam
My webcam is a Logitech C300 and I get "chipmunk"ed squeaky sound.
The following trivial patch fixes it.
Signed-off-by: Jon Levell <linuxusb@coralbark.net>
Cc: stable <stable@kernel.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
index 38f0510..d6a8d82 100644
--- a/drivers/usb/core/quirks.c
+++ b/drivers/usb/core/quirks.c
@@ -44,6 +44,9 @@ static const struct usb_device_id usb_quirk_list[] = {
/* Logitech Webcam C250 */
{ USB_DEVICE(0x046d, 0x0804), .driver_info = USB_QUIRK_RESET_RESUME },
+ /* Logitech Webcam C300 */
+ { USB_DEVICE(0x046d, 0x0805), .driver_info = USB_QUIRK_RESET_RESUME },
+
/* Logitech Webcam B/C500 */
{ USB_DEVICE(0x046d, 0x0807), .driver_info = USB_QUIRK_RESET_RESUME },
diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
index d6a8d82..caa1991 100644
--- a/drivers/usb/core/quirks.c
+++ b/drivers/usb/core/quirks.c
@@ -50,6 +50,9 @@ static const struct usb_device_id usb_quirk_list[] = {
/* Logitech Webcam B/C500 */
{ USB_DEVICE(0x046d, 0x0807), .driver_info = USB_QUIRK_RESET_RESUME },
+ /* Logitech Webcam C600 */
+ { USB_DEVICE(0x046d, 0x0808), .driver_info = USB_QUIRK_RESET_RESUME },
+
/* Logitech Webcam Pro 9000 */
{ USB_DEVICE(0x046d, 0x0809), .driver_info = USB_QUIRK_RESET_RESUME },