mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added community/classpath
This commit is contained in:
parent
4f8a27c348
commit
139eacc72f
3 changed files with 134 additions and 0 deletions
82
community/classpath/PKGBUILD
Normal file
82
community/classpath/PKGBUILD
Normal file
|
@ -0,0 +1,82 @@
|
|||
# $Id$
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Maintainer: tardo <tardo@nagi-fanboi.net>
|
||||
# Contributor: Sean Gillespie <Sean.D.Gillespie@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - AArch64 patch
|
||||
|
||||
pkgname=classpath
|
||||
pkgver=0.99
|
||||
pkgrel=1
|
||||
pkgdesc="A free replacement for Sun's proprietary core Java class libraries."
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/classpath/"
|
||||
license=('GPL')
|
||||
depends=('gtk2>=2.8' 'libxtst' 'libsm' 'freetype2')
|
||||
makedepends=('gtk2>=2.8' 'libxtst' 'gconf' 'java-environment' 'antlr2')
|
||||
optdepends=('file' 'gconf')
|
||||
source=(ftp://ftp.gnu.org/gnu/classpath/$pkgname-$pkgver.tar.gz freetype2_include.patch
|
||||
aarch64.patch)
|
||||
md5sums=('0ae1571249172acd82488724a3b8acb4'
|
||||
'55dafc301c5f2e497696d01e9c1dab9c'
|
||||
'5a5548d07da9155b1172e04ef65952e5')
|
||||
|
||||
prepare() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
||||
patch -p0 Makefile.in <<EOF
|
||||
298,299c298,299
|
||||
< SUBDIRS = lib doc external include native resource scripts \$(TOOLSDIR) \$(EXAMPLESDIR)
|
||||
< DIST_SUBDIRS = lib doc external include native resource scripts tools examples
|
||||
---
|
||||
> SUBDIRS = lib doc external include native resource scripts
|
||||
> DIST_SUBDIRS = lib doc external include native resource scripts
|
||||
EOF
|
||||
|
||||
# fix freetype2 include path
|
||||
patch -Np1 -i $srcdir/freetype2_include.patch
|
||||
|
||||
# add AArch64 support
|
||||
patch -p1 -i ../aarch64.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
./configure --prefix=/usr --disable-Werror --disable-plugin \
|
||||
--with-antlr-jar=/usr/share/java/antlr2.jar
|
||||
make EXAMPLESDIR=
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
make EXAMPLESDIR= DESTDIR=$pkgdir install
|
||||
|
||||
rm -f $pkgdir/usr/bin/gappletviewer
|
||||
rm -f $pkgdir/usr/bin/gjar
|
||||
rm -f $pkgdir/usr/bin/gjarsigner
|
||||
rm -f $pkgdir/usr/bin/gjavah
|
||||
rm -f $pkgdir/usr/bin/gkeytool
|
||||
rm -f $pkgdir/usr/bin/gnative2ascii
|
||||
rm -f $pkgdir/usr/bin/gorbd
|
||||
rm -f $pkgdir/usr/bin/grmic
|
||||
rm -f $pkgdir/usr/bin/grmid
|
||||
rm -f $pkgdir/usr/bin/grmiregistry
|
||||
rm -f $pkgdir/usr/bin/gserialver
|
||||
rm -f $pkgdir/usr/bin/gtnameserv
|
||||
rm -f $pkgdir/usr/lib/logging.properties
|
||||
rm -f $pkgdir/usr/lib/security/classpath.security
|
||||
rm -f $pkgdir/usr/share/man/man1/gappletviewer.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gcjh.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gjar.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gjarsigner.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gjavah.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gkeytool.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gnative2ascii.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gorbd.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/grmid.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/grmiregistry.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gserialver.1*
|
||||
rm -f $pkgdir/usr/share/man/man1/gtnameserv.1*
|
||||
rm -f $pkgdir/usr/share/info/dir
|
||||
}
|
18
community/classpath/aarch64.patch
Normal file
18
community/classpath/aarch64.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
diff -urN a/native/fdlibm/ieeefp.h b/native/fdlibm/ieeefp.h
|
||||
--- a/native/fdlibm/ieeefp.h 2008-01-13 10:33:50.000000000 -0700
|
||||
+++ b/native/fdlibm/ieeefp.h 2015-07-25 10:17:49.689641997 -0600
|
||||
@@ -4,6 +4,14 @@
|
||||
#ifndef __IEEE_BIG_ENDIAN
|
||||
#ifndef __IEEE_LITTLE_ENDIAN
|
||||
|
||||
+#ifdef __aarch64__
|
||||
+#ifdef __AARCH64EB__
|
||||
+#define __IEEE_BIG_ENDIAN
|
||||
+#else
|
||||
+#define __IEEE_LITTLE_ENDIAN
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
#ifdef __alpha__
|
||||
#define __IEEE_LITTLE_ENDIAN
|
||||
#endif
|
34
community/classpath/freetype2_include.patch
Normal file
34
community/classpath/freetype2_include.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
diff -aur classpath-0.98/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c classpath-0.98.new/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c
|
||||
--- classpath-0.98/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c 2008-12-18 01:43:41.000000000 +0100
|
||||
+++ classpath-0.98.new/native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c 2014-03-11 22:03:55.888827143 +0100
|
||||
@@ -42,8 +42,9 @@
|
||||
#include <pango/pango.h>
|
||||
#include <pango/pangoft2.h>
|
||||
#include <pango/pangofc-font.h>
|
||||
-#include <freetype/ftglyph.h>
|
||||
-#include <freetype/ftoutln.h>
|
||||
+#include <ft2build.h>
|
||||
+#include FT_GLYPH_H
|
||||
+#include FT_OUTLINE_H
|
||||
#include "jcl.h"
|
||||
#include "gdkfont.h"
|
||||
#include "gnu_java_awt_peer_gtk_FreetypeGlyphVector.h"
|
||||
diff -aur classpath-0.98/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c classpath-0.98.new/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c
|
||||
--- classpath-0.98/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c 2007-04-25 16:53:04.000000000 +0200
|
||||
+++ classpath-0.98.new/native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c 2014-03-11 22:03:18.788834707 +0100
|
||||
@@ -39,10 +39,11 @@
|
||||
#include <pango/pango.h>
|
||||
#include <pango/pangoft2.h>
|
||||
#include <pango/pangofc-font.h>
|
||||
-#include <freetype/ftglyph.h>
|
||||
-#include <freetype/ftoutln.h>
|
||||
-#include <freetype/fttypes.h>
|
||||
-#include <freetype/tttables.h>
|
||||
+#include <ft2build.h>
|
||||
+#include FT_GLYPH_H
|
||||
+#include FT_OUTLINE_H
|
||||
+#include FT_TYPES_H
|
||||
+#include FT_TRUETYPE_TABLES_H
|
||||
#include "gdkfont.h"
|
||||
#include "gtkpeer.h"
|
||||
#include "gnu_java_awt_peer_gtk_GdkFontPeer.h"
|
Loading…
Reference in a new issue