mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/gcc: remove armhf patch (#582)
This commit is contained in:
parent
f7bfcb3416
commit
1484734c58
2 changed files with 0 additions and 111 deletions
|
@ -27,7 +27,6 @@ checkdepends=('dejagnu' 'inetutils')
|
|||
options=('!libtool' '!emptydirs' '!distcc')
|
||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
armhf-triplet-trunk.diff
|
||||
gcc-4.8-filename-output.patch)
|
||||
md5sums=('a3d7d63b9cb6b6ea049469a0c4a43c9d'
|
||||
'bd7330bd41845929f1e0efb3b7d0a060'
|
||||
|
|
|
@ -1,110 +0,0 @@
|
|||
diff -urN a/gcc/ada/gcc-interface/Makefile.in b/gcc/ada/gcc-interface/Makefile.in
|
||||
--- a/gcc/ada/gcc-interface/Makefile.in 2012-06-12 09:12:37.000000000 -0600
|
||||
+++ b/gcc/ada/gcc-interface/Makefile.in 2012-07-06 19:53:20.740322776 -0600
|
||||
@@ -1867,7 +1867,7 @@
|
||||
LIBRARY_VERSION := $(LIB_VERSION)
|
||||
endif
|
||||
|
||||
-ifeq ($(strip $(filter-out arm% linux-gnueabi,$(arch) $(osys)-$(word 4,$(targ)))),)
|
||||
+ifeq ($(strip $(filter-out arm%-linux,$(arch)-$(osys)) $(if $(findstring eabi,$(word 4,$(targ))),,$(word 4,$(targ)))),)
|
||||
LIBGNAT_TARGET_PAIRS = \
|
||||
a-intnam.ads<a-intnam-linux.ads \
|
||||
s-inmaop.adb<s-inmaop-posix.adb \
|
||||
diff -urN a/gcc/config.gcc b/gcc/config.gcc
|
||||
--- a/gcc/config.gcc 2012-06-04 03:51:00.000000000 -0600
|
||||
+++ b/gcc/config.gcc 2012-07-06 19:53:20.724697276 -0600
|
||||
@@ -842,7 +842,7 @@
|
||||
esac
|
||||
tmake_file="${tmake_file} arm/t-arm"
|
||||
case ${target} in
|
||||
- arm*-*-linux-*eabi)
|
||||
+ arm*-*-linux-*eabi*)
|
||||
tm_file="$tm_file arm/bpabi.h arm/linux-eabi.h"
|
||||
tmake_file="$tmake_file arm/t-arm-elf arm/t-bpabi arm/t-linux-eabi"
|
||||
# Define multilib configuration for arm-linux-androideabi.
|
||||
@@ -869,7 +869,7 @@
|
||||
tm_file="dbxelf.h elfos.h arm/unknown-elf.h arm/elf.h arm/linux-gas.h arm/uclinux-elf.h glibc-stdint.h"
|
||||
tmake_file="arm/t-arm arm/t-arm-elf"
|
||||
case ${target} in
|
||||
- arm*-*-uclinux*eabi)
|
||||
+ arm*-*-uclinux*eabi*)
|
||||
tm_file="$tm_file arm/bpabi.h arm/uclinux-eabi.h"
|
||||
tmake_file="$tmake_file arm/t-bpabi"
|
||||
# The BPABI long long divmod functions return a 128-bit value in
|
||||
diff -urN a/gcc/testsuite/lib/target-supports.exp b/gcc/testsuite/lib/target-supports.exp
|
||||
--- a/gcc/testsuite/lib/target-supports.exp 2012-04-09 03:24:22.000000000 -0600
|
||||
+++ b/gcc/testsuite/lib/target-supports.exp 2012-07-06 19:53:20.732510026 -0600
|
||||
@@ -3840,7 +3840,7 @@
|
||||
|| [istarget i?86-*-*]
|
||||
|| [istarget x86_64-*-*]
|
||||
|| [istarget alpha*-*-*]
|
||||
- || [istarget arm*-*-linux-gnueabi]
|
||||
+ || [istarget arm*-*-linux-*eabi*]
|
||||
|| [istarget bfin*-*linux*]
|
||||
|| [istarget hppa*-*linux*]
|
||||
|| [istarget s390*-*-*]
|
||||
@@ -3870,7 +3870,7 @@
|
||||
|| [istarget i?86-*-*]
|
||||
|| [istarget x86_64-*-*]
|
||||
|| [istarget alpha*-*-*]
|
||||
- || [istarget arm*-*-linux-gnueabi]
|
||||
+ || [istarget arm*-*-linux-*eabi*]
|
||||
|| [istarget hppa*-*linux*]
|
||||
|| [istarget s390*-*-*]
|
||||
|| [istarget powerpc*-*-*]
|
||||
diff -urN a/libgcc/config.host b/libgcc/config.host
|
||||
--- a/libgcc/config.host 2012-04-30 11:39:57.000000000 -0600
|
||||
+++ b/libgcc/config.host 2012-07-06 19:53:20.787199276 -0600
|
||||
@@ -327,7 +327,7 @@
|
||||
arm*-*-linux*) # ARM GNU/Linux with ELF
|
||||
tmake_file="${tmake_file} arm/t-arm t-fixedpoint-gnu-prefix"
|
||||
case ${host} in
|
||||
- arm*-*-linux-*eabi)
|
||||
+ arm*-*-linux-*eabi*)
|
||||
tmake_file="${tmake_file} arm/t-elf arm/t-bpabi arm/t-linux-eabi t-slibgcc-libgcc"
|
||||
tm_file="$tm_file arm/bpabi-lib.h"
|
||||
unwind_header=config/arm/unwind-arm.h
|
||||
diff -urN a/libjava/configure.ac b/libjava/configure.ac
|
||||
--- a/libjava/configure.ac 2012-05-21 12:14:01.000000000 -0600
|
||||
+++ b/libjava/configure.ac 2012-07-06 19:53:20.709071776 -0600
|
||||
@@ -931,7 +931,7 @@
|
||||
# on Darwin -single_module speeds up loading of the dynamic libraries.
|
||||
extra_ldflags_libjava=-Wl,-single_module
|
||||
;;
|
||||
-arm*linux*eabi)
|
||||
+arm*-*-linux-*eabi*)
|
||||
# Some of the ARM unwinder code is actually in libstdc++. We
|
||||
# could in principle replicate it in libgcj, but it's better to
|
||||
# have a dependency on libstdc++.
|
||||
diff -urN a/libstdc++-v3/configure.host b/libstdc++-v3/configure.host
|
||||
--- a/libstdc++-v3/configure.host 2012-02-10 11:10:12.000000000 -0700
|
||||
+++ b/libstdc++-v3/configure.host 2012-07-06 19:53:20.748135526 -0600
|
||||
@@ -340,7 +340,7 @@
|
||||
fi
|
||||
esac
|
||||
case "${host}" in
|
||||
- arm*-*-linux-*eabi)
|
||||
+ arm*-*-linux-*eabi*)
|
||||
port_specific_symbol_files="\$(srcdir)/../config/os/gnu-linux/arm-eabi-extra.ver"
|
||||
;;
|
||||
esac
|
||||
diff -urN a/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc b/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc
|
||||
--- a/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc 2011-09-21 05:23:11.000000000 -0600
|
||||
+++ b/libstdc++-v3/testsuite/20_util/make_signed/requirements/typedefs-2.cc 2012-07-06 19:53:20.771573776 -0600
|
||||
@@ -1,5 +1,5 @@
|
||||
// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums" }
|
||||
-// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux*eabi } }
|
||||
+// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux-*eabi* } }
|
||||
|
||||
// 2007-05-03 Benjamin Kosnik <bkoz@redhat.com>
|
||||
//
|
||||
diff -urN a/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc b/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc
|
||||
--- a/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc 2011-09-21 05:23:11.000000000 -0600
|
||||
+++ b/libstdc++-v3/testsuite/20_util/make_unsigned/requirements/typedefs-2.cc 2012-07-06 19:53:20.763761026 -0600
|
||||
@@ -1,5 +1,5 @@
|
||||
// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums" }
|
||||
-// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux*eabi } }
|
||||
+// { dg-options "-std=gnu++0x -funsigned-char -fshort-enums -Wl,--no-enum-size-warning" { target arm*-*-linux-*eabi* } }
|
||||
|
||||
// 2007-05-03 Benjamin Kosnik <bkoz@redhat.com>
|
||||
//
|
Loading…
Reference in a new issue