mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/tarantool to 2.0.4.r497-4
This commit is contained in:
parent
e0d40e0284
commit
14a205cef6
2 changed files with 53 additions and 1 deletions
|
@ -8,7 +8,7 @@ buildarch=12
|
||||||
pkgname=tarantool
|
pkgname=tarantool
|
||||||
_commit=9a543202c93ef903b07b293463650d78002ae866
|
_commit=9a543202c93ef903b07b293463650d78002ae866
|
||||||
pkgver=2.0.4.r497
|
pkgver=2.0.4.r497
|
||||||
pkgrel=3
|
pkgrel=4
|
||||||
pkgdesc='Lua application server integrated with a database management system'
|
pkgdesc='Lua application server integrated with a database management system'
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url='https://www.tarantool.org'
|
url='https://www.tarantool.org'
|
||||||
|
@ -25,6 +25,7 @@ source=(git+https://github.com/tarantool/tarantool.git#commit=$_commit
|
||||||
git+https://github.com/tarantool/small.git
|
git+https://github.com/tarantool/small.git
|
||||||
git+https://github.com/tarantool/zstd.git
|
git+https://github.com/tarantool/zstd.git
|
||||||
git+https://github.com/tarantool/luarocks.git#branch=tarantool-1.7
|
git+https://github.com/tarantool/luarocks.git#branch=tarantool-1.7
|
||||||
|
libcurl-7.62.patch
|
||||||
tarantool.sysusers)
|
tarantool.sysusers)
|
||||||
sha1sums=('SKIP'
|
sha1sums=('SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
|
@ -35,6 +36,7 @@ sha1sums=('SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
|
'8308459e0d3832cbdf37b8aa678fde37ed627fce'
|
||||||
'9021b3d50e45f719f0304ab529627cac69a7a149')
|
'9021b3d50e45f719f0304ab529627cac69a7a149')
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
|
@ -44,6 +46,10 @@ pkgver() {
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd tarantool
|
cd tarantool
|
||||||
|
|
||||||
|
# https://github.com/tarantool/tarantool/commit/02da15f710
|
||||||
|
patch -Np1 -i ../libcurl-7.62.patch
|
||||||
|
|
||||||
git submodule init
|
git submodule init
|
||||||
git config -f .gitmodules 'submodule.third_party/luajit.url' "$srcdir/luajit"
|
git config -f .gitmodules 'submodule.third_party/luajit.url' "$srcdir/luajit"
|
||||||
git config -f .gitmodules 'submodule.src/lib/msgpuck.url' "$srcdir/msgpuck"
|
git config -f .gitmodules 'submodule.src/lib/msgpuck.url' "$srcdir/msgpuck"
|
||||||
|
|
46
community/tarantool/libcurl-7.62.patch
Normal file
46
community/tarantool/libcurl-7.62.patch
Normal file
|
@ -0,0 +1,46 @@
|
||||||
|
From 02da15f7109b8bb7921eb97a751607b9dd2885b2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Vladimir Davydov <vdavydov.dev@gmail.com>
|
||||||
|
Date: Thu, 1 Nov 2018 13:35:24 +0300
|
||||||
|
Subject: [PATCH] httpc: fix compilation with libcurl >= 7.62.0
|
||||||
|
|
||||||
|
Starting from libcurl 7.62.0, CURL_SSL_CACERT is defined as a macro
|
||||||
|
alias to CURLE_PEER_FAILED_VERIFICATION, see
|
||||||
|
|
||||||
|
https://github.com/curl/curl/commit/3f3b26d6feb0667714902e836af608094235fca2
|
||||||
|
|
||||||
|
This breaks compilation:
|
||||||
|
|
||||||
|
httpc.c:337:7: error: duplicate case value 'CURLE_PEER_FAILED_VERIFICATION'
|
||||||
|
case CURLE_PEER_FAILED_VERIFICATION:
|
||||||
|
^
|
||||||
|
httpc.c:336:7: note: previous case defined here
|
||||||
|
case CURLE_SSL_CACERT:
|
||||||
|
^
|
||||||
|
curl.h:589:26: note: expanded from macro 'CURLE_SSL_CACERT'
|
||||||
|
#define CURLE_SSL_CACERT CURLE_PEER_FAILED_VERIFICATION
|
||||||
|
^
|
||||||
|
|
||||||
|
Fix this by using CURLE_SSL_CACERT only if libcurl version is less
|
||||||
|
than 7.62.0.
|
||||||
|
|
||||||
|
Note, we can't use CURL_AT_LEAST_VERSION to check libcurl version,
|
||||||
|
because it isn't available in libcurl shipped with CentOS 6.
|
||||||
|
---
|
||||||
|
src/httpc.c | 4 +++-
|
||||||
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/httpc.c b/src/httpc.c
|
||||||
|
index 4d48a313d8..950f8b32f6 100644
|
||||||
|
--- a/src/httpc.c
|
||||||
|
+++ b/src/httpc.c
|
||||||
|
@@ -333,7 +333,9 @@ httpc_execute(struct httpc_request *req, double timeout)
|
||||||
|
++env->stat.http_other_responses;
|
||||||
|
}
|
||||||
|
break;
|
||||||
|
- case CURLE_SSL_CACERT:
|
||||||
|
+#if LIBCURL_VERSION_NUM < 0x073e00
|
||||||
|
+ case CURLE_SSL_CACERT: /* deprecated in libcurl 7.62.0 */
|
||||||
|
+#endif
|
||||||
|
case CURLE_PEER_FAILED_VERIFICATION:
|
||||||
|
/* 495 SSL Certificate Error (nginx non-standard) */
|
||||||
|
req->status = 495;
|
Loading…
Reference in a new issue