mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
Remove core/linux-imx6-cubox-dt
This commit is contained in:
parent
0cc7c9053f
commit
14df6b7e63
7 changed files with 0 additions and 6635 deletions
|
@ -1,74 +0,0 @@
|
|||
From 5d77ba2d26110c678b40fd723866a17d4036de12 Mon Sep 17 00:00:00 2001
|
||||
From: Lucas De Marchi <lucas.demarchi@intel.com>
|
||||
Date: Tue, 18 Feb 2014 02:19:26 -0300
|
||||
Subject: [PATCH 1/6] Bluetooth: allocate static minor for vhci
|
||||
|
||||
Commit bfacbb9 (Bluetooth: Use devname:vhci module alias for virtual HCI
|
||||
driver) added the module alias to hci_vhci module so it's possible to
|
||||
create the /dev/vhci node. However creating an alias without
|
||||
specifying the minor doesn't allow us to create the node ahead,
|
||||
triggerring module auto-load when it's first accessed.
|
||||
|
||||
Starting with depmod from kmod 16 we started to warn if there's a
|
||||
devname alias without specifying the major and minor.
|
||||
|
||||
Let's do the same done for uhid, kvm, fuse and others, specifying a
|
||||
fixed minor. In systems with systemd as the init the following will
|
||||
happen: on early boot systemd will call "kmod static-nodes" to read
|
||||
/lib/modules/$(uname -r)/modules.devname and then create the nodes. When
|
||||
first accessed these "dead" nodes will trigger the module loading.
|
||||
|
||||
Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
|
||||
Acked-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
||||
Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
|
||||
---
|
||||
Documentation/devices.txt | 1 +
|
||||
drivers/bluetooth/hci_vhci.c | 3 ++-
|
||||
include/linux/miscdevice.h | 1 +
|
||||
3 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Documentation/devices.txt b/Documentation/devices.txt
|
||||
index 10378cc..04356f5 100644
|
||||
--- a/Documentation/devices.txt
|
||||
+++ b/Documentation/devices.txt
|
||||
@@ -353,6 +353,7 @@ Your cooperation is appreciated.
|
||||
133 = /dev/exttrp External device trap
|
||||
134 = /dev/apm_bios Advanced Power Management BIOS
|
||||
135 = /dev/rtc Real Time Clock
|
||||
+ 137 = /dev/vhci Bluetooth virtual HCI driver
|
||||
139 = /dev/openprom SPARC OpenBoot PROM
|
||||
140 = /dev/relay8 Berkshire Products Octal relay card
|
||||
141 = /dev/relay16 Berkshire Products ISO-16 relay card
|
||||
diff --git a/drivers/bluetooth/hci_vhci.c b/drivers/bluetooth/hci_vhci.c
|
||||
index 1ef6990..add1c6a 100644
|
||||
--- a/drivers/bluetooth/hci_vhci.c
|
||||
+++ b/drivers/bluetooth/hci_vhci.c
|
||||
@@ -359,7 +359,7 @@ static const struct file_operations vhci_fops = {
|
||||
static struct miscdevice vhci_miscdev= {
|
||||
.name = "vhci",
|
||||
.fops = &vhci_fops,
|
||||
- .minor = MISC_DYNAMIC_MINOR,
|
||||
+ .minor = VHCI_MINOR,
|
||||
};
|
||||
|
||||
static int __init vhci_init(void)
|
||||
@@ -385,3 +385,4 @@ MODULE_DESCRIPTION("Bluetooth virtual HCI driver ver " VERSION);
|
||||
MODULE_VERSION(VERSION);
|
||||
MODULE_LICENSE("GPL");
|
||||
MODULE_ALIAS("devname:vhci");
|
||||
+MODULE_ALIAS_MISCDEV(VHCI_MINOR);
|
||||
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
|
||||
index 3737f72..7bb6148 100644
|
||||
--- a/include/linux/miscdevice.h
|
||||
+++ b/include/linux/miscdevice.h
|
||||
@@ -23,6 +23,7 @@
|
||||
#define TEMP_MINOR 131 /* Temperature Sensor */
|
||||
#define RTC_MINOR 135
|
||||
#define EFI_RTC_MINOR 136 /* EFI Time services */
|
||||
+#define VHCI_MINOR 137
|
||||
#define SUN_OPENPROM_MINOR 139
|
||||
#define DMAPI_MINOR 140 /* DMAPI */
|
||||
#define NVRAM_MINOR 144
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,85 +0,0 @@
|
|||
commit 7c545ae5467cca6ce537e213ecd647fcd4c3c4c0
|
||||
Author: wolfgar <stephan.rafin@laposte.net>
|
||||
Date: Fri Sep 12 01:42:52 2014 +0200
|
||||
|
||||
Remove superflous guards that could even break invocation from mxc-hdmi
|
||||
|
||||
diff --git a/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c b/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
index e53510f..88670bd 100644
|
||||
--- a/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
+++ b/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
@@ -83,8 +83,6 @@ struct hdmi_cec_event {
|
||||
|
||||
static LIST_HEAD(head);
|
||||
|
||||
-static int hdmi_cec_ready = 0;
|
||||
-static int hdmi_cec_started;
|
||||
static int hdmi_cec_major;
|
||||
static struct class *hdmi_cec_class;
|
||||
static struct hdmi_cec_priv hdmi_cec_data;
|
||||
@@ -315,7 +313,7 @@ static ssize_t hdmi_cec_write(struct file *file, const char __user *buf,
|
||||
mutex_unlock(&hdmi_cec_data.lock);
|
||||
return -EACCES;
|
||||
}
|
||||
- /* Ensure that there is only one writer who is the only listener of tx_cec_queue */
|
||||
+ /* Ensure that there is only one writer who is the unique listener of tx_cec_queue */
|
||||
if (hdmi_cec_data.tx_answer != CEC_TX_AVAIL) {
|
||||
mutex_unlock(&hdmi_cec_data.lock);
|
||||
return -EBUSY;
|
||||
@@ -359,13 +357,11 @@ static ssize_t hdmi_cec_write(struct file *file, const char __user *buf,
|
||||
return ret;
|
||||
}
|
||||
|
||||
+
|
||||
void hdmi_cec_start_device(void)
|
||||
{
|
||||
u8 val;
|
||||
|
||||
- if (!hdmi_cec_ready || hdmi_cec_started)
|
||||
- return;
|
||||
-
|
||||
val = hdmi_readb(HDMI_MC_CLKDIS);
|
||||
val &= ~HDMI_MC_CLKDIS_CECCLK_DISABLE;
|
||||
hdmi_writeb(val, HDMI_MC_CLKDIS);
|
||||
@@ -378,11 +374,7 @@ void hdmi_cec_start_device(void)
|
||||
hdmi_writeb(val, HDMI_CEC_MASK);
|
||||
hdmi_writeb(val, HDMI_IH_MUTE_CEC_STAT0);
|
||||
hdmi_cec_data.link_status = hdmi_readb(HDMI_PHY_STAT0) & 0x02;
|
||||
- mutex_lock(&hdmi_cec_data.lock);
|
||||
hdmi_cec_data.cec_state = true;
|
||||
- mutex_unlock(&hdmi_cec_data.lock);
|
||||
-
|
||||
- hdmi_cec_started = 1;
|
||||
}
|
||||
EXPORT_SYMBOL(hdmi_cec_start_device);
|
||||
|
||||
@@ -390,9 +382,6 @@ void hdmi_cec_stop_device(void)
|
||||
{
|
||||
u8 val;
|
||||
|
||||
- if (!hdmi_cec_ready || !hdmi_cec_started)
|
||||
- return;
|
||||
-
|
||||
hdmi_writeb(0x10, HDMI_CEC_CTRL);
|
||||
val = HDMI_IH_CEC_STAT0_WAKEUP | HDMI_IH_CEC_STAT0_ERROR_FOLL | HDMI_IH_CEC_STAT0_ERROR_INIT | HDMI_IH_CEC_STAT0_ARB_LOST | \
|
||||
HDMI_IH_CEC_STAT0_NACK | HDMI_IH_CEC_STAT0_EOM | HDMI_IH_CEC_STAT0_DONE;
|
||||
@@ -402,11 +391,7 @@ void hdmi_cec_stop_device(void)
|
||||
val = hdmi_readb(HDMI_MC_CLKDIS);
|
||||
val |= HDMI_MC_CLKDIS_CECCLK_DISABLE;
|
||||
hdmi_writeb(val, HDMI_MC_CLKDIS);
|
||||
- mutex_lock(&hdmi_cec_data.lock);
|
||||
hdmi_cec_data.cec_state = false;
|
||||
- mutex_unlock(&hdmi_cec_data.lock);
|
||||
-
|
||||
- hdmi_cec_started = 0;
|
||||
}
|
||||
EXPORT_SYMBOL(hdmi_cec_stop_device);
|
||||
|
||||
@@ -580,7 +565,6 @@ static int hdmi_cec_dev_probe(struct platform_device *pdev)
|
||||
INIT_DELAYED_WORK(&hdmi_cec_data.hdmi_cec_work, mxc_hdmi_cec_worker);
|
||||
|
||||
dev_info(&pdev->dev, "HDMI CEC initialized\n");
|
||||
- hdmi_cec_ready = 1;
|
||||
goto out;
|
||||
|
||||
err_out_class:
|
|
@ -1,29 +0,0 @@
|
|||
commit b6b72f40ec3b9d7faa0e37e87c3509848928746c
|
||||
Author: wolfgar <stephan.rafin@laposte.net>
|
||||
Date: Fri Sep 12 03:05:22 2014 +0200
|
||||
|
||||
Flush pending events at close
|
||||
|
||||
diff --git a/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c b/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
index 88670bd..f8b3f7a 100644
|
||||
--- a/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
+++ b/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
@@ -466,11 +466,18 @@ static long hdmi_cec_ioctl(struct file *filp, u_int cmd,
|
||||
*/
|
||||
static int hdmi_cec_release(struct inode *inode, struct file *filp)
|
||||
{
|
||||
+ struct hdmi_cec_event *event, *tmp_event;
|
||||
mutex_lock(&hdmi_cec_data.lock);
|
||||
if (open_count) {
|
||||
open_count = 0;
|
||||
hdmi_cec_data.cec_state = false;
|
||||
hdmi_cec_data.Logical_address = 15;
|
||||
+
|
||||
+ /* Flush eventual events which have not been read by user space */
|
||||
+ list_for_each_entry_safe(event, tmp_event, &head, list) {
|
||||
+ list_del(&event->list);
|
||||
+ vfree(event);
|
||||
+ }
|
||||
}
|
||||
mutex_unlock(&hdmi_cec_data.lock);
|
||||
|
|
@ -1,67 +0,0 @@
|
|||
commit 83ee92e168bc5d744f96961254ffac95a6260220
|
||||
Author: wolfgar <stephan.rafin@laposte.net>
|
||||
Date: Sat Sep 13 01:58:08 2014 +0200
|
||||
|
||||
No longer try to get link status directly in this driver
|
||||
Only consume the event sent by mxc-hdmi driver
|
||||
|
||||
diff --git a/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c b/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
index f8b3f7a..c30237e 100644
|
||||
--- a/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
+++ b/drivers/mxc/hdmi-cec/mxc_hdmi-cec.c
|
||||
@@ -67,7 +67,6 @@ struct hdmi_cec_priv {
|
||||
u8 msg_len;
|
||||
int tx_answer;
|
||||
u16 latest_cec_stat;
|
||||
- u8 link_status;
|
||||
spinlock_t irq_lock;
|
||||
struct delayed_work hdmi_cec_work;
|
||||
struct mutex lock;
|
||||
@@ -96,7 +95,6 @@ static irqreturn_t mxc_hdmi_cec_isr(int irq, void *data)
|
||||
struct hdmi_cec_priv *hdmi_cec = data;
|
||||
u16 cec_stat = 0;
|
||||
unsigned long flags;
|
||||
- u8 phy_stat0;
|
||||
irqreturn_t ret = IRQ_HANDLED;
|
||||
|
||||
spin_lock_irqsave(&hdmi_cec->irq_lock, flags);
|
||||
@@ -105,7 +103,6 @@ static irqreturn_t mxc_hdmi_cec_isr(int irq, void *data)
|
||||
|
||||
cec_stat = hdmi_readb(HDMI_IH_CEC_STAT0);
|
||||
hdmi_writeb(cec_stat, HDMI_IH_CEC_STAT0);
|
||||
- phy_stat0 = hdmi_readb(HDMI_PHY_STAT0) & 0x02;
|
||||
|
||||
if ((cec_stat & (HDMI_IH_CEC_STAT0_ERROR_INIT | \
|
||||
HDMI_IH_CEC_STAT0_NACK | HDMI_IH_CEC_STAT0_EOM | \
|
||||
@@ -113,14 +110,7 @@ static irqreturn_t mxc_hdmi_cec_isr(int irq, void *data)
|
||||
ret = IRQ_NONE;
|
||||
cec_stat = 0;
|
||||
}
|
||||
- if (hdmi_cec->link_status ^ phy_stat0) {
|
||||
- /* HPD value changed */
|
||||
- hdmi_cec->link_status = phy_stat0;
|
||||
- if (hdmi_cec->link_status)
|
||||
- cec_stat |= 0x80; /* Connected */
|
||||
- else
|
||||
- cec_stat |= 0x100; /* Disconnected */
|
||||
- }
|
||||
+
|
||||
pr_debug("HDMI CEC interrupt received\n");
|
||||
hdmi_cec->latest_cec_stat = cec_stat ;
|
||||
|
||||
@@ -357,7 +347,6 @@ static ssize_t hdmi_cec_write(struct file *file, const char __user *buf,
|
||||
return ret;
|
||||
}
|
||||
|
||||
-
|
||||
void hdmi_cec_start_device(void)
|
||||
{
|
||||
u8 val;
|
||||
@@ -373,7 +362,6 @@ void hdmi_cec_start_device(void)
|
||||
val = HDMI_IH_CEC_STAT0_WAKEUP | HDMI_IH_CEC_STAT0_ERROR_FOLL | HDMI_IH_CEC_STAT0_ARB_LOST;
|
||||
hdmi_writeb(val, HDMI_CEC_MASK);
|
||||
hdmi_writeb(val, HDMI_IH_MUTE_CEC_STAT0);
|
||||
- hdmi_cec_data.link_status = hdmi_readb(HDMI_PHY_STAT0) & 0x02;
|
||||
hdmi_cec_data.cec_state = true;
|
||||
}
|
||||
EXPORT_SYMBOL(hdmi_cec_start_device);
|
|
@ -1,316 +0,0 @@
|
|||
# Maintainer: Dave Higham <pepedog@archlinuxarm.org>
|
||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# Maintainer: Oleg Rakhmanov <oleg@archlinuxarm.org>
|
||||
|
||||
# Cubox i.MX6 kernel and headers
|
||||
# - note: any other kernel packages should include headers for that march
|
||||
# - there will be no v7 kernel26 package, each march will be tagged individually
|
||||
|
||||
buildarch=4
|
||||
|
||||
pkgbase=linux-imx6-cubox-dt
|
||||
pkgname=('linux-imx6-cubox-dt' 'linux-headers-imx6-cubox-dt')
|
||||
# pkgname=linux-custom # Build kernel with a different name
|
||||
_commit=fc2f25cb23e21b67bbbbf38e42ada325f07e1d47
|
||||
_srcname=linux-imx6-3.14-${_commit}
|
||||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.14
|
||||
pkgver=${_basekernel}.58
|
||||
pkgrel=1
|
||||
cryptodev_commit=bc67142c57eadc0aafd0323ec527849012786643
|
||||
bfqver=v7r8
|
||||
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage' 'git' 'lzop')
|
||||
options=('!strip')
|
||||
source=("linux-${_commit}::https://github.com/moonman/linux-imx6-3.14/archive/${_commit}.tar.gz"
|
||||
"cryptodev-${cryptodev_commit}.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}.40+"
|
||||
'0001-Bluetooth-allocate-static-minor-for-vhci.patch'
|
||||
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
|
||||
'config'
|
||||
'001_cec.patch'
|
||||
'002_cec.patch'
|
||||
'003_cec.patch')
|
||||
|
||||
md5sums=('3553c7a8f7803b78b3b01df53079bec6'
|
||||
'2c8ecae91223868decdf37b8a76489b7'
|
||||
'SKIP'
|
||||
'1b276abe16d14e133f3f28d9c9e6bd68'
|
||||
'defe6b5df33f8c11c2bf45f67ad35d8d'
|
||||
'2c10ccc1169884d2f12ba95fe11d29fd'
|
||||
'3baee38bf7fdcd47b2cc9628949b5784'
|
||||
'1ea8de6e5c6cae2e33f5767c7f16174e'
|
||||
'8bf79a580704e8dab806f58043720a90'
|
||||
'6391a74bf1d451b74df6f189a25cf642'
|
||||
'a70798b63a0e7c3fb50a57ea1815d353')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
msg2 "Fix hci_vhci no minor warning"
|
||||
patch -Np1 -i ${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch
|
||||
|
||||
msg2 "Copying aufs3 patches into the kernel source tree"
|
||||
cp -ru "${srcdir}/aufs3-standalone/"{Documentation,fs} "${srcdir}/${_srcname}/"
|
||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/${_srcname}/include/"{linux/,uapi/linux/}
|
||||
|
||||
msg2 "Applying aufs3 patches"
|
||||
patch -Np1 -i ../aufs3-standalone/aufs3-kbuild.patch
|
||||
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
|
||||
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
|
||||
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
|
||||
|
||||
msg2 "Add BFQ patches"
|
||||
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
|
||||
patch -Np1 -i "${srcdir}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
|
||||
patch -Np1 -i "${srcdir}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
|
||||
|
||||
msg2 "CEC patches"
|
||||
patch -Np1 -i ${srcdir}/001_cec.patch
|
||||
patch -Np1 -i ${srcdir}/002_cec.patch
|
||||
patch -Np1 -i ${srcdir}/003_cec.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
||||
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
||||
sed -i '2iexit 0' scripts/depmod.sh
|
||||
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
#LDFLAGS=""
|
||||
|
||||
# get kernel version
|
||||
make prepare
|
||||
|
||||
# load configuration
|
||||
# Configure the kernel. Replace the line below with one of your choice.
|
||||
#make menuconfig # CLI menu for configuration
|
||||
#make nconfig # new CLI menu for configuration
|
||||
#make xconfig # X-based configuration
|
||||
#make oldconfig # using old config from previous kernel version
|
||||
# ... or manually edit .config
|
||||
|
||||
# Copy back our configuration (use with new kernel version)
|
||||
#cp ./.config ../${_basekernel}.config
|
||||
|
||||
####################
|
||||
# stop here
|
||||
# this is useful to configure the kernel
|
||||
#msg "Stopping build"
|
||||
#return 1
|
||||
####################
|
||||
|
||||
#yes "" | make config
|
||||
|
||||
# build!
|
||||
make ${MAKEFLAGS} zImage modules imx6q-cubox-i.dtb imx6dl-cubox-i.dtb imx6dl-hummingboard.dtb imx6q-hummingboard.dtb
|
||||
|
||||
msg "Building cryptodev module"
|
||||
cd "${srcdir}/cryptodev-linux-${cryptodev_commit}"
|
||||
make KERNEL_DIR="${srcdir}/${_srcname}"
|
||||
}
|
||||
|
||||
package_linux-imx6-cubox-dt() {
|
||||
pkgdesc="The Linux Kernel and modules - i.MX6 processors for all cubox-i"
|
||||
depends=('coreutils' 'linux-firmware' 'module-init-tools>=3.16' 'mkinitcpio>=0.7')
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
provides=('kernel26' "linux=${pkgver}" 'aufs_friendly' 'cryptodev_friendly')
|
||||
conflicts=('linux-trimslice' 'linux-omap')
|
||||
install=${pkgname}.install
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
KARCH=arm
|
||||
|
||||
# get kernel version
|
||||
_kernver="$(make kernelrelease)"
|
||||
|
||||
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot/dtbs}
|
||||
make INSTALL_MOD_PATH="${pkgdir}" modules_install
|
||||
cp arch/$KARCH/boot/zImage "${pkgdir}/boot/zImage"
|
||||
cp arch/$KARCH/boot/dts/*.dtb "${pkgdir}/boot/dtbs"
|
||||
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
||||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||
-i "${startdir}/${pkgname}.install"
|
||||
|
||||
# remove build and source links
|
||||
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
rm -rf "${pkgdir}/lib/firmware"
|
||||
# gzip -9 all modules to save 100MB of space
|
||||
find "${pkgdir}" -name '*.ko' |xargs -P 2 -n 1 gzip -9
|
||||
# make room for external modules
|
||||
ln -s "../extramodules-${_basekernel}-${_kernelname:-ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
|
||||
# add real version for building modules and running depmod from post_install/upgrade
|
||||
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}"
|
||||
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}/version"
|
||||
|
||||
# install cryptodev module
|
||||
cd "${srcdir}/cryptodev-linux-${cryptodev_commit}"
|
||||
make -C "${srcdir}/${_srcname}" INSTALL_MOD_PATH="${pkgdir}" SUBDIRS=`pwd` modules_install
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# Now we call depmod...
|
||||
depmod -b "$pkgdir" -F System.map "$_kernver"
|
||||
|
||||
# move module tree /lib -> /usr/lib
|
||||
mkdir -p "${pkgdir}/usr"
|
||||
mv "$pkgdir/lib" "$pkgdir/usr"
|
||||
}
|
||||
|
||||
package_linux-headers-imx6-cubox-dt() {
|
||||
pkgdesc="Header files and scripts for building modules for linux kernel - i.MX6 cubox-i"
|
||||
provides=("linux-headers=${pkgver}" "linux-headers-imx6-fsl=${pkgver}")
|
||||
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
||||
|
||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||
|
||||
cd "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||
ln -sf ../../../src/linux-${_kernver} build
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
install -D -m644 Makefile \
|
||||
"${pkgdir}/usr/src/linux-${_kernver}/Makefile"
|
||||
install -D -m644 kernel/Makefile \
|
||||
"${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile"
|
||||
install -D -m644 .config \
|
||||
"${pkgdir}/usr/src/linux-${_kernver}/.config"
|
||||
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include"
|
||||
|
||||
for i in acpi asm-generic config crypto drm generated linux math-emu \
|
||||
media net pcmcia scsi sound trace uapi video xen; do
|
||||
cp -a include/${i} "${pkgdir}/usr/src/linux-${_kernver}/include/"
|
||||
done
|
||||
|
||||
# copy arch includes for external modules
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
||||
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-imx
|
||||
cp -a arch/$KARCH/mach-imx/*.h ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-imx/
|
||||
|
||||
# copy files necessary for later builds, like nvidia and vmware
|
||||
cp Module.symvers "${pkgdir}/usr/src/linux-${_kernver}"
|
||||
cp -a scripts "${pkgdir}/usr/src/linux-${_kernver}"
|
||||
|
||||
# fix permissions on scripts dir
|
||||
chmod og-w -R "${pkgdir}/usr/src/linux-${_kernver}/scripts"
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions"
|
||||
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/kernel"
|
||||
|
||||
cp arch/${KARCH}/Makefile "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/"
|
||||
|
||||
if [ "${CARCH}" = "i686" ]; then
|
||||
cp arch/${KARCH}/Makefile_32.cpu "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/"
|
||||
fi
|
||||
|
||||
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/kernel/"
|
||||
|
||||
# add headers for lirc package
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/video"
|
||||
|
||||
cp drivers/video/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/video/"
|
||||
|
||||
for i in cpia2 pwc; do
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/${i}"
|
||||
cp -a drivers/media/usb/${i}/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/${i}"
|
||||
done
|
||||
|
||||
# add docbook makefile
|
||||
install -D -m644 Documentation/DocBook/Makefile \
|
||||
"${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile"
|
||||
|
||||
# add dm headers
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/md"
|
||||
cp drivers/md/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/md"
|
||||
|
||||
# add inotify.h
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include/linux"
|
||||
cp include/linux/inotify.h "${pkgdir}/usr/src/linux-${_kernver}/include/linux/"
|
||||
|
||||
# add wireless headers
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/"
|
||||
cp net/mac80211/*.h "${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/"
|
||||
|
||||
# add dvb headers for external modules
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/9912
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-core"
|
||||
cp drivers/media/dvb-core/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-core/"
|
||||
# and...
|
||||
# http://bugs.archlinux.org/task/11194
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/"
|
||||
cp include/config/dvb/*.h "${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/"
|
||||
|
||||
# add dvb headers
|
||||
# in reference to:
|
||||
# http://bugs.archlinux.org/task/20402
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/dvb-usb"
|
||||
cp drivers/media/usb/dvb-usb/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/dvb-usb/"
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends"
|
||||
cp drivers/media/dvb-frontends/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends/"
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/tuners"
|
||||
cp drivers/media/tuners/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/tuners/"
|
||||
|
||||
# add xfs and shmem for aufs building
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs"
|
||||
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
||||
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
||||
|
||||
#make uapi headers, some of them are needed for vpu/ipu usage
|
||||
mkdir -p "${srcdir}/headers"
|
||||
make headers_install ARCH=$KARCH INSTALL_HDR_PATH="${srcdir}/headers"
|
||||
|
||||
|
||||
# copy freescale specific headers to /usr/include/linux
|
||||
mkdir -p "${pkgdir}/usr/include/linux"
|
||||
for f in "$srcdir/headers/include/linux"/mxc*.h "$srcdir/headers/include/linux/ipu.h"; do
|
||||
cp "$f" "${pkgdir}/usr/include/linux"
|
||||
done
|
||||
|
||||
# copy in Kconfig files
|
||||
for i in `find . -name "Kconfig*"`; do
|
||||
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
||||
cp ${i} "${pkgdir}/usr/src/linux-${_kernver}/${i}"
|
||||
done
|
||||
|
||||
chown -R root.root "${pkgdir}/usr/src/linux-${_kernver}"
|
||||
find "${pkgdir}/usr/src/linux-${_kernver}" -type d -exec chmod 755 {} \;
|
||||
|
||||
# strip scripts directory
|
||||
find "${pkgdir}/usr/src/linux-${_kernver}/scripts" -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||
case "$(file -bi "${binary}")" in
|
||||
*application/x-sharedlib*) # Libraries (.so)
|
||||
/usr/bin/strip ${STRIP_SHARED} "${binary}";;
|
||||
*application/x-archive*) # Libraries (.a)
|
||||
/usr/bin/strip ${STRIP_STATIC} "${binary}";;
|
||||
*application/x-executable*) # Binaries
|
||||
/usr/bin/strip ${STRIP_BINARIES} "${binary}";;
|
||||
esac
|
||||
done
|
||||
|
||||
# remove unneeded architectures
|
||||
rm -rf "${pkgdir}"/usr/src/linux-${_kernver}/arch/{alpha,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,x86,xtensa}
|
||||
|
||||
# install cryptodev header
|
||||
cd "${srcdir}/cryptodev-linux-${cryptodev_commit}"
|
||||
install -D crypto/cryptodev.h "${pkgdir}/usr/src/linux-${_kernver}/crypto/cryptodev.h"
|
||||
}
|
||||
|
File diff suppressed because it is too large
Load diff
|
@ -1,31 +0,0 @@
|
|||
# arg 1: the new package version
|
||||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-imx6-cubox-dt
|
||||
KERNEL_VERSION=3.14.55-1-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
echo ">>> Updating module dependencies. Please wait ..."
|
||||
depmod ${KERNEL_VERSION}
|
||||
|
||||
echo "NOTE: You will probably need to copy the contents of /boot/ to the first partition"
|
||||
echo " of your SD card."
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
if grep "^[^#]*[[:space:]]/boot" etc/fstab 2>&1 >/dev/null; then
|
||||
if ! grep "[[:space:]]/boot" etc/mtab 2>&1 >/dev/null; then
|
||||
echo "WARNING: /boot appears to be a seperate partition but is not mounted"
|
||||
echo " This is most likely not what you want. Please mount your /boot"
|
||||
echo " partition and reinstall the kernel unless you are sure this is OK"
|
||||
fi
|
||||
fi
|
||||
|
||||
# updating module dependencies
|
||||
echo ">>> Updating module dependencies. Please wait ..."
|
||||
depmod ${KERNEL_VERSION}
|
||||
|
||||
echo "NOTE: You will probably need to copy /boot/uImage to the first partition"
|
||||
echo " of your SD card."
|
||||
}
|
Loading…
Reference in a new issue