extra/qt3 to 3.3.8-18

This commit is contained in:
Kevin Mihelich 2011-03-03 21:50:15 -05:00
parent f815e05c3b
commit 14fc3bfeb8
2 changed files with 2 additions and 27 deletions

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 70485 2010-02-27 00:07:44Z ibiru $
# $Id: PKGBUILD 108411 2011-01-30 22:43:23Z andyrtr $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: John Proctor <jproctor@prium.net>
@ -10,7 +10,7 @@ plugrel=1
pkgname=qt3
pkgver=3.3.8
pkgrel=17
pkgrel=18
pkgdesc="The QT gui toolkit."
arch=(i686 x86_64)
license=('GPL')

View file

@ -1,25 +0,0 @@
diff -urN qt-x11-free-3.3.8.orig/src/tools/qglobal.h qt-x11-free-3.3.8/src/tools/qglobal.h
--- qt-x11-free-3.3.8.orig/src/tools/qglobal.h 2011-01-20 21:18:42.000000000 -0700
+++ qt-x11-free-3.3.8/src/tools/qglobal.h 2011-01-20 21:20:34.000000000 -0700
@@ -320,6 +320,9 @@
# if __GNUC__ == 3 && __GNUC_MINOR__ >= 4
# define Q_NO_PACKED_REFERENCE
# endif
+# if __GNUC__ == 4 && __GNUC_MINOR__ >= 0
+# define Q_NO_PACKED_POINTERS
+# endif
# endif
# if !defined(__EXCEPTIONS)
# define Q_NO_EXCEPTIONS
diff -urN qt-x11-free-3.3.8.orig/src/tools/qstring.h qt-x11-free-3.3.8/src/tools/qstring.h
--- qt-x11-free-3.3.8.orig/src/tools/qstring.h 2011-01-20 21:18:43.000000000 -0700
+++ qt-x11-free-3.3.8/src/tools/qstring.h 2011-01-20 21:21:48.000000000 -0700
@@ -195,6 +195,8 @@
ushort unicode() const { return ucs; }
#ifdef Q_NO_PACKED_REFERENCE
ushort &unicode() { return *(&ucs); }
+#elif defined Q_NO_PACKED_POINTERS
+ ushort &unicode() { ushort& tmp = ucs; return tmp; }
#else
ushort &unicode() { return ucs; }
#endif