core/linux-armv7 to 5.2.10-2

This commit is contained in:
Kevin Mihelich 2019-08-27 12:48:24 +00:00
parent 9c671bbce9
commit 150896d1ef
11 changed files with 31 additions and 35 deletions

View file

@ -1,4 +1,4 @@
From 715001b5f5917bddfde2d802fabfb9a64dab0368 Mon Sep 17 00:00:00 2001
From ff613634f9e7068b177d4b17789033744a200f94 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot

View file

@ -1,4 +1,4 @@
From 45ce3dfa97865b1ab05b5074b0712f24daeee36c Mon Sep 17 00:00:00 2001
From b7ad47d7fc3812b2e115a570448b44234ee1b9b2 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell

View file

@ -1,4 +1,4 @@
From 39b7c00e3cb226a9356937425a29da17c2981f8d Mon Sep 17 00:00:00 2001
From 140e552063180af228b37df97d2350af64796ee2 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/10] SMILE Plug device tree file

View file

@ -1,4 +1,4 @@
From c0a8c786ab5cd65319a330d264d1cf5485b77939 Mon Sep 17 00:00:00 2001
From 9e042330733ac4ad8fdf8e487046fcff933ea3f3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/10] fix mvsdio eMMC timing

View file

@ -1,4 +1,4 @@
From a71f7ca149aa36525082c55ba3d353e5638b056f Mon Sep 17 00:00:00 2001
From 949cb0817cb0ee90052f08eeab8fd6a7c2ee9dca Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a

View file

@ -1,4 +1,4 @@
From 67004e3f653d695e342b2aafd3405ef40d70dc73 Mon Sep 17 00:00:00 2001
From 0316306aae3acc2929b8ecf808c7a0ce2a681584 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/10] set default cubietruck led triggers

View file

@ -1,4 +1,4 @@
From ba9005d557f10c61701551a084ca05b8ac720809 Mon Sep 17 00:00:00 2001
From e24a6024b32b86271b0941cb49eca50bcbc88342 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/10] exynos4412-odroid: set higher minimum buck2 regulator

View file

@ -1,4 +1,4 @@
From fbb489e948062ea2e4c666f1d87ff5f81b8caf26 Mon Sep 17 00:00:00 2001
From 554cee8b797900bf23a2b9dd8a973b41c29a341f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/10] ARM: dove: enable ethernet on D3Plug

View file

@ -1,13 +1,13 @@
From cd3566d3e5566029a8255fc5991ac2c5973b4e3a Mon Sep 17 00:00:00 2001
From 74f42aad50ad3a540c2af84f3decee87362c0d37 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 09/10] USB Armory MkII support
---
arch/arm/boot/dts/Makefile | 2 +
arch/arm/boot/dts/imx6ul-usbarmory.dts | 257 +++++++++++++++++++++++
arch/arm/boot/dts/imx6ull-usbarmory.dts | 258 ++++++++++++++++++++++++
3 files changed, 517 insertions(+)
arch/arm/boot/dts/imx6ul-usbarmory.dts | 255 +++++++++++++++++++++++
arch/arm/boot/dts/imx6ull-usbarmory.dts | 256 ++++++++++++++++++++++++
3 files changed, 513 insertions(+)
create mode 100644 arch/arm/boot/dts/imx6ul-usbarmory.dts
create mode 100644 arch/arm/boot/dts/imx6ull-usbarmory.dts
@ -29,10 +29,10 @@ index acc6197cdc41..1a36a8de9ef2 100644
imx7d-cl-som-imx7.dtb \
diff --git a/arch/arm/boot/dts/imx6ul-usbarmory.dts b/arch/arm/boot/dts/imx6ul-usbarmory.dts
new file mode 100644
index 000000000000..a596af4cea25
index 000000000000..3936ef8a64f1
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ul-usbarmory.dts
@@ -0,0 +1,257 @@
@@ -0,0 +1,255 @@
+/*
+ * USB armory Mk II device tree file
+ * https://inversepath.com/usbarmory
@ -122,8 +122,6 @@ index 000000000000..a596af4cea25
+ regulator-name = "VSD_3V3";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ gpio = <&gpio1 9 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ };
+ };
+};
@ -292,10 +290,10 @@ index 000000000000..a596af4cea25
+};
diff --git a/arch/arm/boot/dts/imx6ull-usbarmory.dts b/arch/arm/boot/dts/imx6ull-usbarmory.dts
new file mode 100644
index 000000000000..7b3ed97fbe31
index 000000000000..85cf30bff527
--- /dev/null
+++ b/arch/arm/boot/dts/imx6ull-usbarmory.dts
@@ -0,0 +1,258 @@
@@ -0,0 +1,256 @@
+/*
+ * USB armory Mk II device tree file
+ * https://inversepath.com/usbarmory
@ -385,8 +383,6 @@ index 000000000000..7b3ed97fbe31
+ regulator-name = "VSD_3V3";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ gpio = <&gpio1 9 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ };
+ };
+};

View file

@ -1,4 +1,4 @@
From e3e497cd65fd1150de25411aaad124d8d500137e Mon Sep 17 00:00:00 2001
From 6e5287df72d9ed7f6855714eb0f175e43cd1f3cf Mon Sep 17 00:00:00 2001
From: Jacky Bai <ping.bai@nxp.com>
Date: Mon, 20 May 2019 07:54:51 +0000
Subject: [PATCH 10/10] clk: imx: keep the mmdc p1 ipg clock always on on

View file

@ -8,9 +8,9 @@ _srcname=linux-5.2
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=5.2.10
pkgrel=1
rcnver=5.2.9
rcnrel=armv7-x5
pkgrel=2
rcnver=5.2.10
rcnrel=armv7-x6
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -38,17 +38,17 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'90-linux.hook')
md5sums=('ddf994de00d7b18395886dd9b30b9262'
'7c9a170cf18a9ab1d2e005b2d206d9bc'
'f32edc341c6e2ce170be25bc589bff6e'
'8d46ef56e9bcae861bf195e4ec7c1eb1'
'8ab3932a38bc5ed13fce15d3a3a40911'
'be5a0605483ab8d1bd8d49ba9670ef4d'
'797d4553dc3adeb09f4949abe6f94a94'
'6b949b85098ccb84c3c20d6e88478d92'
'00132dc693b122007bcb3f119edb0bd7'
'9fdab0e15c86922ad5b67461fd624fdc'
'3ea3cba13acc5a1a499fbf544cb2fea1'
'6799346f31c74909652b85187641f01c'
'0be8a0ff2c84446b43e07185f276718e'
'635bc8fe92286294ab942c371757f458'
'3a438ea4ec18674e839088aba5a010e8'
'3c7d208e8d2514064804840853458554'
'bba33bc98ccb7ed84214efefab0037a1'
'48ab87b5ca829602b26f6a32f299870c'
'4adbc558097f076822be5003572ae63e'
'4bc88592c8ae5fae88ea42563418c501'
'703882ad134f4402ed4ee8190b9ebb7e'
'3883c9e0cf320c6355afc124ef058c2d'
'd5b1239bcfb0a612a7194553699b4319'
'6427cd863fd9051dce3dccbc657d596d'
'9ae3548c28a9ea84bc04fdc66bc832f3'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'