Removed extra/ntp

This commit is contained in:
Kevin Mihelich 2011-02-21 12:23:22 -05:00
parent ed90ed1c13
commit 154d065de6
9 changed files with 0 additions and 434 deletions

View file

@ -1,86 +0,0 @@
# $Id: PKGBUILD 95196 2010-10-17 01:43:50Z kevin $
# Maintainer: kevin <kevin@archlinux.org>
plugrel=1
# PlugApps changes: Added avahi to dependencies
pkgname=ntp
pkgver=4.2.6.p2
_realver=4.2.6p2
pkgrel=1
pkgdesc="NTP (Network Time Protocol) tries to keep servers in sync"
arch=(i686 x86_64)
license=('custom')
url="http://www.ntp.org/"
depends=('openssl' 'readline' 'libcap' 'avahi')
makedepends=('perl-html-parser')
backup=('etc/ntp.conf' 'etc/conf.d/ntp-client.conf')
options=('!emptydirs')
changelog=changelog
source=(http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${_realver}.tar.gz
ntp-4.2.4_p7-nano.patch
fix-ipv6.patch
ntp-4.2.4-html2man.patch
ntp.conf
ntp-client.conf
ntpd
ntpdate)
md5sums=('cf73cd85f248232c62f8029e6eb05938' '36c5711228cb0cf48966daa993e06f55'
'9dabdbc6b8cd020f2205515df7972c21' '1b04e888717bb31479a6087632981723'
'5bd3924f5720b97837969ec4ec4d5e09' 'c7f50632b69bd4f32cf052d0b1848463'
'46118a8ec2c4f5bbfafd730af21b7c03' '140855352baeb89da0c6c1c475c18b57')
build() {
cd "$srcdir/$pkgname-$_realver"
# fix glibc build issue
patch -Np1 -i ../ntp-4.2.4_p7-nano.patch
# fix ipv6 support
patch -Np1 -i ../fix-ipv6.patch
# fix man page generation
patch -Np1 -i ../ntp-4.2.4-html2man.patch
# configure
# 4.2.6p2 not finding rt lib: added LIS
export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
libtoolize --copy --force
ac_cv_header_dns_sd_h=0 ./configure LIBS=-lrt --prefix=/usr --mandir=/usr/share/man --enable-linux-caps
# build
make
}
package() {
cd "$srcdir/$pkgname-$_realver"
# install
make DESTDIR="$pkgdir" install
# install conf files
mkdir -p "$pkgdir/usr/share/ntp"
install -D -m644 conf/* "$pkgdir/usr/share/ntp/"
# install launch scripts
mkdir -p "$pkgdir/etc/rc.d"
install -D -m755 "$srcdir"/{ntpd,ntpdate} "$pkgdir/etc/rc.d/"
# install man pages
cd html
../scripts/html2man
sed -i 's/^[\t\ ]*$//;/./,/^$/!d' man/man*/*.[58]
install -d "$pkgdir"/usr/share/man/man{5,8}
install -m644 man/man5/* "$pkgdir/usr/share/man/man5/"
install -m644 man/man8/* "$pkgdir/usr/share/man/man8/"
mv "$pkgdir/usr/share/man/man8/ntpd.8" "$pkgdir/usr/share/man/man8/ntp-ntpd.8"
cd ..
# install sample configs
install -D -m644 "$srcdir/ntp.conf" "$pkgdir/etc/ntp.conf"
install -D -m644 "$srcdir/ntp-client.conf" \
"$pkgdir/etc/conf.d/ntp-client.conf"
# create /var/lib/ntp
mkdir -p "$pkgdir/var/lib/ntp"
touch "$pkgdir/var/lib/ntp/.placeholder"
install -Dm644 "$srcdir/$pkgname-$_realver/COPYRIGHT" "$pkgdir/usr/share/licenses/$pkgname/COPYRIGHT"
}

View file

@ -1,7 +0,0 @@
2010-10-16 kevin <kevin@archlinux.org>
* ntp 4.2.6p2
- Added changelog
- Set LIBS to use librt since configure doesn't set it
- Convert PKGBUILD to build()/package() format
- removed "|| return 1"

View file

@ -1,10 +0,0 @@
--- ntp-4.2.4p7-orig/configure.ac 2009-06-18 14:48:12.151346763 +0200
+++ ntp-4.2.4p7/configure.ac 2009-06-18 14:50:07.054692531 +0200
@@ -4456,6 +4456,7 @@
[
AC_LANG_PROGRAM(
[
+ #define _GNU_SOURCE
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>

View file

@ -1,183 +0,0 @@
--- ntp-4.2.4/scripts/html2man.in.html2man 2006-06-06 22:17:10.000000000 +0200
+++ ntp-4.2.4/scripts/html2man.in 2007-01-08 12:47:31.000000000 +0100
@@ -23,10 +23,10 @@
'ntpq' => ['ntpq', 8, 'ntpd(8), ntpdc(8)'],
'ntpdate' => ['ntpdate', 8, 'ntpd(8)'],
'ntpdc' => ['ntpdc', 8, 'ntpd(8)'],
- 'ntptime' => ['ntpdtime', 8, 'ntpd(8), ntpdate(8)'],
+ 'ntptime' => ['ntptime', 8, 'ntpd(8), ntpdate(8)'],
'ntptrace' => ['ntptrace', 8, 'ntpd(8)'],
'keygen' => ['ntp-keygen', 8, 'ntpd(8), ntp_auth(5)'],
- 'confopt' => ['ntp.conf', 5, 'ntpd(8)'],
+ 'confopt' => ['ntp.conf', 5, 'ntpd(8), ntp_auth(5), ntp_mon(5), ntp_acc(5), ntp_clock(5), ntp_misc(5)'],
'authopt' => ['ntp_auth', 5, 'ntp.conf(5), ntpd(8)'],
'monopt' => ['ntp_mon', 5, 'ntp.conf(5)'],
'accopt' => ['ntp_acc', 5, 'ntp.conf(5)'],
@@ -34,17 +34,8 @@
'miscopt' => ['ntp_misc', 5, 'ntp.conf(5)']);
# Disclaimer to go in SEE ALSO section of the man page
-$seealso_disclaimer = 'These man pages are automatically hacked from the main NTP ' .
- 'documentation pages, which are maintained in HTML format. These files are ' .
- 'included in the NTP source distribution. If you installed NTP from a binary ' .
- 'package, or it came pre-installed on your system, chances are the documentation ' .
- 'was also included in the usual place for your system. The HTML files are more ' .
- 'correct and complete than these man pages, which are provided for your reference ' .
- 'only.';
-
-# Disclaimer to go right at the top
-$top_disclaimer = 'This file was automatically generated from HTML source, and may be ' .
- 'incorrect. See the SEE ALSO section at the end of this file for more info';
+$seealso_disclaimer = "Primary source of documentation: /usr/share/doc/ntp-*\n\n" .
+ "This file was automatically generated from HTML source.\n";
mkdir $MANDIR, 0777;
mkdir "$MANDIR/man8", 0777;
@@ -64,7 +55,8 @@
$fileinfo = $manfiles{$filename};
$p = HTML::TokeParser->new("$filename.html") || die "Can't open $filename.html: $!";
- open(MANOUT, ">$MANDIR/man$fileinfo->[1]/$fileinfo->[0].$fileinfo->[1]")
+ $fileout = "$MANDIR/man$fileinfo->[1]/$fileinfo->[0].$fileinfo->[1]";
+ open(MANOUT, ">$fileout")
|| die "Can't open: $!";
$p->get_tag("title");
@@ -73,7 +65,6 @@
# Setup man header
print MANOUT ".TH " . $fileinfo->[0] . " " . $fileinfo->[1] . "\n";
- print MANOUT ".UC 4\n";
print MANOUT ".SH NAME\n";
$pat = $fileinfo->[0];
if ($name =~ /$pat/) {
@@ -81,10 +72,12 @@
# Add the manpage name, if not in the HTML title already
print MANOUT "$fileinfo->[0] - ";
}
- print MANOUT "$name\n\n";
-
- print MANOUT "$top_disclaimer\n";
+ print MANOUT "$name\n.SH \\ \n\n";
+ @fontstack = ();
+ $deflevel = 0;
+ $pre = 0;
+ $ignore = 0;
# Now start scanning. We basically print everything after translating some tags.
# $token->[0] has "T", "S", "E" for Text, Start, End
# $token->[1] has the tag name, or text (for "T" case)
@@ -92,19 +85,37 @@
while (my $token = $p->get_token) {
if($token->[0] eq "T") {
my $text = $token->[1];
- if($tag) {
- $text =~ s/^[\n ]*//;
- $text =~ s/[\n ]*$/ /;
+ if (!$pre) {
+ if($tag) {
+ $text =~ s/^[\n\t ]*//;
+ }
+ $text =~ s/^[\n\t ][\n\t ]+$//;
+ $text =~ s/[\n\t ]+/ /g;
+ $text =~ s/&nbsp\;/ /g;
+ $text =~ s/&gt\;/>/g;
+ $text =~ s/&lt\;/</g;
+ $text =~ s/&quot\;/"/g;
+ $text =~ s/&amp\;/&/g;
+ $text =~ s/^\./\\[char46]/;
}
- $text =~ s/&nbsp\;/ /g;
- $text =~ s/^\./\\./;
print MANOUT "$text";
$tag = 0;
}
if($token->[0] eq "S") {
if($token->[1] eq "h4") {
my $text = uc($p->get_trimmed_text("/h4"));
- print MANOUT ".SH $text\n";
+ # ignore these two sections in ntpd.html
+ if ($filename eq "ntpd" &&
+ ($text eq "FILES" || $text eq "CONFIGURATION OPTIONS")) {
+ $ignore = 1;
+ close(MANOUT);
+ open(MANOUT, ">/dev/null");
+ } elsif ($ignore) {
+ $ignore = 0;
+ close(MANOUT);
+ open(MANOUT, ">>$fileout");
+ }
+ print MANOUT "\n\n.SH $text\n";
}
if($token->[1] eq "tt") {
push @fontstack, "tt";
@@ -118,22 +129,30 @@
my $text = $p->get_trimmed_text("/address");
print MANOUT "\n.SH AUTHOR\n$text\n";
}
- if($token->[1] eq "dt") {
- $tmp = $deflevel-4;
- print MANOUT "\n.RS $tmp\n";
+ if($token->[1] eq "dt" || $token->[1] eq "br" && $deflevel > 0) {
+ print MANOUT "\n.TP 8\n";
$tag = 1;
}
if($token->[1] eq "dd") {
- print MANOUT "\n.RS $deflevel\n";
+ print MANOUT "\n";
$tag = 1;
}
if($token->[1] eq "dl") {
- $deflevel+=4;
+ $deflevel+=1;
+ if ($deflevel > 0) {
+ print MANOUT "\n.RS ", $deflevel > 1 ? 8 : 0;
+ }
+ }
+ if($token->[1] eq "p") {
+ print MANOUT "\n";
+ }
+ if($token->[1] eq "pre") {
+ print MANOUT "\n.nf";
+ $pre = 1;
}
}
elsif($token->[0] eq "E") {
- if($token->[1] eq "dd") {
- print MANOUT "\n.RE\n";
+ if($token->[1] eq "h4") {
$tag = 1;
}
if($token->[1] eq "tt") {
@@ -157,15 +176,27 @@
print MANOUT "$fontswitch";
}
if($token->[1] eq "dl") {
- $deflevel-=4;
+ if ($deflevel > 0) {
+ print MANOUT "\n.RE";
+ }
+ print MANOUT "\n";
+ $deflevel-=1;
}
- if($token->[1] eq "dt") {
- print MANOUT "\n.RE";
+ if($token->[1] eq "p") {
+ print MANOUT "\n";
$tag = 1;
}
+ if($token->[1] eq "pre") {
+ print MANOUT "\n.fi";
+ $pre = 0;
+ }
}
}
- print MANOUT ".SH SEE ALSO\n\n";
+ if ($ignore) {
+ close(MANOUT);
+ open(MANOUT, ">>$fileout");
+ }
+ print MANOUT "\n.SH SEE ALSO\n\n";
print MANOUT "$fileinfo->[2]\n\n";
print MANOUT "$seealso_disclaimer\n";
close(MANOUT);

View file

@ -1,20 +0,0 @@
http://bugs.gentoo.org/270483
ripped from fedora
--- ntp-4.2.4p7/include/ntp_syscall.h
+++ ntp-4.2.4p7/include/ntp_syscall.h
@@ -14,5 +14,13 @@
# include <sys/timex.h>
#endif
+#if defined(ADJ_NANO) && !defined(MOD_NANO)
+#define MOD_NANO ADJ_NANO
+#endif
+
+#if defined(ADJ_TAI) && !defined(MOD_TAI)
+#define MOD_TAI ADJ_TAI
+#endif
+
#ifndef NTP_SYSCALLS_LIBC
#ifdef NTP_SYSCALLS_STD

View file

@ -1,11 +0,0 @@
# change this to a server closer to your location
NTP_CLIENT_SERVER="pool.ntp.org"
# client options
NTP_CLIENT_OPTION="-b -u"
# timeout for the ntp-client
NTPCLIENT_TIMEOUT=10
# arguments passed to ntpd when started
NTPD_ARGS="-g"

View file

@ -1,47 +0,0 @@
# NOTES:
# - you should only have to update the server line below
# - if you start getting lines like 'restrict' and 'fudge'
# and you didnt add them, AND you run dhcpcd on your
# network interfaces, be sure to add '-Y -N' to the
# dhcpcd_ethX variables in /etc/conf.d/net
# Name of the servers ntpd should sync with
# Please respect the access policy as stated by the responsible person.
#server ntp.example.tld iburst
server pool.ntp.org
##
# A list of available servers can be found here:
# http://www.pool.ntp.org/
# http://www.pool.ntp.org/#use
# A good way to get servers for your machine is:
# netselect -s 3 pool.ntp.org
##
# you should not need to modify the following paths
driftfile /var/lib/ntp/ntp.drift
#server ntplocal.example.com prefer
#server timeserver.example.org
# Warning: Using default NTP settings will leave your NTP
# server accessible to all hosts on the Internet.
# If you want to deny all machines (including your own)
# from accessing the NTP server, uncomment:
#restrict default ignore
# To deny other machines from changing the
# configuration but allow localhost:
restrict default nomodify nopeer
restrict 127.0.0.1
# To allow machines within your network to synchronize
# their clocks with your server, but ensure they are
# not allowed to configure the server or used as peers
# to synchronize against, uncomment this line.
#
#restrict 192.168.0.0 mask 255.255.255.0 nomodify nopeer notrap

View file

@ -1,40 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
. /etc/conf.d/ntp-client.conf
PID=`pidof -o %PPID /usr/bin/ntpd`
case "$1" in
start)
stat_busy "Starting NTP Daemon"
if [ -z "$PID" ]; then
/usr/bin/ntpd $NTPD_ARGS &
fi
if [ ! -z "$PID" -o $? -gt 0 ]; then
stat_fail
else
PID=`pidof -o %PPID /usr/bin/ntpd`
echo $PID > /var/run/ntpd.pid
add_daemon ntpd
stat_done
fi
;;
stop)
stat_busy "Stopping NTP Daemon"
[ ! -z "$PID" ] && kill $PID &> /dev/null
if [ $? -gt 0 ]; then
stat_fail
else
rm_daemon ntpd
stat_done
fi
;;
restart)
$0 stop
sleep 1
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac

View file

@ -1,30 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
. /etc/conf.d/ntp-client.conf
case "$1" in
start)
stat_busy "Starting NTP Client"
/usr/bin/ntpdate $NTP_CLIENT_OPTION -t $NTPCLIENT_TIMEOUT $NTP_CLIENT_SERVER > /dev/null 2>&1
if [ $? -gt 0 ]; then
stat_fail
else
add_daemon ntpdate
stat_done
fi
;;
stop)
stat_busy "Stopping NTP Client"
rm_daemon ntpdate
stat_done
;;
restart)
$0 stop
sleep 1
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac