core/linux-raspberrypi-latest to 3.18.1-1

This commit is contained in:
moonman 2014-12-23 09:51:10 +00:00
parent 4de84d0589
commit 15621bac2f
2 changed files with 93 additions and 3 deletions

View file

@ -0,0 +1,86 @@
From b4e9c2511bfe0eed13f7d0550241b60f6730d76a Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 18 Dec 2014 00:41:44 -0700
Subject: [PATCH] AUFS fix for 3.18.1
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
fs/aufs/dcsub.c | 4 ++--
fs/aufs/debug.c | 2 +-
fs/aufs/export.c | 2 +-
fs/aufs/hnotify.c | 4 ++--
4 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/fs/aufs/dcsub.c b/fs/aufs/dcsub.c
index 9fbc218..04663e5 100644
--- a/fs/aufs/dcsub.c
+++ b/fs/aufs/dcsub.c
@@ -134,7 +134,7 @@ resume:
while (next != &this_parent->d_subdirs) {
struct list_head *tmp = next;
struct dentry *dentry = list_entry(tmp, struct dentry,
- d_u.d_child);
+ d_child);
next = tmp->next;
spin_lock_nested(&dentry->d_lock, DENTRY_D_LOCK_NESTED);
@@ -170,7 +170,7 @@ resume:
this_parent = tmp;
spin_lock(&this_parent->d_lock);
rcu_read_unlock();
- next = child->d_u.d_child.next;
+ next = child->d_child.next;
goto resume;
}
diff --git a/fs/aufs/debug.c b/fs/aufs/debug.c
index e3ee24d..563bac0 100644
--- a/fs/aufs/debug.c
+++ b/fs/aufs/debug.c
@@ -169,7 +169,7 @@ void au_dpri_dalias(struct inode *inode)
struct dentry *d;
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
au_dpri_dentry(d);
spin_unlock(&inode->i_lock);
}
diff --git a/fs/aufs/export.c b/fs/aufs/export.c
index 32df1ed..864ec30 100644
--- a/fs/aufs/export.c
+++ b/fs/aufs/export.c
@@ -243,7 +243,7 @@ static struct dentry *decode_by_ino(struct super_block *sb, ino_t ino,
dentry = d_find_alias(inode);
else {
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
if (!au_test_anon(d)
&& d->d_parent->d_inode->i_ino == dir_ino) {
diff --git a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
index e120c55..94d6d6e 100644
--- a/fs/aufs/hnotify.c
+++ b/fs/aufs/hnotify.c
@@ -211,7 +211,7 @@ static int hn_gen_by_inode(char *name, unsigned int nlen, struct inode *inode,
AuDebugOn(!name);
au_iigen_dec(inode);
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
dname = &d->d_name;
if (dname->len != nlen
@@ -378,7 +378,7 @@ static struct dentry *lookup_wlock_by_name(char *name, unsigned int nlen,
dentry = NULL;
spin_lock(&parent->d_lock);
- list_for_each_entry(d, &parent->d_subdirs, d_u.d_child) {
+ list_for_each_entry(d, &parent->d_subdirs, d_child) {
/* AuDbg("%pd\n", d); */
spin_lock_nested(&d->d_lock, DENTRY_D_LOCK_NESTED);
dname = &d->d_name;
--
2.1.3

View file

@ -5,11 +5,11 @@
buildarch=18
pkgbase=linux-raspberrypi-latest
_commit=b665bea457d3ddaaec45b88d8cf6c3083539ab1f
_commit=5fdce56c57f419a8f8a57a6c5b90d63deabca713
_srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="Raspberry Pi"
pkgver=3.18.0
pkgver=3.18.1
pkgrel=1
bfqver=v7r6
@ -25,16 +25,18 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
'imagetool-uncompressed.py'
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
# "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}"
'0001-AUFS-fix-for-3.18.1.patch'
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch")
md5sums=('bb58d6f9db305b29bc58c75954892b14'
md5sums=('6ec3789f8527e682984071d3b22e202e'
'c57c9a9e89778b1db264747f4cd42d5b'
'9335d1263fd426215db69841a380ea26'
'a00e424e2fbb8c5a5f77ba2c4871bed4'
'2f82dbe5752af65ff409d737caf11954'
'SKIP'
'aa83d1bca3a3583aa4011d03ff23bfd5'
'f84f5f809a0f92e5e469d7c9e2dbac58'
'22ef862652608c8d6b07536e990d4bcb'
'b031b1aafd416453d1c8579bd6823fca')
@ -57,6 +59,8 @@ msg "Patches:"
patch -Np1 -i ../aufs3-standalone/aufs3-base.patch
patch -Np1 -i ../aufs3-standalone/aufs3-mmap.patch
patch -Np1 -i ../aufs3-standalone/aufs3-standalone.patch
# Remove when updated upstream
patch -Np1 -i ../0001-AUFS-fix-for-3.18.1.patch
msg2 "Add BFQ patches"
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"