core/linux-imx6-cubox-dt to 3.14.54-2

This commit is contained in:
moonman 2015-10-11 09:51:49 +00:00
parent a7a011e36d
commit 157a45de94
2 changed files with 7 additions and 46 deletions

View file

@ -1,45 +0,0 @@
diff -ruN a/fs/aufs/debug.c b/fs/aufs/debug.c
--- a/fs/aufs/debug.c 2015-05-01 08:27:35.903754731 +0000
+++ b/fs/aufs/debug.c 2015-05-01 08:30:16.164156908 +0000
@@ -168,7 +168,7 @@
struct dentry *d;
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
au_dpri_dentry(d);
spin_unlock(&inode->i_lock);
}
diff -ruN a/fs/aufs/export.c b/fs/aufs/export.c
--- a/fs/aufs/export.c 2015-05-01 08:27:35.908755087 +0000
+++ b/fs/aufs/export.c 2015-05-01 08:34:17.023328460 +0000
@@ -243,7 +243,7 @@
dentry = d_find_alias(inode);
else {
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
if (!au_test_anon(d)
&& d->d_parent->d_inode->i_ino == dir_ino) {
diff -ruN a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
--- a/fs/aufs/hnotify.c 2015-05-01 08:27:35.914755514 +0000
+++ b/fs/aufs/hnotify.c 2015-05-01 08:32:32.574871642 +0000
@@ -211,7 +211,7 @@
AuDebugOn(!name);
au_iigen_dec(inode);
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
dname = &d->d_name;
if (dname->len != nlen
@@ -378,7 +378,7 @@
dentry = NULL;
spin_lock(&parent->d_lock);
- list_for_each_entry(d, &parent->d_subdirs, d_u.d_child) {
+ list_for_each_entry(d, &parent->d_subdirs, d_child) {
/* AuDbg("%pd\n", d); */
spin_lock_nested(&d->d_lock, DENTRY_D_LOCK_NESTED);
dname = &d->d_name;

View file

@ -16,7 +16,7 @@ _srcname=linux-imx6-3.14-${_commit}
_kernelname=${pkgname#linux}
_basekernel=3.14
pkgver=${_basekernel}.54
pkgrel=1
pkgrel=2
cryptodev_commit=da730106c2558c8e0c8e1b1b1812d32ef9574ab7
bfqver=v7r8
@ -32,6 +32,7 @@ source=("linux-${_commit}::https://github.com/moonman/linux-imx6-3.14/archive/${
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
'https://github.com/moonman/linux-imx6-3.14/commit/427f994587dde5a0064e85614a631c075481c4ba.patch'
'config'
'001_cec.patch'
'002_cec.patch'
@ -44,6 +45,7 @@ md5sums=('42ddf343f1d247b0e0685cae366fefcd'
'defe6b5df33f8c11c2bf45f67ad35d8d'
'2c10ccc1169884d2f12ba95fe11d29fd'
'3baee38bf7fdcd47b2cc9628949b5784'
'4cd794bab0abedf5c6eea5a991cc939c'
'1ea8de6e5c6cae2e33f5767c7f16174e'
'8bf79a580704e8dab806f58043720a90'
'6391a74bf1d451b74df6f189a25cf642'
@ -52,6 +54,10 @@ md5sums=('42ddf343f1d247b0e0685cae366fefcd'
prepare() {
cd "${srcdir}/${_srcname}"
# Fixes infinate list on 'ip rule list'
# Remove when fixed upstram
patch -R -Np1 -i ${srcdir}/427f994587dde5a0064e85614a631c075481c4ba.patch
msg2 "Fix hci_vhci no minor warning"
patch -Np1 -i ${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch