community/csound to 6.13.0-1

This commit is contained in:
Kevin Mihelich 2019-07-13 21:51:34 +00:00
parent 4af328bee5
commit 15b11d574c
2 changed files with 32 additions and 88 deletions

View file

@ -12,36 +12,29 @@ buildarch=22
pkgbase=csound
pkgname=('csound' 'csound-doc')
pkgver=6.12.2
pkgrel=8
pkgver=6.13.0
pkgrel=1
pkgdesc="A programming language for sound rendering and signal processing."
arch=('x86_64')
url="https://csound.com"
license=('LGPL')
# libpd needs to be packaged: https://github.com/libpd/libpd/releases
# current gmm doesn't work https://github.com/csound/csound/issues/920
# gmm > 5.1 breaks linear-algebra opcode: https://github.com/csound/csound/issues/920
makedepends=('boost' 'cmake' 'cunit' 'doxygen' 'dssi' 'eigen' 'faust' 'fltk'
'fluidsynth' 'git' 'hdf5' 'java-environment' 'ladspa' 'libmusicxml'
'libwebsockets' 'llvm' 'luajit' 'portmidi' 'portsmf' 'python2' 'stk' 'swig'
'wiiuse')
'fluidsynth' 'hdf5' 'java-environment' 'ladspa' 'libmusicxml' 'libwebsockets'
'link' 'llvm' 'lua' 'portmidi' 'portsmf' 'python2' 'stk' 'swig' 'wiiuse')
source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/${pkgbase}/${pkgbase}/archive/${pkgver}.tar.gz"
"${pkgbase}.sh"
"fluidsynth2.patch"
"https://github.com/${pkgbase}/${pkgbase}/releases/download/${pkgver}/Csound${pkgver}_manual_html.zip"
"https://github.com/${pkgbase}/${pkgbase}/releases/download/${pkgver}/Csound${pkgver}_manual_pdf.zip"
"fluidsynth2.patch")
sha512sums=('e00a1f74e38cc5edadcaa4ea2a38a79a010be21008cad091b46c79ed18242a925ab9279fc049b4e82f6944e4d6e815787b7f847b08ae3bba9bde60570aa96f58'
"https://github.com/${pkgbase}/${pkgbase}/releases/download/${pkgver}/Csound${pkgver}_manual_pdf.zip")
sha512sums=('51a30cb426fc77ac648f6a9fb669b9298e6608b39ae3b12181d16ecf1fb6f2ed3db31471615a60d2ce7906b91fdb911b38c8dfa3f93699768f490f87a2bcbbbd'
'53a8ae1e61db2a3a492930ef0f0881b613ae47108c5e8de0a6e2aa28bcf7a5c93c7fea8b7fc2bbae29ab92e1e68bf94ba406be1255ad8ab5725ea9078c1fd6dc'
'bf762db1079dde5b62f2bfe8ba649ac9e719b6ada535f3d67d048213133aeecb3caa3cb1e5bbf26fe78e4b1882e08be9bbea701bd49c914bfbf8d3ab7d83013b'
'eb287b9070c16d6cfbd890532d97eda34d72d8b5e5548a1a55ed7de91b2b913e04426cd50c94d0ac84221396002421077a5d22b3b67ce634c34a9aa1ceb53d9d'
'881bbdae5ab7fceb28199084173492eb8cc6477e72100739599e9d1448c607062efd1390b5cb19e03aeeae9c58eb608b61f36853dddb4d9141b86da31d00bc45'
'bf762db1079dde5b62f2bfe8ba649ac9e719b6ada535f3d67d048213133aeecb3caa3cb1e5bbf26fe78e4b1882e08be9bbea701bd49c914bfbf8d3ab7d83013b')
'87de3efc9aba736751d5bd93bb7bb9d47a3fc4c2e9df4552c9c1f3030f84e1aa29fa421f5360a22993cf0f6f7baae1d70bfb54201e5110f44f5a8c81d955deb5'
'30a55ec2c3ab0e243ac48a081954bea1f8fa653d25c908383c49a879972b94ba2ce7c3b3b0701be18ace28dc7fd199597d889fa1f9e5aca478792b835909c8fa')
prepare() {
cd "${pkgbase}-${pkgver}"
patch -Np1 -i ../fluidsynth2.patch
mkdir build
}
build() {
@ -51,13 +44,13 @@ build() {
-DCMAKE_CXX_FLAGS="-Wno-error -Wno-missing-field-initializers -DPFFFT_SIMD_DISABLE" \
-DCMAKE_C_FLAGS="-Wno-error -Wno-missing-field-initializers -DPFFFT_SIMD_DISABLE" \
-DBUILD_JAVA_INTERFACE=0 \
-DLUA_MODULE_INSTALL_DIR=/usr/lib/lua/5.1/ \
-DLUAJIT_LIBRARY=/usr/lib/libluajit-5.1.so \
-DLUA_H_PATH=/usr/include/luajit-2.0/ \
-DLUA_LIBRARY=/usr/lib/liblua.so \
-DPYTHON_MODULE_INSTALL_DIR=/usr/lib/python2.7/site-packages \
-DBUILD_STATIC_LIBRARY=ON \
-DBUILD_ABLETON_LINK_OPCODES=ON \
-DABLETON_LINK_HOME=/usr/include/ableton \
..
make
make VERBOSE=1
}
check() {
@ -67,15 +60,25 @@ check() {
package_csound() {
groups=('pro-audio')
depends=('fluidsynth' 'git' 'hdf5' 'liblo' 'libmusicxml' 'libwebsockets'
'luajit' 'portmidi' 'portsmf' 'stk' 'tk' 'wiiuse')
optdepends=('csound-doc: The canonical Csound Reference Manual'
'csoundqt: Qt frontend'
'fltk: fltk GUIs'
'faust: Embed faust'
'java-runtime=8: Use csound with Java'
'python2: python opcodes'
'vim-csound: Use csound with vim')
depends=('curl' 'libsndfile')
optdepends=('alsa-lib: librtalsa opcode'
'csound-doc: The canonical Csound Reference Manual'
'csoundqt: frontend/ editor with integrated help'
'fltk: libvirtual/libwidgets opcode'
'faust: libfaustcsound opcode'
'fluidsynth: libfluidsynth opcode'
'hdf5: hdf5ops opcode'
'jack: libjacko, librtjack, libjackTransport opcode'
'java-runtime: java integration'
'liblo: OSC opcode'
'libpulse: librtpulse opcode'
'libwebsockets: libwebsocketIO opcode'
'lua: LUA integration'
'portmidi: libpmidi opcode'
'python2: libpy opcode/ python2 integration'
'stk: stk opcode'
'vim-csound: vim integration'
'wiiuse: wiimote opcode')
cd "${pkgname}-${pkgver}/build"
make DESTDIR="${pkgdir}/" install

View file

@ -1,59 +0,0 @@
diff -ruN a/Opcodes/fluidOpcodes/fluidOpcodes.cpp b/Opcodes/fluidOpcodes/fluidOpcodes.cpp
--- a/Opcodes/fluidOpcodes/fluidOpcodes.cpp 2018-11-07 15:05:23.000000000 +0100
+++ b/Opcodes/fluidOpcodes/fluidOpcodes.cpp 2019-01-25 17:59:40.572147743 +0100
@@ -208,6 +208,7 @@
} else if (listPresets) {
fluid_sfont_t *fluidSoundfont =
fluid_synth_get_sfont_by_id(fluidSynth, soundFontId);
+#if FLUIDSYNTH_VERSION_MAJOR < 2
fluid_preset_t fluidPreset;
fluidSoundfont->iteration_start(fluidSoundfont);
OPARMS oparms;
@@ -218,6 +219,19 @@
soundFontId, fluidPreset.get_banknum(&fluidPreset),
fluidPreset.get_num(&fluidPreset),
fluidPreset.get_name(&fluidPreset));
+#else
+ fluid_preset_t *fluidPreset;
+ fluid_sfont_iteration_start(fluidSoundfont);
+ OPARMS oparms;
+ csound->GetOParms(csound, &oparms);
+ if (oparms.msglevel & 0x7)
+ while (fluidPreset = fluid_sfont_iteration_next(fluidSoundfont))
+ {
+ log(csound, "SoundFont: %3d Bank: %3d Preset: %3d %s\n",
+ soundFontId, fluid_preset_get_banknum(fluidPreset),
+ fluid_preset_get_num(fluidPreset),
+ fluid_preset_get_name(fluidPreset));
+#endif
}
}
return result;
@@ -279,6 +293,7 @@
toa(iFluidSynth, fluidSynth);
fluid_sfont_t *fluidSoundfont =
fluid_synth_get_sfont(fluidSynth, 0);
+#if FLUIDSYNTH_VERSION_MAJOR < 2
fluid_preset_t fluidPreset;
fluidSoundfont->iteration_start(fluidSoundfont);
OPARMS oparms;
@@ -290,6 +305,19 @@
ss << "Bank: " << fluidPreset.get_banknum(&fluidPreset) <<
" Preset: " << fluidPreset.get_num(&fluidPreset) <<
" Name: " << fluidPreset.get_name(&fluidPreset);
+#else
+ fluid_preset_t *fluidPreset;
+ fluid_sfont_iteration_start(fluidSoundfont);
+ OPARMS oparms;
+ csound->GetOParms(csound, &oparms);
+ if (oparms.msglevel & 0x7)
+ while (fluidPreset = fluid_sfont_iteration_next(fluidSoundfont))
+ {
+ std::stringstream ss;
+ ss << "Bank: " << fluid_preset_get_banknum(fluidPreset) <<
+ " Preset: " << fluid_preset_get_num(fluidPreset) <<
+ " Name: " << fluid_preset_get_name(fluidPreset);
+#endif
programs.push_back(ss.str());
}