extra/openal to 1.14-1

This commit is contained in:
Kevin Mihelich 2012-06-07 09:01:05 -04:00
parent fed6838e23
commit 15ee02b3fb
2 changed files with 48 additions and 12 deletions

View file

@ -1,17 +1,14 @@
# $Id$
# $Id: PKGBUILD 155305 2012-04-01 14:23:52Z heftig $
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributer: Jason Chu <jchu@xentac.net>
# Contributor: Jason Chu <jchu@xentac.net>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - 1.14 is broken for ARM, staying at 1.13 for now
plugrel=1
noautobuild=1
# - fix for unimplemented _FPU_EXTENDED
pkgname=openal
pkgver=1.13
pkgrel=3
pkgver=1.14
pkgrel=1
pkgdesc="A cross-platform 3D audio library"
arch=(i686 x86_64)
url="http://www.openal.org/"
@ -19,17 +16,21 @@ license=(LGPL)
depends=(glibc)
makedepends=(alsa-lib sdl pkgconfig cmake libpulse)
options=('!libtool')
source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2)
md5sums=('58b7d2809790c70681b825644c5f3614')
source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2
no-fpuextended.patch)
md5sums=('3d8b86c21a2f87a2a5e60f78f3b3f03d'
'de9569536f9f1c2b7b0e90d381c631de')
build() {
cd "$srcdir/$pkgname-soft-$pkgver/build"
cd "${srcdir}/$pkgname-soft-$pkgver"
patch -p1 -i "${srcdir}"/no-fpuextended.patch
cd "${srcdir}/$pkgname-soft-$pkgver/build"
cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release ..
make
}
package() {
cd "$srcdir/$pkgname-soft-$pkgver"
cd $pkgname-soft-$pkgver
make -C build DESTDIR="$pkgdir/" install
install -Dm644 alsoftrc.sample "$pkgdir/etc/openal/alsoft.conf.sample"
}

View file

@ -0,0 +1,35 @@
Description: Fix builds on architectures without _FPU_EXTENDED
Author: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
--- a/OpenAL32/Include/alu.h
+++ b/OpenAL32/Include/alu.h
@@ -224,6 +224,29 @@
return a0*mu*mu2 + a1*mu2 + a2*mu + a3;
}
+#if defined(_FPU_GETCW) && defined(_FPU_SETCW)
+ #ifndef _FPU_EXTENDED
+ #define _FPU_EXTENDED 0
+ #endif
+ #ifndef _FPU_DOUBLE
+ #define _FPU_DOUBLE 0
+ #endif
+ #ifndef _FPU_SINGLE
+ #define _FPU_SINGLE 0
+ #endif
+ #ifndef _FPU_RC_NEAREST
+ #define _FPU_RC_NEAREST 0
+ #endif
+ #ifndef _FPU_RC_DOWN
+ #define _FPU_RC_DOWN 0
+ #endif
+ #ifndef _FPU_RC_UP
+ #define _FPU_RC_UP 0
+ #endif
+ #ifndef _FPU_RC_ZERO
+ #define _FPU_RC_ZERO 0
+ #endif
+#endif
static __inline int SetMixerFPUMode(void)
{