mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-kirkwood-dt to 3.8-rc2
This commit is contained in:
parent
2536ca89dd
commit
160baac217
3 changed files with 21 additions and 20 deletions
|
@ -7,7 +7,7 @@ pkgbase=linux-kirkwood-dt
|
|||
pkgname=('linux-kirkwood-dt' 'linux-headers-kirkwood-dt')
|
||||
#pkgname=linux-test # Build kernel with a different name
|
||||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.8_rc1
|
||||
_basekernel=3.8_rc2
|
||||
pkgver=${_basekernel}
|
||||
pkgrel=1
|
||||
cryptover=1.5
|
||||
|
@ -21,6 +21,7 @@ source=('support.patch'
|
|||
'dts-bootarg-wipe.patch'
|
||||
'usb-add-reset-resume-quirk-for-several-webcams.patch'
|
||||
'rtl871x-arm.patch'
|
||||
'mvebu-clk.patch'
|
||||
'pending-3.8.patch'
|
||||
"http://download.gna.org/cryptodev-linux/cryptodev-linux-${cryptover}.tar.gz"
|
||||
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/3.7.0-v5r1/0001-block-cgroups-kconfig-build-bits-for-BFQ-v5r1-3.7.patch"
|
||||
|
@ -31,14 +32,15 @@ md5sums=('f5d3635da03cb45904bedd69b47133de'
|
|||
'6d955c1f4882be73618018fc3b419ebf'
|
||||
'd00814b57448895e65fbbc800e8a58ba'
|
||||
'c38fa5f5065be065282887e0a3e2dc63'
|
||||
'36ff44ed40baabfad659e11ce170ccd4'
|
||||
'a3d5a876ac8ac41457c104cc04ae9b47'
|
||||
'3a4b8d23c1708283e29477931d63ffb8'
|
||||
'9daa5f662145f91b25b91b9fbeb874d9'
|
||||
'c80954ae588d8c168a0b1ae9ffe84c0e')
|
||||
|
||||
__gitroot="git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git"
|
||||
__gitname="linux-next"
|
||||
__gitbranch="v3.8-rc1"
|
||||
__gitroot="git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git"
|
||||
__gitname="linux"
|
||||
__gitbranch="v3.8-rc2"
|
||||
|
||||
build() {
|
||||
cd "${srcdir}"
|
||||
|
@ -73,13 +75,12 @@ build() {
|
|||
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
|
||||
# patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
|
||||
|
||||
# Fix read_current_timer so it's exported to modules, upstream is aware and
|
||||
# a proper fix is pending.
|
||||
#patch -Np1 -i "${srcdir}/read_current_timer2.patch"
|
||||
|
||||
# Hack fix for an alignment bug in RTL8712 driver
|
||||
patch -Np1 -i "${srcdir}/rtl871x-arm.patch"
|
||||
|
||||
# Section Mismatch in mvebu clk
|
||||
patch -Np1 -i "${srcdir}/mvebu-clk.patch"
|
||||
|
||||
# General fixes queued for next release
|
||||
patch -Np1 -i "${srcdir}/pending-3.8.patch"
|
||||
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -upr linux-3.0.orig/kernel/printk.c linux-3.0/kernel/printk.c
|
||||
--- linux-3.0.orig/kernel/printk.c 2011-07-22 05:17:23.000000000 +0300
|
||||
+++ linux-3.0/kernel/printk.c 2011-07-27 14:43:07.000000000 +0300
|
||||
@@ -58,7 +58,7 @@ void asmlinkage __attribute__((weak)) ea
|
||||
|
||||
/* We show everything that is MORE important than this.. */
|
||||
#define MINIMUM_CONSOLE_LOGLEVEL 1 /* Minimum loglevel we let people use */
|
||||
-#define DEFAULT_CONSOLE_LOGLEVEL 7 /* anything MORE serious than KERN_DEBUG */
|
||||
+#define DEFAULT_CONSOLE_LOGLEVEL 4 /* anything MORE serious than KERN_DEBUG */
|
||||
|
||||
DECLARE_WAIT_QUEUE_HEAD(log_wait);
|
||||
|
12
core/linux-kirkwood-dt/mvebu-clk.patch
Normal file
12
core/linux-kirkwood-dt/mvebu-clk.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -ruN a/drivers/clk/mvebu/clk-gating-ctrl.c b/drivers/clk/mvebu/clk-gating-ctrl.c
|
||||
--- a/drivers/clk/mvebu/clk-gating-ctrl.c 2013-01-02 21:13:21.000000000 -0500
|
||||
+++ b/drivers/clk/mvebu/clk-gating-ctrl.c 2013-01-03 11:40:44.000000000 -0500
|
||||
@@ -32,7 +32,7 @@
|
||||
|
||||
#define to_clk_gate(_hw) container_of(_hw, struct clk_gate, hw)
|
||||
|
||||
-static struct clk __init *mvebu_clk_gating_get_src(
|
||||
+static struct clk *mvebu_clk_gating_get_src(
|
||||
struct of_phandle_args *clkspec, void *data)
|
||||
{
|
||||
struct mvebu_gating_ctrl *ctrl = (struct mvebu_gating_ctrl *)data;
|
Loading…
Reference in a new issue