mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed extra/graphite
This commit is contained in:
parent
8ec692fcfe
commit
161573dcd5
2 changed files with 0 additions and 87 deletions
|
@ -1,71 +0,0 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: AndyRTR <andyrtr@archlinux.org>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - patch for arm
|
|
||||||
|
|
||||||
pkgname=graphite
|
|
||||||
pkgver=1.3.11
|
|
||||||
pkgrel=1
|
|
||||||
epoch=1
|
|
||||||
arch=('x86_64')
|
|
||||||
url="https://github.com/silnrsi/graphite"
|
|
||||||
pkgdesc='reimplementation of the SIL Graphite text processing engine'
|
|
||||||
license=('LGPL' 'GPL' 'custom')
|
|
||||||
depends=('gcc-libs')
|
|
||||||
makedepends=('cmake' 'freetype2' 'python2'
|
|
||||||
# for documentation
|
|
||||||
'doxygen' 'dblatex' 'graphviz' 'asciidoc')
|
|
||||||
checkdepends=('python2-fonttools')
|
|
||||||
options=('!emptydirs')
|
|
||||||
source=(https://github.com/silnrsi/graphite/releases/download/${pkgver}/graphite2-${pkgver}.tgz
|
|
||||||
graphite-arm-nodefaultlibs.patch)
|
|
||||||
sha1sums=('26b70897bac68868d964ef70002c384ec10b6572'
|
|
||||||
'67b4fb81303484a65ab5bfa183da999d14169157')
|
|
||||||
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${srcdir}"
|
|
||||||
|
|
||||||
# python2 fixes
|
|
||||||
sed -i "s:\/usr\/bin\/python:\/usr\/bin\/python2:" graphite2-${pkgver}/tests/{corrupt.py,defuzz,fnttxtrender,fuzzbidi,fuzztest,hbspeeds,jsoncmp}
|
|
||||||
|
|
||||||
cd graphite2-${pkgver}
|
|
||||||
patch -Np1 -i ${srcdir}/graphite-arm-nodefaultlibs.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
mkdir build
|
|
||||||
cd build
|
|
||||||
cmake -G "Unix Makefiles" ../graphite2-${pkgver} \
|
|
||||||
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
|
|
||||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
||||||
-DCMAKE_BUILD_TYPE:STRING=Release \
|
|
||||||
-DGRAPHITE2_COMPARE_RENDERER=OFF \
|
|
||||||
|
|
||||||
# fix unwanted -O3 cflag (taken form Debian)
|
|
||||||
find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
|
|
||||||
|
|
||||||
make
|
|
||||||
make -j1 docs
|
|
||||||
}
|
|
||||||
|
|
||||||
check() {
|
|
||||||
cd "${srcdir}"/build
|
|
||||||
# python2 fixes
|
|
||||||
sed -i "s:python:python2:g" tests/CTestTestfile.cmake
|
|
||||||
ctest || true
|
|
||||||
}
|
|
||||||
|
|
||||||
package() {
|
|
||||||
cd "${srcdir}"/build
|
|
||||||
make DESTDIR="$pkgdir/" install
|
|
||||||
# install doc files
|
|
||||||
mkdir -p "${pkgdir}"/usr/share/doc/graphite2/api
|
|
||||||
cp -vrf doc/doxygen/{html,latex/refman.pdf} "${pkgdir}"/usr/share/doc/graphite2/api
|
|
||||||
cp -vrf doc/{GTF,manual}.html "${pkgdir}"/usr/share/doc/graphite2
|
|
||||||
|
|
||||||
# licenses
|
|
||||||
mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
|
|
||||||
install -m644 "${srcdir}"/graphite2-${pkgver}/COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
|
|
||||||
}
|
|
|
@ -1,16 +0,0 @@
|
||||||
--- graphite2-1.2.0/src/CMakeLists.txt.orig 2012-11-09 17:48:04.908391335 +0800
|
|
||||||
+++ graphite2-1.2.0/src/CMakeLists.txt 2012-11-09 17:48:48.647102280 +0800
|
|
||||||
@@ -118,11 +118,7 @@
|
|
||||||
if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
|
|
||||||
target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
|
|
||||||
else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
|
|
||||||
- if (GRAPHITE2_ASAN)
|
|
||||||
- target_link_libraries(graphite2 c gcc_s)
|
|
||||||
- else (GRAPHITE2_ASAN)
|
|
||||||
- target_link_libraries(graphite2 c gcc)
|
|
||||||
- endif (GRAPHITE2_ASAN)
|
|
||||||
+ target_link_libraries(graphite2 c gcc_s)
|
|
||||||
include(Graphite)
|
|
||||||
nolib_test(stdc++ $<TARGET_SONAME_FILE:graphite2>)
|
|
||||||
endif (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
|
|
||||||
|
|
Loading…
Reference in a new issue