mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/nodejs: v6 fix
This commit is contained in:
parent
9d8d44fe8a
commit
162cbd50d8
2 changed files with 24 additions and 2 deletions
|
@ -10,6 +10,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - set config and gyp flags
|
||||
# - patch to link libatomic for v6
|
||||
|
||||
buildarch=28
|
||||
|
||||
|
@ -23,8 +24,10 @@ license=('MIT')
|
|||
depends=('openssl' 'zlib' 'icu' 'libuv' 'http-parser' 'c-ares' 'libnghttp2') # 'v8')
|
||||
makedepends=('python2' 'procps-ng')
|
||||
optdepends=('npm: nodejs package manager')
|
||||
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz")
|
||||
sha512sums=('43eae2d23eb9326ce9f248dcf136151dcbd1ccdf557ab8bce7b96cb2b330a4817eddeadb0460bdd8d468e67d480a2ef781a96c0e8e0e35a8900764484e55f0a1')
|
||||
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz"
|
||||
'atomic.patch')
|
||||
sha512sums=('43eae2d23eb9326ce9f248dcf136151dcbd1ccdf557ab8bce7b96cb2b330a4817eddeadb0460bdd8d468e67d480a2ef781a96c0e8e0e35a8900764484e55f0a1'
|
||||
'fa6d8a03f397b170353cdf2ca6578b5173d1cbc1f588e404e5aab1e34c05d99ad4fe2f1cf28cbbeb3bf8b7563960f37f9469c312484bdbe41c20d6fe05121c95')
|
||||
|
||||
prepare() {
|
||||
cd node-$pkgver
|
||||
|
@ -38,6 +41,10 @@ prepare() {
|
|||
-e 's_^\(.*\)python\( \+-c \+.*\)$_\1python2\2_'\
|
||||
-e "s_'python'_'python2'_" -i {} \;
|
||||
find test/ -type f -exec sed 's_python _python2 _' -i {} \;
|
||||
|
||||
if [[ $CARCH == "armv6h" ]]; then
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
15
community/nodejs/atomic.patch
Normal file
15
community/nodejs/atomic.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- node.gyp.orig 2018-08-16 12:34:32.110341767 -0600
|
||||
+++ node.gyp 2018-08-16 12:35:47.914941800 -0600
|
||||
@@ -320,6 +320,12 @@
|
||||
'<(SHARED_INTERMEDIATE_DIR)' # for node_natives.h
|
||||
],
|
||||
|
||||
+ 'link_settings': {
|
||||
+ 'libraries': [
|
||||
+ '-latomic',
|
||||
+ ],
|
||||
+ },
|
||||
+
|
||||
'sources': [
|
||||
'src/async_wrap.cc',
|
||||
'src/bootstrapper.cc',
|
Loading…
Reference in a new issue