extra/linux-tools to 6.3-4

This commit is contained in:
Kevin Mihelich 2023-08-07 12:37:45 +00:00
parent b9e9f43337
commit 164b27727a
2 changed files with 62 additions and 3 deletions

View file

@ -22,7 +22,7 @@ pkgname=(
'iio-utils' 'iio-utils'
) )
pkgver=6.3 pkgver=6.3
pkgrel=2 pkgrel=4
license=('GPL2') license=('GPL2')
arch=('x86_64') arch=('x86_64')
url='https://www.kernel.org' url='https://www.kernel.org'
@ -55,7 +55,9 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-${pkgver}.tar.xz"
'usbipd.service' 'usbipd.service'
'hv_fcopy_daemon.service' 'hv_fcopy_daemon.service'
'hv_kvp_daemon.service' 'hv_kvp_daemon.service'
'hv_vss_daemon.service') 'hv_vss_daemon.service'
'fix-perf-tests.patch'
)
sha256sums=('74862fa8ab40edae85bb3385c0b71fe103288bce518526d63197800b3cbdecb1' sha256sums=('74862fa8ab40edae85bb3385c0b71fe103288bce518526d63197800b3cbdecb1'
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f' '4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
'b692f4859ed3fd9831a058a450a84d8c409bf7e3e45aac1c2896a14bb83f3d7a' 'b692f4859ed3fd9831a058a450a84d8c409bf7e3e45aac1c2896a14bb83f3d7a'
@ -63,7 +65,8 @@ sha256sums=('74862fa8ab40edae85bb3385c0b71fe103288bce518526d63197800b3cbdecb1'
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f' '2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
'16855c197d2334f820cb190312a5a7fffe9165189db01344a957e582e39e17d8' '16855c197d2334f820cb190312a5a7fffe9165189db01344a957e582e39e17d8'
'b1315cb77a35454e1af9172f821a52e2a0cb18561be05a340d21cf337b01ae61' 'b1315cb77a35454e1af9172f821a52e2a0cb18561be05a340d21cf337b01ae61'
'2d5e2f8d40b6f19bf2e1dead57ca105d72098fb0b418c09ff2e0cb91089710af') '2d5e2f8d40b6f19bf2e1dead57ca105d72098fb0b418c09ff2e0cb91089710af'
'26bce106f363fd382b5669c5098c76c127d564da827b254847c7b7e76e39f912')
prepare() { prepare() {
cd linux-$pkgver cd linux-$pkgver

View file

@ -0,0 +1,56 @@
First noticed on Fedora Rawhide:
tests/bpf.c: In function epoll_pwait_loop:
tests/bpf.c:36:17: error: argument 2 null where non-null expected [-Werror=nonnull]
36 | epoll_pwait(-(i + 1), NULL, 0, 0, NULL);
| ^~~~~~~~~~~
In file included from tests/bpf.c:5:
/usr/include/sys/epoll.h:134:12: note: in a call to function epoll_pwait declared nonnull
134 | extern int epoll_pwait (int __epfd, struct epoll_event *__events,
| ^~~~~~~~~~~
[perfbuilder@27cfe44d67ed perf-6.5.0-rc2]$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/13/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-redhat-linux
Configured with: ../configure --enable-bootstrap --enable-languages=c,c++,fortran,objc,obj-c++,ada,go,d,m2,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --enable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-gcc-major-version-only --enable-libstdcxx-backtrace --with-libstdcxx-zoneinfo=/usr/share/zoneinfo --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --with-isl=/builddir/build/BUILD/gcc-13.2.1-20230728/obj-x86_64-redhat-linux/isl-install --enable-offload-targets=nvptx-none --without-cuda-driver --enable-offload-defaulted --enable-gnu-indirect-function --enable-cet --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux --with-build-config=bootstrap-lto --enable-link-serialization=1
Thread model: posix
Supported LTO compression algorithms: zlib zstd
gcc version 13.2.1 20230728 (Red Hat 13.2.1-1) (GCC)
[perfbuilder@27cfe44d67ed perf-6.5.0-rc2]$
Just add that argument to address this compiler warning.
Cc: Adrian Hunter <adrian.hunter@intel.com>
Cc: Ian Rogers <irogers@google.com>
Cc: Jiri Olsa <jolsa@kernel.org>
Cc: Namhyung Kim <namhyung@kernel.org>
Link: https://lore.kernel.org/lkml/
Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
---
tools/perf/tests/bpf.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/tools/perf/tests/bpf.c b/tools/perf/tests/bpf.c
index 31796f2a80f47fb1..9ccecd873ecdd046 100644
--- a/tools/perf/tests/bpf.c
+++ b/tools/perf/tests/bpf.c
@@ -29,11 +29,12 @@
static int epoll_pwait_loop(void)
{
+ struct epoll_event events;
int i;
/* Should fail NR_ITERS times */
for (i = 0; i < NR_ITERS; i++)
- epoll_pwait(-(i + 1), NULL, 0, 0, NULL);
+ epoll_pwait(-(i + 1), &events, 0, 0, NULL);
return 0;
}
--
2.37.1