community/gdal to 1.11.2-1

This commit is contained in:
Kevin Mihelich 2015-02-24 01:55:43 +00:00
parent ea8103c2aa
commit 1659062c49
2 changed files with 5 additions and 25 deletions

View file

@ -8,8 +8,8 @@
# - use uname in path in removing rpath in packaging
pkgname=gdal
pkgver=1.11.1
pkgrel=6
pkgver=1.11.2
pkgrel=1
pkgdesc="A translator library for raster geospatial data formats"
arch=('i686' 'x86_64')
url="http://www.gdal.org/"
@ -21,16 +21,13 @@ optdepends=('postgresql: postgresql database support'
'perl: perl binding support')
changelog=$pkgname.changelog
source=(http://download.osgeo.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
gdal-1.5.1-python-install.patch gdal-sqlite-3.8.7.patch)
sha256sums=('f46b5944a8cabc8516673f231f466131cdfd2cdc6677dbee5d96ec7fc58a3340'
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6'
'2c1546f3303c27b5b9476192fd1f75fad0824380e711699ab09c2dd2f42d53c0')
gdal-1.5.1-python-install.patch)
sha256sums=('66bc8192d24e314a66ed69285186d46e6999beb44fc97eeb9c76d82a117c0845'
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6')
prepare() {
cd "${srcdir}"/$pkgname-$pkgver
patch -Np0 -i "${srcdir}"/gdal-1.5.1-python-install.patch
#FS#43193
patch -Np2 -i "${srcdir}"/gdal-sqlite-3.8.7.patch
# python2 fixes
sed -i 's_python python1.5_python2 python python1.5_' configure

View file

@ -1,17 +0,0 @@
diff --git a/gdal/ogr/ogrsf_frmts/sqlite/ogrsqlitevirtualogr.cpp b/gdal/ogr/ogrsf_frmts/sqlite/ogrsqlitevirtualogr.cpp
index a30b452..d45f3ff 100644
--- a/gdal/ogr/ogrsf_frmts/sqlite/ogrsqlitevirtualogr.cpp
+++ b/gdal/ogr/ogrsf_frmts/sqlite/ogrsqlitevirtualogr.cpp
@@ -2451,6 +2451,12 @@ int OGR2SQLITE_static_register (sqlite3 * hDB, char **pzErrMsg,
/* OGR2SQLITE_Register() */
/************************************************************************/
+#ifdef sqlite3_auto_extension
+// Sqlite 3.8.7 defines sqlite3_auto_extension via sqlite3_api
+// which is not initialized at this moment
+#undef sqlite3_auto_extension
+#endif
+
/* We call this function so that each time a db is created, */
/* OGR2SQLITE_static_register is called, to initialize the sqlite3_api */
/* structure with the right pointers. */