core/linux-armv7 to 4.18.12-1

This commit is contained in:
Kevin Mihelich 2018-10-09 01:37:09 +00:00
parent de98c0e3e1
commit 1697a97c5c
16 changed files with 98 additions and 115 deletions

View file

@ -1,4 +1,4 @@
From 6cd78f818001a5e2caac7cadc3ffff95d752a021 Mon Sep 17 00:00:00 2001
From 6224b22e9cee18409420b6afcbea455a44ab8432 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/14] ARM: atags: add support for Marvell's u-boot
@ -47,5 +47,5 @@ index 6b335a9ff8c8..614150b53643 100644
};
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From a383c6aaa67e862797d380a5163e633637358568 Mon Sep 17 00:00:00 2001
From 35efb3ef775746d24439855fb3ceab2a494067a5 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/14] ARM: atags/fdt: retrieve MAC addresses from Marvell
@ -43,5 +43,5 @@ index 41fa7316c52b..807ed160a4b9 100644
}
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 121aa156d4d107cf2b174c8eac89c7c473c43829 Mon Sep 17 00:00:00 2001
From 4b7d62ac895d119d77a19d7424a1ee0aae6e2e06 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/14] SMILE Plug device tree file
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From bca0f6d98bb3003178d962f83ba795d524460346 Mon Sep 17 00:00:00 2001
From 9d43507a5440306db90fc73ab93ef02f71d05f55 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/14] fix mvsdio eMMC timing
@ -34,5 +34,5 @@ index e22bbff89c8d..6b30c850ce07 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 021b0a93050b75f56690bbe41fc470c77f7573c0 Mon Sep 17 00:00:00 2001
From aff9778d098775518d28ae13f3569345986439ae Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
@ -92,5 +92,5 @@ index 06b4d290784d..3be3b5a4a176 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 529b0cbe182106ce8b52cf465f3c54c3e0f12e1c Mon Sep 17 00:00:00 2001
From d41a1997e872ccccc6bebc01934224a763901b2e Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/14] set default cubietruck led triggers
@ -29,5 +29,5 @@ index 5649161de1d7..2be64a886555 100644
};
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From adec3bf3f301ddb15994be72c92f43cc5569dd03 Mon Sep 17 00:00:00 2001
From f9ca16df1a08bff0130b5635a4ded4efc985d287 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/14] exynos4412-odroid: set higher minimum buck2 regulator
@ -26,5 +26,5 @@ index a09e46c9dbc0..d8117a820812 100644
regulator-always-on;
regulator-boot-on;
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 58b7a9138a44bef39a860611354c3dac0f558b1f Mon Sep 17 00:00:00 2001
From 3ab4beffef5dba9464bbbf602e26b0de956b5858 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/14] ARM: dove: enable ethernet on D3Plug
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 4ddcbb9ed40c97371724245d0b8d01d471bb6570 Mon Sep 17 00:00:00 2001
From bd8a33c8e2e066c662c318dae6f87e02f97667c7 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:03 +0800
Subject: [PATCH 09/14] power: add power sequence library
@ -109,10 +109,10 @@ index 000000000000..554608e5f3b6
+.. kernel-doc:: drivers/power/pwrseq/core.c
+ :export:
diff --git a/MAINTAINERS b/MAINTAINERS
index 96e98e206b0d..99339375209c 100644
index 544cac829cf4..ac1c64ba20fa 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11398,6 +11398,15 @@ F: drivers/firmware/psci*.c
@@ -11402,6 +11402,15 @@ F: drivers/firmware/psci*.c
F: include/linux/psci.h
F: include/uapi/linux/psci.h
@ -786,5 +786,5 @@ index 000000000000..c5b278f5f2ae
+
+#endif /* __LINUX_PWRSEQ_H */
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 1358757f34c7feff4aab541814c73f6cf3e83b69 Mon Sep 17 00:00:00 2001
From b8a4a0686bf56ac41d3eab86b1397968bca5aea9 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:05 +0800
Subject: [PATCH 10/14] usb: core: add power sequence handling for USB devices
@ -39,7 +39,7 @@ index 987fc5ba6321..bd09fc8ff763 100644
---help---
Universal Serial Bus (USB) is a specification for a serial bus
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index fcae521df29b..0c708d3ef179 100644
index 1fb266809966..3003d482109b 100644
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
@@ -28,6 +28,7 @@
@ -50,7 +50,7 @@ index fcae521df29b..0c708d3ef179 100644
#include <linux/uaccess.h>
#include <asm/byteorder.h>
@@ -1654,6 +1655,7 @@ static void hub_disconnect(struct usb_interface *intf)
@@ -1658,6 +1659,7 @@ static void hub_disconnect(struct usb_interface *intf)
hub->error = 0;
hub_quiesce(hub, HUB_DISCONNECT);
@ -58,7 +58,7 @@ index fcae521df29b..0c708d3ef179 100644
mutex_lock(&usb_port_peer_mutex);
/* Avoid races with recursively_mark_NOTATTACHED() */
@@ -1700,11 +1702,41 @@ static bool hub_descriptor_is_sane(struct usb_host_interface *desc)
@@ -1704,11 +1706,41 @@ static bool hub_descriptor_is_sane(struct usb_host_interface *desc)
return true;
}
@ -100,7 +100,7 @@ index fcae521df29b..0c708d3ef179 100644
desc = intf->cur_altsetting;
hdev = interface_to_usbdev(intf);
@@ -1795,6 +1827,7 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
@@ -1799,6 +1831,7 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
INIT_DELAYED_WORK(&hub->leds, led_work);
INIT_DELAYED_WORK(&hub->init_work, NULL);
INIT_WORK(&hub->events, hub_event);
@ -108,7 +108,7 @@ index fcae521df29b..0c708d3ef179 100644
usb_get_intf(intf);
usb_get_dev(hdev);
@@ -1808,11 +1841,14 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
@@ -1812,11 +1845,14 @@ static int hub_probe(struct usb_interface *intf, const struct usb_device_id *id)
if (id->driver_info & HUB_QUIRK_CHECK_PORT_AUTOSUSPEND)
hub->quirk_check_port_auto_suspend = 1;
@ -126,7 +126,7 @@ index fcae521df29b..0c708d3ef179 100644
}
static int
@@ -3653,14 +3689,19 @@ static int hub_suspend(struct usb_interface *intf, pm_message_t msg)
@@ -3657,14 +3693,19 @@ static int hub_suspend(struct usb_interface *intf, pm_message_t msg)
/* stop hub_wq and related activity */
hub_quiesce(hub, HUB_SUSPEND);
@ -160,5 +160,5 @@ index 4accfb63f7dc..abe71c5e84cb 100644
/**
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 0b61e501bdfb883df4211fdc47d246df6af06e5a Mon Sep 17 00:00:00 2001
From f1eed409a101441d63efaa49dee661e909f1a761 Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:06 +0800
Subject: [PATCH 11/14] ARM: dts: imx6qdl: Enable usb node children with <reg>
@ -45,5 +45,5 @@ index 911141e24681..c74e9c7a83bf 100644
interrupts = <0 42 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>;
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 3e35057ab8b11c232a7c0edeea3299d53c6d600d Mon Sep 17 00:00:00 2001
From a154b0eeb6953a096afc7ee940feea11c3b2c6b5 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:07 +0800
Subject: [PATCH 12/14] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
@ -76,5 +76,5 @@ index 4f27861bbb32..dead14b0d4bf 100644
&usdhc3 {
--
2.18.0
2.19.0

View file

@ -1,4 +1,4 @@
From 9d40728e452daf4d77f8924e499814138dc5363c Mon Sep 17 00:00:00 2001
From eec27ce353f52898b5341814f403441b0b254097 Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:08 +0800
Subject: [PATCH 13/14] ARM: dts: imx6q-evi: Fix onboard hub reset line
@ -70,5 +70,5 @@ index fcd257bc5ac3..d32fa81bba95 100644
>;
};
--
2.18.0
2.19.0

View file

@ -1,61 +0,0 @@
From a877c2568fc96a7a7ba89dd4cf0df20341df2a37 Mon Sep 17 00:00:00 2001
From: Ethan Tuttle <ethan@ethantuttle.com>
Date: Tue, 19 Jun 2018 21:31:08 -0700
Subject: [PATCH 14/14] ARM: mvebu: declare asm symbols as character arrays in
pmsu.c
With CONFIG_FORTIFY_SOURCE, memcpy uses the declared size of operands to
detect buffer overflows. If src or dest is declared as a char, attempts to
copy more than byte will result in a fortify_panic().
Address this problem in mvebu_setup_boot_addr_wa() by declaring
mvebu_boot_wa_start and mvebu_boot_wa_end as character arrays. Also remove
a couple addressof operators to avoid "arithmetic on pointer to an
incomplete type" compiler error.
See commit 54a7d50b9205 ("x86: mark kprobe templates as character arrays,
not single characters") for a similar fix.
Fixes "detected buffer overflow in memcpy" error during init on some mvebu
systems (armada-370-xp, armada-375):
(fortify_panic) from (mvebu_setup_boot_addr_wa+0xb0/0xb4)
(mvebu_setup_boot_addr_wa) from (mvebu_v7_cpu_pm_init+0x154/0x204)
(mvebu_v7_cpu_pm_init) from (do_one_initcall+0x7c/0x1a8)
(do_one_initcall) from (kernel_init_freeable+0x1bc/0x254)
(kernel_init_freeable) from (kernel_init+0x8/0x114)
(kernel_init) from (ret_from_fork+0x14/0x2c)
Signed-off-by: Ethan Tuttle <ethan@ethantuttle.com>
Tested-by: Ethan Tuttle <ethan@ethantuttle.com>
---
arch/arm/mach-mvebu/pmsu.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/arm/mach-mvebu/pmsu.c b/arch/arm/mach-mvebu/pmsu.c
index 27a78c80e5b1..73d5d72dfc3e 100644
--- a/arch/arm/mach-mvebu/pmsu.c
+++ b/arch/arm/mach-mvebu/pmsu.c
@@ -116,8 +116,8 @@ void mvebu_pmsu_set_cpu_boot_addr(int hw_cpu, void *boot_addr)
PMSU_BOOT_ADDR_REDIRECT_OFFSET(hw_cpu));
}
-extern unsigned char mvebu_boot_wa_start;
-extern unsigned char mvebu_boot_wa_end;
+extern unsigned char mvebu_boot_wa_start[];
+extern unsigned char mvebu_boot_wa_end[];
/*
* This function sets up the boot address workaround needed for SMP
@@ -130,7 +130,7 @@ int mvebu_setup_boot_addr_wa(unsigned int crypto_eng_target,
phys_addr_t resume_addr_reg)
{
void __iomem *sram_virt_base;
- u32 code_len = &mvebu_boot_wa_end - &mvebu_boot_wa_start;
+ u32 code_len = mvebu_boot_wa_end - mvebu_boot_wa_start;
mvebu_mbus_del_window(BOOTROM_BASE, BOOTROM_SIZE);
mvebu_mbus_add_window_by_id(crypto_eng_target, crypto_eng_attribute,
--
2.18.0

View file

@ -0,0 +1,44 @@
From 917f2c7ef10029386dc0a0e3046aa5087499e94a Mon Sep 17 00:00:00 2001
From: Hal Emmerich <hal@halemmerich.com>
Date: Thu, 19 Jul 2018 21:48:08 -0500
Subject: [PATCH 14/14] usb: dwc2: disable power_down on rockchip devices
The bug would let the usb controller enter partial power down,
which was formally known as hibernate, upon boot if nothing was plugged
in to the port. Partial power down couldn't be exited properly, so any
usb devices plugged in after boot would not be usable.
Before the name change, params.hibernation was false by default, so
_dwc2_hcd_suspend() would skip entering hibernation. With the
rename, _dwc2_hcd_suspend() was changed to use params.power_down
to decide whether or not to enter partial power down.
Since params.power_down is non-zero by default, it needs to be set
to 0 for rockchip devices to restore functionality.
This bug was reported in the linux-usb thread:
REGRESSION: usb: dwc2: USB device not seen after boot
The commit that caused this regression is:
6d23ee9caa6790aea047f9aca7f3c03cb8d96eb6
Signed-off-by: Hal Emmerich <hal@halemmerich.com>
---
drivers/usb/dwc2/params.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/dwc2/params.c b/drivers/usb/dwc2/params.c
index af075d4da895..f621970d3979 100644
--- a/drivers/usb/dwc2/params.c
+++ b/drivers/usb/dwc2/params.c
@@ -83,6 +83,7 @@ static void dwc2_set_rk_params(struct dwc2_hsotg *hsotg)
p->host_perio_tx_fifo_size = 256;
p->ahbcfg = GAHBCFG_HBSTLEN_INCR16 <<
GAHBCFG_HBSTLEN_SHIFT;
+ p->power_down = 0;
}
static void dwc2_set_ltq_params(struct dwc2_hsotg *hsotg)
--
2.19.0

View file

@ -7,9 +7,9 @@ pkgbase=linux-armv7
_srcname=linux-4.18
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=4.18.11
pkgver=4.18.12
pkgrel=1
rcnrel=armv7-x11
rcnrel=armv7-x12
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -31,7 +31,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch'
'0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch'
'0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch'
'0014-ARM-mvebu-declare-asm-symbols-as-character-arrays-in.patch'
'0014-usb-dwc2-disable-power_down-on-rockchip-devices.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -39,22 +39,22 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset'
'99-linux.hook')
md5sums=('bee5fe53ee1c3142b8f0c12c0d3348f9'
'35f0d753cd3e1fb905299d8b4af5e7d7'
'70d3a9e663ac840f40ebcc6d93bf3bc2'
'fb218c1825366e722be83dd705d02822'
'bfeb8670a65fc8c14a7076ec623e9898'
'1651316b545214bb346af28f3925ccd0'
'625bc1c129c076f85a0794277438fbf3'
'95ffcc1c52475c1de2e5478c4896f0ca'
'5d8b1483f219edd892536e26663d16c7'
'8be87b6399b1cabbca28ee3592d5a9c9'
'0fcaafdce5964746e7de8c2bfd8a3421'
'd1f48c3560244b8d37084ec316b412d1'
'ec013d7dcb738d91ebe668addc96af8f'
'2d2e38af1b7db6d27babb8e072c144fc'
'eb51f5bbcf5b38956a0ba931d7898f07'
'cd9f373ec6e45e99610c9892a8e38100'
'8b896e19eac2b3bff797c48e737a166b'
'8186fbd0e436c775e2dc70148ff2f446'
'8f8c5a8b5f14131e267b6f92c34699f0'
'82059089d9ad1ef5dbb838eda091fcfa'
'febcfc46f7911d2523f0aa2aaaa9ca47'
'3fe6b37f56aa09c25b1d2401a266b7ca'
'03f34822382a4feec407bd7de1ae2ebb'
'1a77b60d684676df8b4edd8ad9e25ffa'
'b8b4e4e349626a6d2d83c2d44f7099e2'
'ddfe27165ecf85ce754514d5bcc12d90'
'75f192717be2324c6221d4b378acce7a'
'ec405026e7ce1082cb28910e98eb2ff6'
'6ea14429f233f7b7dd96a9de95ac33dc'
'a10cd1de65af2bb6fadd12e660486143'
'6fb53a35c5d36ea06cedae765e59273f'
'29f60bdb8f2a7264286a30838a4a07fe'
'7c9cd099eadd715c616628c506972c28'
'3ccf2beb2c2dbc7e428a5f0f3d192c9a'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -85,7 +85,7 @@ prepare() {
git apply ../0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch
git apply ../0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch
git apply ../0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch
git apply ../0014-ARM-mvebu-declare-asm-symbols-as-character-arrays-in.patch
git apply ../0014-usb-dwc2-disable-power_down-on-rockchip-devices.patch
cat "${srcdir}/config" > ./.config