extra/chromium to 71.0.3578.98-3

This commit is contained in:
Kevin Mihelich 2019-01-05 06:33:16 +00:00
parent 63353a3a35
commit 169f5a64b7
3 changed files with 44 additions and 32 deletions

View file

@ -16,7 +16,7 @@ highmem=1
pkgname=chromium
pkgver=71.0.3578.98
pkgrel=2
pkgrel=3
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
@ -33,14 +33,14 @@ optdepends=('kdialog: needed for file dialogs in KDE'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
enable-ServiceWorkerServicification-by-default.patch
fix-nav-preload-with-third-party-cookie-blocking.patch
chromium-harfbuzz-r0.patch
chromium-system-icu.patch
chromium-widevine.patch
chromium-skia-harmony.patch)
sha256sums=('1c56a9e30825774c83d568d194e9585625c6e90f81ee0ef09760fcedc86b9d45'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'd8736348aef47c92f417f38cb4eaab45e75c48b16e3dd3bbe2e4ef64d858b97a'
'd2c497f3400baad7d380305f4705fd1e5b9f70a8460384490a1bb78e1c2b0f23'
'1b370d49c43e88acfe7c0b1f9517047e927f3407bd80b4a48bba32c001f80136'
'c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5'
'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
@ -104,7 +104,7 @@ prepare() {
third_party/libxml/chromium/libxml_utils.cc
# https://crbug.com/913220
patch -Np1 -i ../enable-ServiceWorkerServicification-by-default.patch
patch -Np1 -i ../fix-nav-preload-with-third-party-cookie-blocking.patch
# Load Widevine CDM if available
patch -Np1 -i ../chromium-widevine.patch

View file

@ -1,28 +0,0 @@
From 5d2271ca9f5f569bbec950f9f0cc98af070ea52f Mon Sep 17 00:00:00 2001
From: Matt Falkenhagen <falken@chromium.org>
Date: Wed, 17 Oct 2018 10:12:44 +0000
Subject: [PATCH] Enable ServiceWorkerServicification by default.
Bug: 715640, 846235
Change-Id: I49ed8a5a3bc5962cd52e24ab734b00fdfdd7b32d
Reviewed-on: https://chromium-review.googlesource.com/c/1286238
Commit-Queue: Matt Falkenhagen <falken@chromium.org>
Reviewed-by: Kinuko Yasuda <kinuko@chromium.org>
Cr-Commit-Position: refs/heads/master@{#600337}
---
third_party/blink/common/features.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/third_party/blink/common/features.cc b/third_party/blink/common/features.cc
index a5cf355e1b..b58abdb515 100644
--- a/third_party/blink/common/features.cc
+++ b/third_party/blink/common/features.cc
@@ -59,7 +59,7 @@ const base::Feature kServiceWorkerParallelSideDataReading{
// Enable new service worker glue for NetworkService. Can be
// enabled independently of NetworkService.
const base::Feature kServiceWorkerServicification{
- "ServiceWorkerServicification", base::FEATURE_DISABLED_BY_DEFAULT};
+ "ServiceWorkerServicification", base::FEATURE_ENABLED_BY_DEFAULT};
// Freeze scheduler task queues in background after allowed grace time.
// "stop" is a legacy name.

View file

@ -0,0 +1,40 @@
From c0d0bacc0ae01f15c4d06405057fd35f371bcaf3 Mon Sep 17 00:00:00 2001
From: Matt Falkenhagen <falken@chromium.org>
Date: Tue, 18 Dec 2018 08:31:08 +0000
Subject: [PATCH] service worker: Fix nav preload with third-party cookie
blocking.
In non-ServiceWorkerServicification, the navigation preload request
wasn't setting site_for_cookies field when converting from a URLRequest
to ResourceRequest, so StaticCookiePolicy was blocking cookie access
when third-party cookie blocking was enabled. This meant that cookies
weren't sent in the navigation preload request.
ServiceWorkerServicification already set set_for_cookies since it just
passed the ResourceRequest on to the URLLoader for navigation preload.
Test coverage is added as a //chrome browser test.
Bug: 913220
Change-Id: I03acb2c0b67d4645d3f6147b2ac9426a68935dee
Reviewed-on: https://chromium-review.googlesource.com/c/1379792
Commit-Queue: Matt Falkenhagen <falken@chromium.org>
Reviewed-by: Tsuyoshi Horo <horo@chromium.org>
Cr-Commit-Position: refs/heads/master@{#617414}
---
.../browser/service_worker/service_worker_fetch_dispatcher.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/content/browser/service_worker/service_worker_fetch_dispatcher.cc b/content/browser/service_worker/service_worker_fetch_dispatcher.cc
index 413842dd85..049da64651 100644
--- a/content/browser/service_worker/service_worker_fetch_dispatcher.cc
+++ b/content/browser/service_worker/service_worker_fetch_dispatcher.cc
@@ -616,7 +616,7 @@ bool ServiceWorkerFetchDispatcher::MaybeStartNavigationPreload(
network::ResourceRequest request;
request.method = original_request->method();
request.url = original_request->url();
- // TODO(horo): Set site_for_cookies to support Same-site Cookies.
+ request.site_for_cookies = original_request->site_for_cookies();
request.request_initiator =
original_request->initiator().has_value()
? original_request->initiator()