mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-imx6-wandboard-dt remove static noise fix
alarm/xbmc-imx bump version
This commit is contained in:
parent
b0e45392ba
commit
16b3d199eb
3 changed files with 2 additions and 38 deletions
|
@ -6,7 +6,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=xbmc-imx-git
|
||||
pkgver=13.20140411
|
||||
pkgver=13.20140421
|
||||
pkgrel=1
|
||||
pkgdesc="A software media player and entertainment hub for digital media for select imx6 systems"
|
||||
arch=('armv7h')
|
||||
|
|
|
@ -9,17 +9,15 @@ _srcname=linux-${_commit}
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="i.MX6 Wandboard"
|
||||
pkgver=3.10.17
|
||||
pkgrel=6
|
||||
pkgrel=7
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||
options=('!strip')
|
||||
source=("https://github.com/wandboard-org/linux/archive/${_commit}.tar.gz"
|
||||
'fix-static-noise.patch'
|
||||
'config')
|
||||
md5sums=('0c16c05ca4a44396b581079aa267c66e'
|
||||
'8fd33b21538f41c605da7e990fc99ce2'
|
||||
'fb1e187c803f0d38439c91c4e8b7578a')
|
||||
|
||||
prepare() {
|
||||
|
@ -27,9 +25,6 @@ prepare() {
|
|||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# fix static noise on hdmi and spdif
|
||||
patch -l -p0 <../fix-static-noise.patch
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
--- sound/soc/mxs/mxs-pcm.c.orig 2014-03-31 22:18:46.554699921 +0200
|
||||
+++ sound/soc/mxs/mxs-pcm.c 2014-03-31 22:19:53.964699929 +0200
|
||||
@@ -36,9 +36,7 @@
|
||||
SNDRV_PCM_INFO_RESUME |
|
||||
SNDRV_PCM_INFO_INTERLEAVED |
|
||||
SNDRV_PCM_INFO_HALF_DUPLEX,
|
||||
- .formats = SNDRV_PCM_FMTBIT_S16_LE |
|
||||
- SNDRV_PCM_FMTBIT_S20_3LE |
|
||||
- SNDRV_PCM_FMTBIT_S24_LE,
|
||||
+ .formats = SNDRV_PCM_FMTBIT_S16_LE,
|
||||
.channels_min = 2,
|
||||
.channels_max = 2,
|
||||
.period_bytes_min = 32,
|
||||
diff --git sound/soc/fsl/fsl_spdif.h sound/soc/fsl/fsl_spdif.h
|
||||
index dbbbb1e..5a46dcb 100644
|
||||
--- sound/soc/fsl/fsl_spdif.h
|
||||
+++ sound/soc/fsl/fsl_spdif.h
|
||||
@@ -184,9 +184,13 @@ enum spdif_txrate {
|
||||
SNDRV_PCM_RATE_64000 | \
|
||||
SNDRV_PCM_RATE_96000)
|
||||
|
||||
+// !!! temporary workaround for broken 24bit mode !!!
|
||||
+#define FSL_SPDIF_FORMATS_PLAYBACK (SNDRV_PCM_FMTBIT_S16_LE)
|
||||
+/*
|
||||
#define FSL_SPDIF_FORMATS_PLAYBACK (SNDRV_PCM_FMTBIT_S16_LE | \
|
||||
SNDRV_PCM_FMTBIT_S20_3LE | \
|
||||
SNDRV_PCM_FMTBIT_S24_LE)
|
||||
+*/
|
||||
|
||||
#define FSL_SPDIF_FORMATS_CAPTURE (SNDRV_PCM_FMTBIT_S24_LE)
|
||||
|
Loading…
Reference in a new issue