extra/chromium to 69.0.3497.81-1

This commit is contained in:
Kevin Mihelich 2018-09-05 03:10:30 +00:00
parent b16222e611
commit 16b9f26f57
8 changed files with 28 additions and 294 deletions

View file

@ -17,7 +17,7 @@ highmem=1
noautobuild=1
pkgname=chromium
pkgver=68.0.3440.106
pkgver=69.0.3497.81
pkgrel=1
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security"
@ -28,34 +28,24 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-font' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
'clang' 'lld' 'distcc-clang')
'clang' 'lld' 'gn' 'distcc-clang')
optdepends=('kdialog: needed for file dialogs in KDE'
'gnome-keyring: for storing passwords in GNOME keyring'
'kwallet: for storing passwords in KWallet')
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
x11-fix-mixup-between-DIP-pixel-coordinates.patch
blink-disable-XML-catalogs-at-runtime.patch
fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
only-disable-cfi-icall-when-use_system_libjpeg-true.patch
chromium-cors-string-r0.patch
chromium-ffmpeg-r1.patch
chromium-libjpeg-r0.patch
chromium-libwebp-shim-r0.patch
chromium-widevine-r2.patch
chromium-system-icu.patch
chromium-skia-harmony.patch)
sha256sums=('7021040635a0a0d47f699bdb22e3ef5c91482e4f51b428d1de3016da95f0e698'
sha256sums=('165ac7d0d4588e6b4a16331e0a9906ed013f2d29a96b54f0ea78fa0298f97144'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'e2c2754536243a60fa70541bbd4121715eccd83caa8f1fb1873bd994cd81f871'
'98a5c41cf9687c52ee380d2b683c95387334c76254479c347bdb733646dab815'
'97b421bc60a4abdf37de2d88a51b973e9f68fb44d1eccd464adfb3d9f5d71478'
'9cae9ded6497afd15ad72d963897425ab6c7f28941bb3c3948e7996610a0d180'
'f4141e48a25a1403250e9040c18936a16250ab707064dd54103066f40c7db41c'
'aa885330bc4180b78d915f9dfdfc3210038a0acab7b16735ea9828ab6a633bde'
'6b8fc570607631d3558e99a82e92c11eeae9c960ebb0a83c13d46344d4b6adca'
'b368f3827ee4c47c942085e3d2cfbea43f8899b101e01500dbf6a7b01b2b29e0'
'02c69bb3954087db599def7f5b6d65cf8f7cf2ed81dfbdaa4bb7b51863b4df15'
'c4f2d1bed9034c02b8806f00c2e8165df24de467803855904bff709ceaf11af5'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@ -109,12 +99,6 @@ prepare() {
# Allow build to set march and options on AArch64 (crc, crypto)
[[ $CARCH == "aarch64" ]] && CFLAGS=`echo $CFLAGS | sed -e 's/-march=armv8-a//'` && CXXFLAGS="$CFLAGS"
# https://crbug.com/707721
patch -Np1 -i ../x11-fix-mixup-between-DIP-pixel-coordinates.patch
# https://crbug.com/736026
patch -Np1 -i ../blink-disable-XML-catalogs-at-runtime.patch
# https://crbug.com/866290
patch -Np1 -i ../fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
patch -Np1 -i ../only-disable-cfi-icall-when-use_system_libjpeg-true.patch
@ -123,12 +107,11 @@ prepare() {
patch -Np4 -i ../chromium-skia-harmony.patch
# Fixes from Gentoo
patch -Np1 -i ../chromium-cors-string-r0.patch
patch -Np1 -i ../chromium-ffmpeg-r1.patch
patch -Np1 -i ../chromium-libjpeg-r0.patch
patch -Np1 -i ../chromium-libwebp-shim-r0.patch
patch -Np1 -i ../chromium-widevine-r2.patch
# https://bugs.gentoo.org/661880#c21
patch -Np1 -i ../chromium-system-icu.patch
# Remove compiler flags not supported by our system clang
sed -i \
-e '/"-Wno-ignored-pragma-optimize"/d' \
@ -215,10 +198,7 @@ build() {
CPPFLAGS+=' -DNO_UNWIND_TABLES'
fi
python2 tools/gn/bootstrap/bootstrap.py -s --no-clean
out/Release/gn gen out/Release --args="${_flags[*]}" \
--script-executable=/usr/bin/python2
gn gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
ninja -C out/Release chrome chrome_sandbox chromedriver
}

View file

@ -1,47 +0,0 @@
From 8f0c8c8d9bce12c70ce9acb4a7474cd15c9be65b Mon Sep 17 00:00:00 2001
From: Mike Gilbert <floppymaster@gmail.com>
Date: Wed, 20 Jun 2018 20:37:46 +0000
Subject: [PATCH] blink: disable XML catalogs at runtime
Chromium may optionally be built against libxml installed on the system.
The system libxml commonly has XML catalog support enabled. Disable it
by calling xmlCatalogSetDefaults(XML_CATA_ALLOW_NONE).
Bug: https://bugs.gentoo.org/653078
Change-Id: I069f6dcecf81168f9d31eb0efe2519197ec8e779
Reviewed-on: https://chromium-review.googlesource.com/1103710
Reviewed-by: Daniel Cheng <dcheng@chromium.org>
Commit-Queue: Scott Graham <scottmg@chromium.org>
Cr-Commit-Position: refs/heads/master@{#568998}
---
.../blink/renderer/core/xml/parser/xml_document_parser.cc | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc b/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
index 9744de383d9a..d0539f61e4b5 100644
--- a/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
+++ b/third_party/blink/renderer/core/xml/parser/xml_document_parser.cc
@@ -28,6 +28,10 @@
#include <libxml/parser.h>
#include <libxml/parserInternals.h>
+#include <libxml/xmlversion.h>
+#if defined(LIBXML_CATALOG_ENABLED)
+#include <libxml/catalog.h>
+#endif
#include <libxslt/xslt.h>
#include <memory>
@@ -648,6 +652,9 @@ static void InitializeLibXMLIfNecessary() {
if (did_init)
return;
+#if defined(LIBXML_CATALOG_ENABLED)
+ xmlCatalogSetDefaults(XML_CATA_ALLOW_NONE);
+#endif
xmlInitParser();
xmlRegisterInputCallbacks(MatchFunc, OpenFunc, ReadFunc, CloseFunc);
xmlRegisterOutputCallbacks(MatchFunc, OpenFunc, WriteFunc, CloseFunc);
--
2.17.1

View file

@ -1,51 +0,0 @@
From 01d891fa0790950549c7bedb34edf869827a372e Mon Sep 17 00:00:00 2001
From: Jose Dapena Paz <jose.dapena@lge.com>
Date: Thu, 31 May 2018 17:03:37 +0000
Subject: [PATCH] CORS legacy: add missing string include
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The cors_legacy.h file includes declarations using std::string, but
it is not declared due to missing #include <string>.
Also drop unneeded declarations in .cpp file.
Change-Id: I00df799f84a6c3530c2f12f1e52d24c7d9bd6bfd
Reviewed-on: https://chromium-review.googlesource.com/1080707
Reviewed-by: Tom Sepez <tsepez@chromium.org>
Commit-Queue: José Dapena Paz <jose.dapena@lge.com>
Cr-Commit-Position: refs/heads/master@{#563282}
---
services/network/public/cpp/cors/cors_legacy.cc | 2 --
services/network/public/cpp/cors/cors_legacy.h | 1 +
2 files changed, 1 insertion(+), 2 deletions(-)
diff --git a/services/network/public/cpp/cors/cors_legacy.cc b/services/network/public/cpp/cors/cors_legacy.cc
index 8f32ac3be64e..f01af63619b5 100644
--- a/services/network/public/cpp/cors/cors_legacy.cc
+++ b/services/network/public/cpp/cors/cors_legacy.cc
@@ -5,8 +5,6 @@
#include "services/network/public/cpp/cors/cors_legacy.h"
#include <algorithm>
-#include <string>
-#include <vector>
#include "url/gurl.h"
#include "url/url_util.h"
diff --git a/services/network/public/cpp/cors/cors_legacy.h b/services/network/public/cpp/cors/cors_legacy.h
index d2cdf026ca3a..dc9295a92c47 100644
--- a/services/network/public/cpp/cors/cors_legacy.h
+++ b/services/network/public/cpp/cors/cors_legacy.h
@@ -5,6 +5,7 @@
#ifndef SERVICES_NETWORK_PUBLIC_CPP_CORS_CORS_LEGACY_H_
#define SERVICES_NETWORK_PUBLIC_CPP_CORS_CORS_LEGACY_H_
+#include <string>
#include <vector>
#include "base/component_export.h"
--
2.17.1

View file

@ -1,22 +0,0 @@
--- a/build/linux/unbundle/ffmpeg.gn
+++ b/build/linux/unbundle/ffmpeg.gn
@@ -14,8 +14,8 @@ pkg_config("system_ffmpeg") {
]
}
-buildflag_header("ffmpeg_buildflags") {
- header = "ffmpeg_buildflags.h"
+buildflag_header("ffmpeg_features") {
+ header = "ffmpeg_features.h"
flags = [ "USE_SYSTEM_FFMPEG=true" ]
}
@@ -30,7 +30,7 @@ shim_headers("ffmpeg_shim") {
source_set("ffmpeg") {
deps = [
- ":ffmpeg_buildflags",
+ ":ffmpeg_features",
":ffmpeg_shim",
]
public_configs = [ ":system_ffmpeg" ]

View file

@ -1,62 +0,0 @@
From c6b0194f7a4d9f494b2d51f46d2c332e2e5f4050 Mon Sep 17 00:00:00 2001
From: Daniel Bratell <bratell@opera.com>
Date: Mon, 28 May 2018 13:13:01 +0000
Subject: [PATCH] Use the same libjpeg in all of blink/platform
The normal libjpeg renames some symbols with macros so if its
headers are included together with libjpeg-turbo's headers
in the same translation unit, there will be an inconsistent
renaming of libjpeg symbols. This happened in some extreme
jumbo configuration and resulted in confising linker errors.
This patch changes an include so that jpeglib.h becomes included
the same way everywhere.
Change-Id: I7f122d0919d58371bb40dc0097a766b857b9815e
Reviewed-on: https://chromium-review.googlesource.com/1073423
Reviewed-by: Kentaro Hara <haraken@chromium.org>
Commit-Queue: Daniel Bratell <bratell@opera.com>
Cr-Commit-Position: refs/heads/master@{#562243}
---
.../renderer/platform/image-encoders/image_encoder.cc | 11 +++++++++++
.../renderer/platform/image-encoders/image_encoder.h | 2 --
2 files changed, 11 insertions(+), 2 deletions(-)
diff --git a/third_party/blink/renderer/platform/image-encoders/image_encoder.cc b/third_party/blink/renderer/platform/image-encoders/image_encoder.cc
index 0c7f14c7c0e4..4c450f5d6783 100644
--- a/third_party/blink/renderer/platform/image-encoders/image_encoder.cc
+++ b/third_party/blink/renderer/platform/image-encoders/image_encoder.cc
@@ -4,6 +4,17 @@
#include "third_party/blink/renderer/platform/image-encoders/image_encoder.h"
+#include "build/build_config.h"
+
+#if defined(OS_WIN)
+#include <basetsd.h> // Included before jpeglib.h because of INT32 clash
+#endif // OS_WIN
+#include <stdio.h> // Needed by jpeglib.h
+
+#include "jpeglib.h" // for JPEG_MAX_DIMENSION
+
+#include "third_party/libwebp/src/webp/encode.h" // for WEBP_MAX_DIMENSION
+
namespace blink {
bool ImageEncoder::Encode(Vector<unsigned char>* dst,
diff --git a/third_party/blink/renderer/platform/image-encoders/image_encoder.h b/third_party/blink/renderer/platform/image-encoders/image_encoder.h
index 0d1460f34827..40306097d507 100644
--- a/third_party/blink/renderer/platform/image-encoders/image_encoder.h
+++ b/third_party/blink/renderer/platform/image-encoders/image_encoder.h
@@ -7,8 +7,6 @@
#include "third_party/blink/renderer/platform/platform_export.h"
#include "third_party/blink/renderer/platform/wtf/vector.h"
-#include "third_party/libjpeg/jpeglib.h" // for JPEG_MAX_DIMENSION
-#include "third_party/libwebp/src/webp/encode.h" // for WEBP_MAX_DIMENSION
#include "third_party/skia/include/core/SkStream.h"
#include "third_party/skia/include/encode/SkJpegEncoder.h"
#include "third_party/skia/include/encode/SkPngEncoder.h"
--
2.17.1

View file

@ -1,43 +0,0 @@
diff --git a/build/linux/unbundle/libwebp.gn b/build/linux/unbundle/libwebp.gn
index ab92adecf400..12574d87be58 100644
--- a/build/linux/unbundle/libwebp.gn
+++ b/build/linux/unbundle/libwebp.gn
@@ -2,12 +2,34 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
+import("//build/config/linux/pkg_config.gni")
+import("//build/shim_headers.gni")
+
+pkg_config("system_libwebp") {
+ packages = [
+ "libwebp",
+ "libwebpdemux",
+ "libwebpmux",
+ ]
+}
+
+shim_headers("libwebp_shim") {
+ root_path = "src"
+ headers = [
+ "webp/decode.h",
+ "webp/demux.h",
+ "webp/encode.h",
+ "webp/mux.h",
+ "webp/mux_types.h",
+ "webp/types.h",
+ ]
+}
+
source_set("libwebp_webp") {
- libs = [
- "webp",
- "webpdemux",
- "webpmux",
+ deps = [
+ ":libwebp_shim",
]
+ public_configs = [ ":system_libwebp" ]
}
group("libwebp") {

View file

@ -0,0 +1,19 @@
diff --git a/third_party/blink/renderer/platform/text/character_property_data_generator.h b/third_party/blink/renderer/platform/text/character_property_data_generator.h
index 28fb6a9..bb4dbd7 100644
--- a/third_party/blink/renderer/platform/text/character_property_data_generator.h
+++ b/third_party/blink/renderer/platform/text/character_property_data_generator.h
@@ -244,10 +244,12 @@ static const UChar32 kIsHangulRanges[] = {
0xD7B0, 0xD7FF,
// Halfwidth Hangul Jamo
// https://www.unicode.org/charts/nameslist/c_FF00.html
- 0xFFA0, 0xFFDC,
+ 0xFFA0, 0xFFDB,
};
-static const UChar32 kIsHangulArray[] = {};
+static const UChar32 kIsHangulArray[] = {
+ 0xFFDC,
+};
} // namespace blink

View file

@ -1,40 +0,0 @@
From 2752a03ba6435130848aa620b7ab4246eec2f77a Mon Sep 17 00:00:00 2001
From: Tom Anderson <thomasanderson@chromium.org>
Date: Mon, 4 Jun 2018 22:09:08 +0000
Subject: [PATCH] X11: Fix mixup between DIP/pixel coordinates
BUG=707721
R=sky
Change-Id: Ibbbff9c2c815700324f553a3b66e878f76938534
Reviewed-on: https://chromium-review.googlesource.com/1083692
Reviewed-by: Scott Violet <sky@chromium.org>
Commit-Queue: Thomas Anderson <thomasanderson@chromium.org>
Cr-Commit-Position: refs/heads/master@{#564261}
---
ui/views/widget/desktop_aura/desktop_screen_x11.cc | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/ui/views/widget/desktop_aura/desktop_screen_x11.cc b/ui/views/widget/desktop_aura/desktop_screen_x11.cc
index 8fd5d379d344..e90710c2c39c 100644
--- a/ui/views/widget/desktop_aura/desktop_screen_x11.cc
+++ b/ui/views/widget/desktop_aura/desktop_screen_x11.cc
@@ -216,8 +216,13 @@ display::Display DesktopScreenX11::GetDisplayNearestWindow(
if (host) {
DesktopWindowTreeHostX11* rwh = DesktopWindowTreeHostX11::GetHostForXID(
host->GetAcceleratedWidget());
- if (rwh)
- return GetDisplayMatching(rwh->GetX11RootWindowBounds());
+ if (rwh) {
+ const float scale = 1.0f / GetDeviceScaleFactor();
+ const gfx::Rect pixel_rect = rwh->GetX11RootWindowBounds();
+ return GetDisplayMatching(
+ gfx::Rect(gfx::ScaleToFlooredPoint(pixel_rect.origin(), scale),
+ gfx::ScaleToCeiledSize(pixel_rect.size(), scale)));
+ }
}
return GetPrimaryDisplay();
--
2.17.1