From 17365566d08f934a8a719706547f720845161648 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 4 Jun 2018 23:43:34 +0000
Subject: [PATCH] added community/shhmsg

---
 community/shhmsg/PKGBUILD | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
 create mode 100644 community/shhmsg/PKGBUILD

diff --git a/community/shhmsg/PKGBUILD b/community/shhmsg/PKGBUILD
new file mode 100644
index 000000000..b6a622a77
--- /dev/null
+++ b/community/shhmsg/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+# Contributor: Peter Simons <simons@cryp.to>
+
+# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
+#  - build v7/v8 with -fPIC
+
+pkgname=shhmsg
+pkgver=1.4.2
+pkgrel=2.1
+pkgdesc="Library for displaying messages"
+arch=('i686' 'x86_64')
+url="http://shh.thathost.com/pub-unix"
+license=('PerlArtistic')
+options=('staticlibs')
+source=($url/files/$pkgname-$pkgver.tar.gz)
+md5sums=('30cab93040d2892539847437b7246b8b')
+
+build() {
+  cd $pkgname-$pkgver
+
+  [[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CFLAGS+=" -fPIC"
+  make OPTIM="$CFLAGS" dep
+  make OPTIM="$CFLAGS"
+}
+
+package() {
+  cd $pkgname-$pkgver
+
+  make OPTIM="$CFLAGS" INSTBASEDIR="$pkgdir"/usr/ install
+
+  for i in ChangeLog CREDITS INSTALL README; do
+    install -Dm644 $i "$pkgdir"/usr/share/doc/$pkgname/$i
+  done
+}