core/linux-kirkwood-dt to 5.10.12-2

This commit is contained in:
Kevin Mihelich 2021-02-02 00:23:02 +00:00
parent 7e808925e8
commit 173f25f6c0
8 changed files with 156 additions and 35 deletions

View file

@ -1,7 +1,7 @@
From 365ae852397f382bd5833092be57208610ae84b8 Mon Sep 17 00:00:00 2001
From 2c85df8a81c1b8a9ff7170f195e569718bb80e10 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:32:06 -0700
Subject: [PATCH 1/6] leds: trigger: Introduce a SATA trigger
Subject: [PATCH 1/7] leds: trigger: Introduce a SATA trigger
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -91,10 +91,10 @@ index 000000000000..f1798f43666f
+}
+device_initcall(ledtrig_sata_init);
diff --git a/include/linux/leds.h b/include/linux/leds.h
index 2451962d1ec5..225b2a3aa797 100644
index 6a8d6409c993..c6d8a49dc52c 100644
--- a/include/linux/leds.h
+++ b/include/linux/leds.h
@@ -457,6 +457,12 @@ void ledtrig_disk_activity(bool write);
@@ -467,6 +467,12 @@ void ledtrig_disk_activity(bool write);
static inline void ledtrig_disk_activity(bool write) {}
#endif
@ -108,5 +108,5 @@ index 2451962d1ec5..225b2a3aa797 100644
void ledtrig_mtd_activity(void);
#else
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 6110f21c0e4419692a30085ac18edbaa27443f76 Mon Sep 17 00:00:00 2001
From 46cabc7ba646ec301e238f7fb8ccd7ed9d9dd88b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:34:33 -0700
Subject: [PATCH 2/6] ata: sata_mv: Add SATA activity LED trigger support
Subject: [PATCH 2/7] ata: sata_mv: Add SATA activity LED trigger support
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+)
diff --git a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
index d7228f8e9297..f69ebc263e77 100644
index 664ef658a955..ca920c7ce0e5 100644
--- a/drivers/ata/sata_mv.c
+++ b/drivers/ata/sata_mv.c
@@ -59,6 +59,7 @@
@ -30,5 +30,5 @@ index d7228f8e9297..f69ebc263e77 100644
int using_ncq = ((pp->pp_flags & MV_PP_FLAG_NCQ_EN) != 0);
if (want_ncq != using_ncq)
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 257ffa3800348e711e9a7449d4390604ce275dee Mon Sep 17 00:00:00 2001
From 8f43348b6b0e28bca91c8913a5623b1bee4ffbbc Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:37:08 -0700
Subject: [PATCH 3/6] ARM: dts: kirkwood-pogo_e02: Set health LED to default-on
Subject: [PATCH 3/7] ARM: dts: kirkwood-pogo_e02: Set health LED to default-on
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -22,5 +22,5 @@ index f9e95e55f36d..a3ee0ad3c1b4 100644
fault {
label = "pogo_e02:orange:fault";
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From f6e8aa92ce31fe2655016ed6c663e57598c5508a Mon Sep 17 00:00:00 2001
From c8d7638cbef83d8a38957b7663412546d71b8608 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:38:04 -0700
Subject: [PATCH 4/6] Fix mvsdio SD card detection
Subject: [PATCH 4/7] Fix mvsdio SD card detection
Helps SD card detection on PPv4.
@ -13,7 +13,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
3 files changed, 12 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
index 8d2b808e9b58..1afe0301bf4c 100644
index d42037f0f10d..fa9e472061f8 100644
--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
@@ -695,7 +695,7 @@ void mmc_set_data_timeout(struct mmc_data *data, const struct mmc_card *card)
@ -26,7 +26,7 @@ index 8d2b808e9b58..1afe0301bf4c 100644
/*
* SDHC cards always use these fixed values.
diff --git a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
index 5a2210c25aa7..50ef9a2c6ee5 100644
index 6f054c449d46..1ca7d8593e5c 100644
--- a/drivers/mmc/core/sd.c
+++ b/drivers/mmc/core/sd.c
@@ -376,6 +376,15 @@ int mmc_sd_switch_hs(struct mmc_card *card)
@ -46,7 +46,7 @@ index 5a2210c25aa7..50ef9a2c6ee5 100644
if (err)
goto out;
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index cc0752a9df6d..9f64b11292f7 100644
index 629efbe639c4..bc342d88d2d1 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -20,6 +20,7 @@
@ -66,5 +66,5 @@ index cc0752a9df6d..9f64b11292f7 100644
cmdreg = MVSD_CMD_INDEX(cmd->opcode);
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 875bd6bf076500b59ce40474644008b032da73df Mon Sep 17 00:00:00 2001
From ed7ec1236840b4c8f5cc61535e2c3b91b1f70718 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:42:40 -0700
Subject: [PATCH 5/6] ARM: dts: kirkwood: Initial support for GoFlex Home
Subject: [PATCH 5/7] ARM: dts: kirkwood: Initial support for GoFlex Home
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -11,10 +11,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/kirkwood-goflexhome.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index e6a1cac0bfc7..4095ff2cfe77 100644
index ce66ffd5a1bb..e15a0547a4c8 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -275,6 +275,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
@@ -277,6 +277,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
kirkwood-ds411.dtb \
kirkwood-ds411j.dtb \
kirkwood-ds411slim.dtb \
@ -156,5 +156,5 @@ index 000000000000..554716fbf367
+ };
+};
--
2.27.0
2.30.0

View file

@ -1,7 +1,7 @@
From 4d7dda773f2683cd358a940ff693dc5118bac837 Mon Sep 17 00:00:00 2001
From a2545842afc893d09e4fa125b93329bc8636d5c1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 25 Feb 2018 16:45:51 -0700
Subject: [PATCH 6/6] Revert "vfs,mm: fix a dead loop in
Subject: [PATCH 6/7] Revert "vfs,mm: fix a dead loop in
truncate_inode_pages_range()"
This reverts commit c2a9737f45e27d8263ff9643f994bda9bac0b944.
@ -13,10 +13,10 @@ device.
1 file changed, 4 deletions(-)
diff --git a/mm/filemap.c b/mm/filemap.c
index 385759c4ce4b..5dc2a56796b1 100644
index 0b2067b3c328..f5be2ee65e90 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2003,10 +2003,6 @@ ssize_t generic_file_buffered_read(struct kiocb *iocb,
@@ -2197,10 +2197,6 @@ ssize_t generic_file_buffered_read(struct kiocb *iocb,
unsigned int prev_offset;
int error = 0;
@ -28,5 +28,5 @@ index 385759c4ce4b..5dc2a56796b1 100644
prev_index = ra->prev_pos >> PAGE_SHIFT;
prev_offset = ra->prev_pos & (PAGE_SIZE-1);
--
2.27.0
2.30.0

View file

@ -0,0 +1,118 @@
From 46e3b871f8aaca8be4dfd17fe942b1d40ba5ccfc Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 1 Feb 2021 17:19:21 -0700
Subject: [PATCH 7/7] Revert "SUNRPC: Handle TCP socket sends with
kernel_sendpage() again"
This reverts commit 00ee972739fb2526d3936f1e7ccfc8c91d250c60.
---
net/sunrpc/svcsock.c | 86 +-------------------------------------------
1 file changed, 1 insertion(+), 85 deletions(-)
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
index 4404c491eb38..c2752e2b9ce3 100644
--- a/net/sunrpc/svcsock.c
+++ b/net/sunrpc/svcsock.c
@@ -1062,90 +1062,6 @@ static int svc_tcp_recvfrom(struct svc_rqst *rqstp)
return 0; /* record not complete */
}
-static int svc_tcp_send_kvec(struct socket *sock, const struct kvec *vec,
- int flags)
-{
- return kernel_sendpage(sock, virt_to_page(vec->iov_base),
- offset_in_page(vec->iov_base),
- vec->iov_len, flags);
-}
-
-/*
- * kernel_sendpage() is used exclusively to reduce the number of
- * copy operations in this path. Therefore the caller must ensure
- * that the pages backing @xdr are unchanging.
- *
- * In addition, the logic assumes that * .bv_len is never larger
- * than PAGE_SIZE.
- */
-static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
- struct xdr_buf *xdr, rpc_fraghdr marker,
- unsigned int *sentp)
-{
- const struct kvec *head = xdr->head;
- const struct kvec *tail = xdr->tail;
- struct kvec rm = {
- .iov_base = &marker,
- .iov_len = sizeof(marker),
- };
- int flags, ret;
-
- *sentp = 0;
- xdr_alloc_bvec(xdr, GFP_KERNEL);
-
- msg->msg_flags = MSG_MORE;
- ret = kernel_sendmsg(sock, msg, &rm, 1, rm.iov_len);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != rm.iov_len)
- return -EAGAIN;
-
- flags = head->iov_len < xdr->len ? MSG_MORE | MSG_SENDPAGE_NOTLAST : 0;
- ret = svc_tcp_send_kvec(sock, head, flags);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != head->iov_len)
- goto out;
-
- if (xdr->page_len) {
- unsigned int offset, len, remaining;
- struct bio_vec *bvec;
-
- bvec = xdr->bvec;
- offset = xdr->page_base;
- remaining = xdr->page_len;
- flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
- while (remaining > 0) {
- if (remaining <= PAGE_SIZE && tail->iov_len == 0)
- flags = 0;
- len = min(remaining, bvec->bv_len);
- ret = kernel_sendpage(sock, bvec->bv_page,
- bvec->bv_offset + offset,
- len, flags);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != len)
- goto out;
- remaining -= len;
- offset = 0;
- bvec++;
- }
- }
-
- if (tail->iov_len) {
- ret = svc_tcp_send_kvec(sock, tail, 0);
- if (ret < 0)
- return ret;
- *sentp += ret;
- }
-
-out:
- return 0;
-}
-
/**
* svc_tcp_sendto - Send out a reply on a TCP socket
* @rqstp: completed svc_rqst
@@ -1173,7 +1089,7 @@ static int svc_tcp_sendto(struct svc_rqst *rqstp)
mutex_lock(&xprt->xpt_mutex);
if (svc_xprt_is_dead(xprt))
goto out_notconn;
- err = svc_tcp_sendmsg(svsk->sk_sock, &msg, xdr, marker, &sent);
+ err = xprt_sock_sendmsg(svsk->sk_sock, &msg, xdr, 0, marker, &sent);
xdr_free_bvec(xdr);
trace_svcsock_tcp_send(xprt, err < 0 ? err : sent);
if (err < 0 || sent != (xdr->len + sizeof(marker)))
--
2.30.0

View file

@ -8,7 +8,7 @@ _srcname=linux-5.10
_kernelname=${pkgbase#linux}
_desc="Marvell Kirkwood DT"
pkgver=5.10.12
pkgrel=1
pkgrel=2
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
@ -22,18 +22,20 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'0004-Fix-mvsdio-SD-card-detection.patch'
'0005-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch'
'0006-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch'
'0007-Revert-SUNRPC-Handle-TCP-socket-sends-with-kernel_se.patch'
'config'
'linux.preset'
'99-linux.hook')
md5sums=('753adc474bf799d569dec4f165ed92c3'
'd08e416054060a5a61f75c6a711a756c'
'6d1c68eff8d3d14855934915b4db629f'
'673fa211745465f0af73bfc6d6ace606'
'a15280d3ef0605dbdb831049ec71238b'
'832e5f66f42e07f5c0014772afa789fb'
'536d5ff2e76bcfc73f86f0527ad40dba'
'6e22952ece3f53be88bc1d1a3cdeb13f'
'0c40a7e045a7538bf3c8d755e51012e5'
'2aedfdadfb808e3636289a64197ff916'
'171cb19a6ef34ba1e668d6c150276b3d'
'7dd30493a4c00a71a93f7d4f90fa2c11'
'1f1b1c2d26748d38b709bd6df6804910'
'c538017c7d0a0fd98ab269934267c195'
'a38ffa8241b0df8d05e34014b0526685'
'bcee56942897ee4f0253619843859b7f'
'959e49540dac4c5e689ad9037150a360'
'79fa396e3f9a09a85156d6d7c2d34b58')
@ -50,6 +52,7 @@ prepare() {
git apply ../0004-Fix-mvsdio-SD-card-detection.patch
git apply ../0005-ARM-dts-kirkwood-Initial-support-for-GoFlex-Home.patch
git apply ../0006-Revert-vfs-mm-fix-a-dead-loop-in-truncate_inode_page.patch
git apply ../0007-Revert-SUNRPC-Handle-TCP-socket-sends-with-kernel_se.patch
cat "${srcdir}/config" > ./.config