community/qtox to 1.17.2-1

This commit is contained in:
Kevin Mihelich 2020-04-28 18:22:02 +00:00
parent 3aab2ea4c7
commit 176ff3f376
2 changed files with 15 additions and 17 deletions

View file

@ -8,8 +8,8 @@
pkgname=qtox
_pkgname=qTox
pkgver=1.16.3
pkgrel=10
pkgver=1.17.2
pkgrel=1
_gitver='8eed684c37bd711de2ca4bd863f5f0509edcdc2d'
pkgdesc='Powerful Tox client written in C++/Qt that follows the Tox design guidelines'
arch=('x86_64')
@ -18,24 +18,24 @@ license=('GPL3')
depends=('desktop-file-utils'
'libxss'
'openal'
'gtk2'
'ffmpeg'
'qrencode'
'qt5-svg'
'sqlcipher'
'libexif'
'toxcore'
'sonnet'
'libgl')
makedepends=('qt5-tools' 'git' 'check' 'cmake' 'mesa' 'libglvnd')
source=(
"https://github.com/$_pkgname/$_pkgname/releases/download/v$pkgver/v$pkgver.tar.lz"
"https://github.com/$_pkgname/$_pkgname/releases/download/v$pkgver/v$pkgver.tar.lz.asc"
"$pkgname-$pkgver.tar.lz::https://github.com/$_pkgname/$_pkgname/releases/download/v$pkgver/v$pkgver.tar.lz"
"$pkgname-$pkgver.tar.lz.asc::https://github.com/$_pkgname/$_pkgname/releases/download/v$pkgver/v$pkgver.tar.lz.asc"
'atomic.patch'
)
sha512sums=('97c9becd6a90fc6a09a24fb52c1863dd880d19e9a6807499e875020a4012259f926014d98a4c831fd534028d9bcfcb76c5bb32001a553c22e2174a992a493a65'
sha512sums=('c8587bf33edca7b5966b9b64dae824ffd579bd1469949f1f2eca7270b31af2bb760230b83540f815816c8e20a1001f0c7952e7a0d20c99937f29629bbdc2ae51'
'SKIP'
'07c18349c92648455fc603581a594fc1cc30d706d3c136027b5b2a11218b769391a4469b6c9da8afc59d10f43ec6f5b63b7cde899e1286fc17c7d9dbcf570152')
'd2386cda78958e6a154a9612535d6f9f714aa80f07e8c33f9f8ad63b1f6f3599508ab184a67ba04254f9621b66ec6283f560722a3895ca3c2ab4ced9e3d7148d')
## GPG key fingerprints taken from https://github.com/qTox/qTox/blob/$_gitver/README.md
validpgpkeys=('DA262CC93C0E1E525AD21C8596775D454B8EBF44' # sudden6 <sudden6@gmx.at>
@ -54,7 +54,7 @@ prepare() {
# disable -Werror for release packaging
sed -e 's|-Werror||' -i CMakeLists.txt
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
patch -p1 -i atomic.patch
patch -p0 -i atomic.patch
fi
}

View file

@ -1,21 +1,19 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d51e6e3d..8bd39e95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -610,7 +610,8 @@ add_library(${PROJECT_NAME}_static
${${PROJECT_NAME}_SOURCES}
${${PROJECT_NAME}_QM_FILES})
--- CMakeLists.txt.orig 2020-04-28 12:13:40.413921675 -0600
+++ CMakeLists.txt 2020-04-28 12:15:04.340850331 -0600
@@ -671,7 +671,8 @@
${${PROJECT_NAME}_RESOURCES})
target_link_libraries(${PROJECT_NAME}_static
${CMAKE_REQUIRED_LIBRARIES}
- ${ALL_LIBRARIES})
+ ${ALL_LIBRARIES}
+ atomic)
add_executable(${PROJECT_NAME}
WIN32
@@ -619,7 +620,8 @@ add_executable(${PROJECT_NAME}
src/main.cpp)
@@ -681,7 +682,8 @@
target_link_libraries(${PROJECT_NAME}
${PROJECT_NAME}_static
${CMAKE_REQUIRED_LIBRARIES}
- ${ALL_LIBRARIES})
+ ${ALL_LIBRARIES}
+ atomic)