mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/fsarchiver
This commit is contained in:
parent
2bfcbaf92d
commit
1772dd26b2
2 changed files with 83 additions and 0 deletions
36
extra/fsarchiver/PKGBUILD
Normal file
36
extra/fsarchiver/PKGBUILD
Normal file
|
@ -0,0 +1,36 @@
|
|||
# $Id$
|
||||
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix conflicting type definitions (fixes AArch64 build) (thanks Fedora)
|
||||
|
||||
pkgname=fsarchiver
|
||||
pkgver=0.6.20
|
||||
pkgrel=1
|
||||
pkgdesc='Safe and flexible file-system backup and deployment tool'
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://www.fsarchiver.org/'
|
||||
license=('GPL2')
|
||||
depends=('bzip2' 'e2fsprogs' 'lzo' 'xz' 'libgcrypt')
|
||||
source=(https://github.com/fdupoux/fsarchiver/releases/download/$pkgver/fsarchiver-$pkgver.tar.gz
|
||||
fsarchiver-0.6.19-do-not-duplicate-types.patch)
|
||||
md5sums=('04d73f8f8e8dd0063e06f74a125bdcb6'
|
||||
'009bafd9ec764dc2863e18742992bc45')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i ../fsarchiver-0.6.19-do-not-duplicate-types.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
./configure --prefix=/usr --sbindir=/usr/bin
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
|
@ -0,0 +1,47 @@
|
|||
diff --git a/src/fs_btrfs.h b/src/fs_btrfs.h
|
||||
index e2461f3..923e7f5 100644
|
||||
--- a/src/fs_btrfs.h
|
||||
+++ b/src/fs_btrfs.h
|
||||
@@ -18,6 +18,8 @@
|
||||
#ifndef __FS_BTRFS_H__
|
||||
#define __FS_BTRFS_H__
|
||||
|
||||
+#include <linux/types.h>
|
||||
+
|
||||
struct s_dico;
|
||||
struct s_strlist;
|
||||
|
||||
diff --git a/src/fs_xfs.h b/src/fs_xfs.h
|
||||
index ee3c53d..17d0d5e 100644
|
||||
--- a/src/fs_xfs.h
|
||||
+++ b/src/fs_xfs.h
|
||||
@@ -18,6 +18,8 @@
|
||||
#ifndef __FS_XFS_H__
|
||||
#define __FS_XFS_H__
|
||||
|
||||
+#include <linux/types.h>
|
||||
+
|
||||
struct s_dico;
|
||||
struct s_strlist;
|
||||
|
||||
@@ -36,8 +38,6 @@ typedef uint16_t __u16;
|
||||
typedef int16_t __s16;
|
||||
typedef uint32_t __u32;
|
||||
typedef int32_t __s32;
|
||||
-typedef uint64_t __u64;
|
||||
-typedef int64_t __s64;
|
||||
|
||||
typedef __uint32_t xfs_agblock_t; /* blockno in alloc. group */
|
||||
typedef __uint32_t xfs_extlen_t; /* extent length in blocks */
|
||||
diff --git a/src/types.h b/src/types.h
|
||||
index b69dfd7..a18e139 100644
|
||||
--- a/src/types.h
|
||||
+++ b/src/types.h
|
||||
@@ -34,7 +34,6 @@ typedef int64_t s64;
|
||||
|
||||
typedef uint16_t __le16;
|
||||
typedef uint32_t __le32;
|
||||
-typedef uint64_t __le64;
|
||||
|
||||
#define le8_to_cpu(v) (v)
|
||||
#define cpu_to_le8(v) (v)
|
Loading…
Reference in a new issue